LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-26-2005, 08:12 AM   #1
bnj
Member
 
Registered: Apr 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 70

Rep: Reputation: 15
temporarily disable automount


I tried to burn a data-dvd using k3b. It failed.
I have searched on google, and I have seen many people recommending to disable the automount feature while burning a DVD. So I would like to try it out.

So here is my question: how to temporarily disable the automount of DVDs on my system? Is there a better way then deleting (or commenting out) a line in /etc/fstab ?
I am usually very happy with this automount feature. I really want it disabled _only_ when I am trying to burn a DVD.

I am using SuSE 9.3 Professional.

Best regards,

Benjamin
 
Old 06-26-2005, 08:48 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Simple stop the autofs daemons or pid's. Usually its a /sbin/service autofs stop
 
Old 06-26-2005, 08:57 AM   #3
bnj
Member
 
Registered: Apr 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 70

Original Poster
Rep: Reputation: 15
Thank you trickykid for your answer, but could you please be a bit more specific?
I have tried to do a "ps -u root" and a "ps -u benjamin" but I could not find any process called "autofs" or anything alike.
I have cheked whether I have a file or programm called "/sbin/service", but I do not have it.

So how do I stop this deamon that you are talking about? (Do I have to call an exorcist ;-) ?)
And then, how do I restart it?

By the way, while searching on google, I have seen that in Mandrake, there is an easy GUI way to stop this automount service. Is there no such thing in SuSE?

Thank you,

Benjamin
 
Old 06-26-2005, 09:09 AM   #4
Jana Kazakh
LQ Newbie
 
Registered: Mar 2004
Location: Anglesey, Wales
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
As root, try "ps-A", this should list *all* processes on the system (mind out, if you're running an X server, you'll have a lot of them). Find autofs, and note the number to the left of it. then run "kill ####", where #### is the number you just looked up. This should do your exorcism for you. If you want to doublecheck, run "ps -A" again, autofs should be gone.

If you don't see it the first time round, autofs isn't running in the first place. You may have another daemon running (I don't know SuSe), but I'm about to step out of my depth here, so I'll stop.
 
Old 06-26-2005, 09:41 AM   #5
bnj
Member
 
Registered: Apr 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 70

Original Poster
Rep: Reputation: 15
well, I tried to type "ps-A", and it turns out I do not have a deamon called autofs.
Anybody knows the name of this deamon on SuSE?

Still, I would be happy if there was a solution other than killing a process.

thanks to all of you,

Benjamin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto disable automount feature in Mandrake 10.1 MJatIFAD Linux - General 6 09-27-2005 04:26 AM
Disable the Mandrake automount feature pinoez Linux - Newbie 6 06-10-2005 09:41 AM
Can I temporarily disable GRUB?? Tiyogi Linux - General 4 04-15-2005 08:15 AM
How to disable automount in Mandrake 10.1 deathbyswiftwin Linux - Hardware 3 04-11-2005 03:54 AM
Disable automount zokik Linux - General 5 12-07-2003 07:59 AM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration