LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2016, 01:12 PM   #1
arun natarajan
Member
 
Registered: Jun 2014
Posts: 96

Rep: Reputation: Disabled
telnet with port number is not working


hi,

After configuring postfix MTA on my server, not able to verify it with telnet command. Even other parameters are set accordingly. Still no success.


[root@node1 ~]# uname -a
Linux node1.cluster.com 2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@node1 ~]#


[root@node1 ~]# netstat -an | grep :25
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
[root@node1 ~]#


[root@node1 ~]# sestatus
SELinux status: enabled
SELinuxfs mount: /selinux
Current mode: permissive
Mode from config file: disabled
Policy version: 24
Policy from config file: targeted
[root@node1 ~]#


[root@node1 ~]# service iptables status
iptables: Firewall is not running.
[root@node1 ~]#


[root@node1 ~]# telnet 192.168.1.51 25
Trying 192.168.1.51...
telnet: connect to address 192.168.1.51: Connection refused
 
Old 08-15-2016, 01:17 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by arun natarajan View Post
hi,
After configuring postfix MTA on my server, not able to verify it with telnet command. Even other parameters are set accordingly. Still no success.

[root@node1 ~]# uname -a
Linux node1.cluster.com 2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@node1 ~]#

[root@node1 ~]# netstat -an | grep :25
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
[root@node1 ~]#

[root@node1 ~]# sestatus
SELinux status: enabled
SELinuxfs mount: /selinux
Current mode: permissive
Mode from config file: disabled
Policy version: 24
Policy from config file: targeted
[root@node1 ~]#

[root@node1 ~]# service iptables status
iptables: Firewall is not running.
[root@node1 ~]#

[root@node1 ~]# telnet 192.168.1.51 25
Trying 192.168.1.51...
telnet: connect to address 192.168.1.51: Connection refused
Did you actually START the postfix service????
 
Old 08-15-2016, 01:58 PM   #3
arun natarajan
Member
 
Registered: Jun 2014
Posts: 96

Original Poster
Rep: Reputation: Disabled
yes, its running

[root@node1 ~]# service postfix status
master (pid 13970) is running...
 
Old 08-15-2016, 02:32 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by arun natarajan View Post
yes, its running

[root@node1 ~]# service postfix status
master (pid 13970) is running...
Ok...and did you follow the basic postfix guide, and tell the system what interface to listen on? I notice it's only listening on 127.0.0.1...and you're trying to telnet to a different address.
http://www.postfix.org/BASIC_CONFIGURATION_README.html

Change the "inet_interfaces" directive to be ALL, or the address of your active interface.
 
1 members found this post helpful.
Old 08-15-2016, 04:54 PM   #5
/dev/random
Member
 
Registered: Aug 2012
Location: Ontario, Canada
Distribution: Slackware 14.1, LFS-current, NetBSD 6.1.3
Posts: 261

Rep: Reputation: 101Reputation: 101
iptables -L
iptables -F INPUT
iptables -F OUTPUT
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT

If its not a configuration issue, check the firewall.
 
Old 08-16-2016, 08:16 AM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by /dev/random View Post
iptables -L
iptables -F INPUT
iptables -F OUTPUT
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT

If its not a configuration issue, check the firewall.
He already did that, and posted in the first post...iptables isn't running at all, neither is SELinux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Port number used by server when using dynamic port forwarding in SSH? kreeder Linux - Networking 4 11-21-2011 03:07 PM
telnet to port 25 not working from outside showe123 Linux - Server 34 04-03-2011 12:51 PM
PLESK [Solution] Change port to 23 (telnet) instead of default port 8443 x5452 Linux - Software 6 05-10-2009 06:58 AM
USB to serail port adaptor COM port number areftaidi Linux - Software 2 09-25-2007 02:05 AM
Able to change port number between telnet and ssh? x5452 Linux - General 3 03-28-2004 06:04 PM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration