LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2002, 11:53 PM   #1
matrim
Member
 
Registered: Dec 2002
Location: utah
Distribution: Redhat; Fedora 2, 6
Posts: 114

Rep: Reputation: 15
Question telnet into my machine?


What needs to be activated so that I or others can telnet/access my box? I remember something about selecting ftp/telnet and firewalls at the time of installation..I have a router setup so when I do a ifconfig, it's connected to the internet via broadband and the router with the addy of 192...etc, but when I try to access the computer from another it won't connect. Is the router causing the problem?

thanks for any/all help


Big -------------->


G

Last edited by matrim; 12-12-2002 at 01:40 AM.
 
Old 12-12-2002, 12:08 AM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
can u ping both ways? was the telnet-server package installed? if yes, you need t0:

1. enable telnet:

/sbin/chkconfig telnet on

2. set you firewall ruleset to allow incoming telnet connections:

lokkit

This is the basic stuff you need to look at first.
 
Old 12-12-2002, 12:25 AM   #3
kausik
LQ Newbie
 
Registered: Feb 2002
Location: Baruipur, India
Distribution: Red Hat 9.0
Posts: 29

Rep: Reputation: 15
If you are on RH7.1 or above
-------------------------------------
Open /etc/xinetd.d/telnet

You will find the following lines:

service telnet
{
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
** disable = yes
}

Change to "disable=no" on the ** ed line.

Look at /etc/services for "telnet".

If you do not find two lines
====
telnet 23/tcp
telnet 23/udp
====
add them.

Thats all to connect to a box via telnet.

Regds,
Kausik
 
Old 12-12-2002, 01:03 AM   #4
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
Whoa, another Utah guy. Small world. Lokkit isn't included in Red Hat 8.0 though, instead use:

system settings-> security level

if you're not logged in as root, you'll have to type your password, I think you said that you enabled telnet when installing, but it never hurts to check.

also, try 'telnet 127.0.0.1 port' (where port is the port you wish to use) to see if you can telnet the box from the box.
 
Old 12-12-2002, 02:25 AM   #5
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
Quote:
Originally posted by KnightAbel
Lokkit isn't included in Red Hat 8.0 though, instead use:

system settings-> security level

lokkit is still in 8.0:

Searching for lokkit...
CD-1:lokkit-0.50-18.i386.rpm
CD-3:gnome-lokkit-0.50-18.i386.rpm
SOURCE-CD-2:gnome-lokkit-0.50-18.src.rpm
 
Old 12-12-2002, 02:27 AM   #6
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
Quote:
Originally posted by kausik
If you are on RH7.1 or above
-------------------------------------
Open /etc/xinetd.d/telnet

You will find the following lines:

service telnet
{
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
** disable = yes
}

Change to "disable=no" on the ** ed line.
you need to restart xinetd after doing this.

/sbin/service xinetd restart

But /sbin/chkconfig telnet on does this in one step with Red Hat 7.x/8.0 releases
 
Old 12-12-2002, 02:27 AM   #7
matrim
Member
 
Registered: Dec 2002
Location: utah
Distribution: Redhat; Fedora 2, 6
Posts: 114

Original Poster
Rep: Reputation: 15
Okay, thanks for the input all!
- For some reason my redhat 8.0 has lokkit, which i ran, but after selecting telnet and even no firewall, the menu reverts back to high security status...in other words its not saving my changes for some reason. With that said, I can telnet out, but can't telnet my local address, so the firewall needs to be fixed..i tried a couple of your suggetions..the -chkconfig telnet on- gave me...error reading information on service telnet: No such file or directory..

Opening /etc/xinetd.d i found no file named telnet either..as for /etc/services i did find telnet 23/tcp
telnet 23/udp
 
Old 12-12-2002, 04:55 AM   #8
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
well, telnet-server is not installed. You need that to server telnet connections.

in RHL 8.0: CD-2:telnet-server-0.17-23.i386.rpm

Or use redhat-config-packages if you want.
 
Old 12-12-2002, 08:16 AM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
If your telnet isn't installed don't even bother with it, use ssh instead. Telnet is very insecure.

www.openssh.org
 
Old 12-12-2002, 01:19 PM   #10
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
Quote:
Originally posted by born4linux
lokkit is still in 8.0:

Searching for lokkit...
CD-1:lokkit-0.50-18.i386.rpm
CD-3:gnome-lokkit-0.50-18.i386.rpm
SOURCE-CD-2:gnome-lokkit-0.50-18.src.rpm
well, it's not installed in mine for some reason then, or maybe it is. I'll have to check more completely. But yeah, sorry.
 
Old 12-13-2002, 09:17 PM   #11
matrim
Member
 
Registered: Dec 2002
Location: utah
Distribution: Redhat; Fedora 2, 6
Posts: 114

Original Poster
Rep: Reputation: 15
Just wanted to say thanks to all for the help. This place rocks. The linux box is up and running now pretty smoothly, now, on to other things! (see new question)
 
Old 12-18-2002, 12:55 PM   #12
matrim
Member
 
Registered: Dec 2002
Location: utah
Distribution: Redhat; Fedora 2, 6
Posts: 114

Original Poster
Rep: Reputation: 15
Sigh,
I spoke too soon . It seemed I could telnet my box from my box and from a computer on the same network, but when trying to telnet from out of town or another comp etc it didnt work. I changed all the settings to allow incoming telnets. I did notice that when I changed the security level of the firewall to medium and customized to allow telnet, I clicked okay, but tried again with no luck. I checked the security lvl yet again, and for some reason it reverted back to high security firewall with nothing checked including telnet. Is there a way to permanently change this? I've tried in gnome and lokkit both and both revert back to previous settings..



Last edited by matrim; 12-18-2002 at 10:17 PM.
 
Old 12-18-2002, 10:16 PM   #13
matrim
Member
 
Registered: Dec 2002
Location: utah
Distribution: Redhat; Fedora 2, 6
Posts: 114

Original Poster
Rep: Reputation: 15
***
Okay, I neglected to mention that we have a wireless router and my linux box is going through that. That is probably my problem, although I did not have telnet set up in the first place so thanks for helping get that up. So..i have a network address i guess. How can I set that up so i can access from a comp off the network?
 
Old 12-19-2002, 08:46 PM   #14
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,931

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Depending on your router you will need to sets its configuration to allow telnet traffic through to your linux pc. For Linksys routers this requires a static IP for the PC. Setup port forwarding for whatever port and IP you are using.

Assuming you have a dynamic IP you can use one of the many free dynamic ip servers like www.noip.com. A client program on your PC will update the server with your IP address and assigns a hostname (of your choice) to it. Now the rest of the world can access your PC.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to copy files from another machine to the local machine using telnet,..how? shrike_912 Programming 6 03-14-2006 05:45 PM
telnet to solaris machine from windows mjunaidy Solaris / OpenSolaris 2 08-30-2005 07:17 AM
Telnet to debian machine dun_noe Debian 6 10-30-2004 07:17 AM
How can I telnet into slackware from a win98 machine karlena Slackware 0 10-31-2003 03:45 PM
No telnet server on my machine Zingaro2002 Linux - Networking 3 01-23-2003 07:12 AM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration