LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-12-2014, 08:13 AM   #1
The Old Crab
LQ Newbie
 
Registered: Sep 2009
Location: Eastern Pennsylvania
Distribution: Ubuntu 12.04
Posts: 14

Rep: Reputation: 0
Telnet - How to suppress local echo on Linux server


This takes some explanation. We have a large number of network routers, switches and appliances with their console ports connected to a Cyclades (Avocent ACS 6000 series). Our network ops staff connects to these devices through a Linux jump server which allows the tech to select the desired device from a menu, and then Telnets to the IP address associated with that network device on the Cyclades.

The problem is that the Avocent ACSes are new boxes, replacing older equipment that was end-of-life. On the new Avocents, most (but not all) of the network devices now exhibit a local echo (lliikkee tthhiiss), which did not happen before. Everyone says this can be turned off via a Telnet setting, but no one seems to know exactly how to do this. I've read through the MAN page for Telnet several times now, but like all good Linux documentation, it tells you how to use it without telling you how to use it. There's no command line switch that says "don't do local echo". The server is running GNU bash, version 3.1.7(1)-release (i386-redhat-linux-gnu).

There do seem to be Telnet session commands like "unset echo" that you can enter. So I tried using a here document like this:

telnet << EOB
unset echo
open 172.16.0.1
EOB

All this gets me is "Connection closed by remote host". In fact, anything else OTHER than the "open" statement in the here document produces this result, so there's no benefit over just issuing a straight "Telnet 172.16.0.1" command.

I don't understand why changing to a newer Avocent produced this result, and I don't understand why some devices do not emit a local echo. All I know is I've spent 2 days researching this and haven't found a thing. I hope someone here can help.

Additional information:

telnet> status
Connected to 10.64.37.176 (10.64.37.176).
Operating in single character mode
Catching signals locally
Local character echo
No flow control
Escape character is '^]'.
telnet>

So it knows local echo is set; how do I disable local character echo? The local character echo signal is Ctrl-E, but entering Ctrl-E does nothing. I thought it might act as a toggle, but as I say, it seems to do nothing.

Last edited by The Old Crab; 12-12-2014 at 09:02 AM. Reason: Add information
 
Old 12-12-2014, 08:59 AM   #2
The Old Crab
LQ Newbie
 
Registered: Sep 2009
Location: Eastern Pennsylvania
Distribution: Ubuntu 12.04
Posts: 14

Original Poster
Rep: Reputation: 0
Further details:

telnet> status
Connected to 10.64.37.176 (10.64.37.176).
Operating in single character mode
Catching signals locally
Local character echo
No flow control
Escape character is '^]'.

So, how do I disable local character echo? The local character echo signal is Ctrl-E, but entering Ctrl-E does nothing.
 
Old 12-12-2014, 11:13 AM   #3
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
This link may help.

-->http://stackoverflow.com/questions/1...ess-local-echo
 
Old 12-13-2014, 12:19 AM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,599

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
It sort of sounds like what the manpage calls "old line by line"
According to the telnet manpage, you can try "toggle localchars" (or unset).

If it is enabled, it will disable it. If it is disabled (should be the default) it will enable it.

There should be a message about the resulting state.
 
Old 12-15-2014, 12:49 PM   #5
The Old Crab
LQ Newbie
 
Registered: Sep 2009
Location: Eastern Pennsylvania
Distribution: Ubuntu 12.04
Posts: 14

Original Poster
Rep: Reputation: 0
To camorri: didn't help. I'm not writing code, I just want to (somehow) pass a setting to disable this.

To jpollard: tried this, problem remains.
 
  


Reply

Tags
telnet


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
echo local console to a telnet session fred?@yhti.net Linux - Newbie 3 02-10-2013 01:01 PM
Apache LDAP auth with local users - getting warnings - possible to suppress? laggerific Linux - Software 1 08-18-2009 07:32 PM
Unable to telnet to Linux Host inspite of installing telnet-server RPM - Need Help sinamdar Linux - Software 7 04-11-2009 08:09 AM
How to suppress "\M" when using echo command oskeewow Linux - Newbie 3 04-14-2008 02:05 AM
Linux Telnet Server + Echo Celeron463 Linux - Software 3 12-17-2003 04:08 PM


All times are GMT -5. The time now is 11:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration