LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2008, 09:55 AM   #1
jhilton
LQ Newbie
 
Registered: Jun 2008
Posts: 29

Rep: Reputation: 15
Telnet Configuration


Hello! I am trying to configure a telnet server but I am unable to have any client connect to it over telnet. I am only using telnet because I am unable to use SSH at the moment and there are no external connections to the network with all the machines that want to telnet to another network.

I first started with creating hosts.allow and hosts.deny.
In hosts.allow I have
Code:
in.telnetd: ALL
And in hosts.deny I have
Code:
ALL EXCEPT in.telnetd: ALL
Can anyone tell me if I have this setup correctly?

I also tried configuring pam thinking it would play some role with telnet connections. I've changed my /etc/pam.d/other file to have it be similar to the SSHD file. So it looks like

Code:
#%/PAM-1.0
auth     required pam_shells.so
auth     required pam_nologin.so
auth     include  system-auth
account  include  system-auth
password include  system-auth
session  include  system-auth
However I am starting to think that telnet is not affected by pam because even with this configuration a connection with telnet can not still be made.I have also looked into possibilities of SElinux blocking connections but I am unable to find any traces of the security enchancements on the machine. Any ideas as to why this is not connecting?
 
Old 07-01-2008, 10:06 AM   #2
vishnu_sreekumar
Member
 
Registered: Jan 2006
Location: India
Distribution: Ubuntu, RHEL, Debian
Posts: 49

Rep: Reputation: 20
Hi
Are you trying to login as root? If yes, you need to add pseudo terminals in the /etc/securetty file. Open the file /etc/securetty in your favorite editor and add

pts/0
pts/1
.
.
(you can add as many as you want)
 
Old 07-01-2008, 11:06 AM   #3
jhilton
LQ Newbie
 
Registered: Jun 2008
Posts: 29

Original Poster
Rep: Reputation: 15
This actually worked... Sort of.

When I try to let the xinetd take care of telnet I get hung up and it disconnects me before I get prompted to login. Now, if I run this command from the console...


/usr/sbin/in.telnetd -n -debug 23

Now if I try to telnet from a client computer to the server I will be able to connect and everything else. Why can't I connect when I use the xinetd?
 
Old 07-01-2008, 11:12 AM   #4
vishnu_sreekumar
Member
 
Registered: Jan 2006
Location: India
Distribution: Ubuntu, RHEL, Debian
Posts: 49

Rep: Reputation: 20
sorry, didn't quiet understand your question. can you explain it?
 
Old 07-01-2008, 11:16 AM   #5
jhilton
LQ Newbie
 
Registered: Jun 2008
Posts: 29

Original Poster
Rep: Reputation: 15
Humm.... I'll try. Right now on my server I ran the command /usr/sbin/in.telnetd -n -debug 23. This starts the telnet daemon on port 23 and does not shutdown when there is idle. I now go to my client computer and attempt to login to the server, I can login everything is fine.

However, when I try to do the same thing but using the xinet daemon by doing /etc/init.d/xinetd start. xinetd is supposed to handle all telnet, RSH, rlogin and rexec daemons. When I start the xinetd server I am unable to login at all through telnet.

I was wondering why xinetd does not work but if I start the telnet server manually it does.
 
Old 07-01-2008, 11:25 AM   #6
vishnu_sreekumar
Member
 
Registered: Jan 2006
Location: India
Distribution: Ubuntu, RHEL, Debian
Posts: 49

Rep: Reputation: 20
have you edited the telnet configuration file?

/etc/xinetd.d/telnet

Enable telnet using this file and restart xinetd service.
Also do a "chkconfig telnet on" if you want the telnet service to be persistant over reboot.
 
Old 07-01-2008, 11:42 AM   #7
jhilton
LQ Newbie
 
Registered: Jun 2008
Posts: 29

Original Poster
Rep: Reputation: 15
I did modify /etc/xinet.d/telnet to say it is enabled. It still did not and has not work for sometime now.
 
Old 07-01-2008, 11:26 PM   #8
vishnu_sreekumar
Member
 
Registered: Jan 2006
Location: India
Distribution: Ubuntu, RHEL, Debian
Posts: 49

Rep: Reputation: 20
Can't figure out why this happens. try reloading xinetd. may be someone else in this forum can help you. If possible post the error message you get (if any).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
telnet configuration A.Sai Hareesh Linux - Newbie 3 06-28-2008 08:19 PM
Telnet configuration sci3ntist Debian 2 05-22-2007 04:40 PM
telnet configuration reena Linux - Networking 2 01-24-2007 11:58 PM
configuration for telnet sunhui Linux - Security 1 09-08-2006 01:25 PM
Telnet configuration Paasan Linux - Networking 1 09-16-2002 05:54 PM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration