LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-16-2004, 07:46 PM   #1
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
Question talk to USB


mount -l tells me (I think) that USB devices are mounted -
usbdevfs on /proc/bus/usb type usbdevfs (rw)


How can I manually copy (cp) a file to/from the flash/thumb/keyring drive plugged in at the other end of the cable?
TIA
 
Old 02-16-2004, 09:00 PM   #2
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
Re: talk to USB

Quote:
Originally posted by verstapp
mount -l tells me (I think) that USB devices are mounted -
usbdevfs on /proc/bus/usb type usbdevfs (rw)


How can I manually copy (cp) a file to/from the flash/thumb/keyring drive plugged in at the other end of the cable?
TIA
have you tried cd to the directory where the device is and then cp the file to the new directory?
 
Old 02-16-2004, 09:16 PM   #3
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
The devices are mounted there. The filesystem that is on your flash drive is not. In order to copy files to/from your flash drive, you need to find out what device it is (use (as root) fdisk -l (that is a lowercase L) to find out) and mount that. If you have no other USB storage devices, or any other SCSI devices, then you should be safe with mount -t vfat /dev/sda1 /mnt/usbdrive (please ensure the directory /mnt/usbdrive exists before issuing this command).
 
Old 02-17-2004, 12:07 AM   #4
globeTrotter
Member
 
Registered: Feb 2004
Location: Townsville, Queensland, Oz
Distribution: Red Hat 9
Posts: 107

Rep: Reputation: 15
once you have created the /mnt/usbdrive directory you could place a line at the end of your fstab file, which is in the /etc directory. (do all this stuff as root!)

/dev/sda1 /mnt/usbdrive vfat noauto,user 0 0

this alows you to place an icon on your dektop. i use KDE. right click on the desktop, add new drive. choose /dev/sda1 from the dropdown list, choose the icons and away you go. put your usb device in the slot, then double click on the icon and its mounted. you should see a folder open in the browser with all your files in. dont forget to right click on the icon and unmount when finished.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Talk Joe2003 Linux - Newbie 3 10-18-2005 03:39 PM
talk talk daemon configuration ananthkrk Red Hat 1 10-16-2004 11:45 AM
Using Talk twantrd Linux - General 4 08-28-2003 05:21 PM
Talk me through how to do this. Tayste_2000 Linux - Newbie 7 07-06-2002 12:52 PM
why cannot "talk" to others,since mesg is yes and disable = no(in /etc/xinetd.c/talk) whepin Linux - Newbie 0 12-31-2001 02:04 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration