LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-07-2005, 12:32 PM   #1
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Rep: Reputation: 35
System Time keeps going back to Moscow


Hiya all

Been happening since I installed Knoppix, nows its really getting to me!

My system time keeps defaulting to Moscow. I right click>Adjust Date and Time, change it all to GMT etc etc, but next time I log on it is back to Moscow. All good if I lived in Moscow but...

Help!

Thanks

Hong
 
Old 03-07-2005, 01:40 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
You need to adjust the system time settings as root to make the changes system wide.
 
Old 03-07-2005, 01:55 PM   #3
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
But it asked me for the root password....so I thought I was 'Acrting Root' whilst that window was open...

Am I not right in thinking that?
 
Old 03-07-2005, 09:43 PM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
If I remember my knoppix correctly you need to type 'su' first to enter root mode. There may be a gui app similar to drakconf that runs as root and allows you to change the system time amongst other things.
 
Old 03-08-2005, 03:00 PM   #5
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Well I logged in as root, changed the time but when I log back in as Me it still goes back to Moscow.

Any ideas?
 
Old 03-08-2005, 03:29 PM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try running tzconfig as root.
 
Old 03-08-2005, 04:01 PM   #7
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Just tried it, still no go. tzconfig as root and as Me says the timezone is Europe/London, which is correct but it still displays Moscow.

Am I the only one with this problem?
 
Old 03-08-2005, 04:05 PM   #8
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
I think i have solved it.

I simply right clicked on the clock>Show Timezones>Local Timezone.

I reconfigured the correct time and logged off, logged back on and it is still correct.

Fingers crossed!!

Thanks to all those that helped


Hong
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Back in Time? mykrob Linux - General 6 07-28-2004 02:17 PM
It's my time to give back! ipn1nj4 LinuxQuestions.org Member Intro 1 06-11-2004 04:08 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
Raid Over Moscow Bobas200 Linux - Hardware 1 09-04-2002 10:16 AM
Updating System time from some Inet time server Steave Linux - General 6 12-21-2001 03:12 PM


All times are GMT -5. The time now is 05:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration