LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2010, 01:29 AM   #1
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Rep: Reputation: 16
system sound not working on new user account


Hello folks, I am running Debian Lenny with the default Gnome desktop. When I set up a new user the sound is not available. It says the device in not installed. I have used the Gnome system menu as follows.

System, Administration, Users and Groups, then used the add user button and entered the appropriate info. I then went and clicked on the properties button and then the User Privileges section and checked off the "use audio devices" button. Still no sound. When I go to System, Preferences, Sound, Devices, and do the sound tests I get report that device is not installed.

When I am logged in to the user (jon) that I set up when doing the D.Lenny install, the sound on all various media play back works fine.

There is one with 1 exception when loged in to this user(jon). I can not get any sound from the system sounds like select check box = toggle .wav, chose menu item = beep, etc. It would be realy nice to know how to repair or configure tis issue as well.

under system info, pci devices it lists as follows Multimedia audio controller, Intel Corp 82801FB/FBM/FR/FW/FRW. Mother board is a ECS 915P-A2 and I guess about 2007 or so vintage. 1 G mem installed and a P-4 2.66 chip. It has the sound built in to it. It works fine on WinXP.

Direction on either of these issues would be greatly appreciated, Jon
 
Old 01-10-2010, 02:29 AM   #2
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
hi

well you did not mention which groups you added for relevant user so post the results to this pls

su loginname (input passwd for each relevant user)
goups

for me I get
groups
gordy dialout cdrom floppy audio dip video plugdev users scanner netdev vboxusers powerdev fuse

cdrom audio video are the basic sound ones.

2) I don't use gnome but suggest you install alsa-utils which has alsamixer....for each user....in the terminal run


alsamixer

check each user for muting and volumes

press m to mute or unmute ....page up /down or arrow keys to adjust volumes...press escape to exit.
 
Old 01-13-2010, 02:36 AM   #3
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Original Poster
Rep: Reputation: 16
Ok, I have not done anything about groups when I originally set up new user "jill" simply just added a user though gnome desktop. I went back and looked where I created the new user account and it shows root, jon and jill with proper home directories.
To the right there are 4 buttons, add user, properties, delete and manage groups. I was able to go into properties, user privileges and switched on "use audio devices button" and I got the sound to work with most programs and games. the default when I set up the new account had no boxes checked off, obviously this was my major problem.

Still no system sounds for either my account or the jill account. I have taken your advice and ran button from command prompt. It gives more control than the default gnome speaker volume settings icon. I played with all the items, un muting etc. and still no system sounds. I am to make an assumption that gnome is resposible for the system sounds as there is a window to configure and a help button that I have exhausted already.

There is as mentioned previously a button called "Manage groups". Just trying to make sense of it as when I goto properties on "jon" there are the 3 users, root, jill and jon. none of the check boxes are checked off and why in my user name in my group members. If one opens it there is a list of what I comprehend as as groups. They range from the same names as when I type root from the command prompt and others. Interestingly included are "root" "jon" and "jill" If I click on each and then select properties button it gives a short list of the users I have set up including "root". All have a box that can be checked but there are no checks in any boxes including when I do properties for "root". the exceptions are powerdev had both jon and jill's check box already checked off. This is the first time I have been here.

I would like some advice on what should be or what not should be checked off for users in " group settings" for each group.

Here are the reports from running "groups" from command prompt


groups as my regular log in as follows


jon@debianlenny:~$ groups
jon adm dialout fax cdrom floppy tape audio dip video plugdev scanner netdev lpadmin powerdev
jon@debianlenny:~$


groups as loged in as root (su)


jon@debianlenny:~$ su
Password:
debianlenny:/home/jon#



groups as logged in as jill

jill@debianlenny:~$ groups
jill fax cdrom audio vidio scanner netdev



I found another utility in the gnome desktop that reports some info on the "alsa-utils" as follows


from gnome desktop menu bar

Service Settings, Audio settings managment (alsa-utils)


Setting for service "alsa utils"
runlevel status priority
0 stop 50
1 ignore -1
2 start -1
3 ignore -1
4 ignore -1
5 ignore -1
6 stop 50


Not too slick yet with working at the command promt and a bit intimidated as fear of messing something up. i'll get there.

Any help greatly appriciated, Jon
 
Old 01-13-2010, 04:13 AM   #4
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
oh by system sounds you don't mean the beep?

Code:
lsmod | grep pcspkr
If you do not get a hit, look at /etc/modprob.d...some blacklist.conf type file for that module...I do not have your distro so can not tell you exact file name.

if you find it blacklist remove it or add a # using root powers, reboot and test.

hope that helps?
 
Old 01-19-2010, 02:10 AM   #5
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Original Poster
Rep: Reputation: 16
Pc speaker works fine. I just can not seem to make the system sounds normaly played through the sound card function at all. These are the ones that report a particular .wav file noise for specified actions that users can configure. Some as follows, select check box, chose menu item, click on command button, error message log out, log in Etc. The menu is avalable in the gnome desktop as stated earlier in this thread. When in Gnome desktop selecting "System" \ "Sound" \ " Sound preferences" \ "Sounds", one can configure these .wav files to play upon said actions. One can also test the sound in this window and the selected .wav file does not play when I test. The menu is not blanked out and the button to test each sound apears to activate when one clicks on it. When in the sound preferences window (previous button) the first option is "Devices". I have tried all available as follows. AUTODETECT, INTEL ICH6-IEC958, INTEL IECH6, ALSA ADVANCED LINUX SOUND ARCHETECTURE, OSS OPEN SOUND SYSTEM. There is a test button in this window and a sample tone is reported with each and all choices.


All other sound such as watching DVD movies, various games, music play back using rythem box and others work excelent.

I checked and experimented with the alsa mixer console and am sure I do not have any channels muted as previously suggested. I set volume to max on all relivent channels as well. exceptions are channels I do not use such as Mic, Mic Boos, phone and such, I even tried them as well jus to see but switched them back to default. These system sounds work perfectly when I boot Xandros 4.5 OCE. Xandros usees KDE but the configuration is basicly the same. Perhaps firmware is neded as this has been the situation with my wireless card?

Here is a copy of my blacklist, I do not see anything I would associate with system sound, please review if possible.

# This file lists modules which will not be loaded as the result of
# alias expansion, with the purpose of preventing the hotplug subsystem
# to load them. It does not affect autoloading of modules by the kernel.
# This file is provided by the udev package.

# evbug is a debug tool and should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# replaced by tmscsim
blacklist am53c974

# watchdog drivers should be loaded only if a watchdog daemon is installed
blacklist acquirewdt
blacklist advantechwdt
blacklist alim1535_wdt
blacklist alim7101_wdt
blacklist booke_wdt
blacklist cpu5wdt
blacklist eurotechwdt
blacklist hpwdt
blacklist i6300esb
blacklist i8xx_tco
blacklist ib700wdt
blacklist ibmasr
blacklist indydog
blacklist ixp2000_wdt
blacklist ixp4xx_wdt
blacklist it8712f_wdt
blacklist iTCO_wdt
blacklist machzwd
blacklist mixcomwd
blacklist mpc8xx_wdt
blacklist mpcore_wdt
blacklist mv64x60_wdt
blacklist pc87413_wdt
blacklist pcwd
blacklist pcwd_pci
blacklist pcwd_usb
blacklist s3c2410_wdt
blacklist sa1100_wdt
blacklist sbc60xxwdt
blacklist sbc7240_wdt
blacklist sbc8360
blacklist sbc_epx_c3
blacklist sc1200wdt
blacklist sc520_wdt
blacklist scx200_wdt
blacklist shwdt
blacklist smsc37b787_wdt
blacklist softdog
blacklist w83627hf_wdt
blacklist w83697hf_wdt
blacklist w83877f_wdt
blacklist w83977f_wdt
blacklist wafer5823wdt
blacklist wdt285
blacklist wdt977
blacklist wdt
blacklist wdt_pci





Everyones efforts are appriciated, Thanks, Jon

Last edited by Elixer; 01-19-2010 at 02:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse user account stopped working linuxlainen Linux - Newbie 1 10-29-2006 06:41 PM
system account or user account??? yenonn Linux - Newbie 6 05-10-2006 08:49 PM
is it legitimate and allowed and can be done to make another user account set uid and gid to null 0 to make another root account with different name and possibly not damage the debian system creating and using that new account BenJoBoy Linux - Newbie 12 01-29-2006 11:02 AM
User Account suddenly stopped working NanoGeek Linux - General 1 12-29-2005 10:29 AM
sound only working on my account mraray Linux - Software 3 11-26-2005 08:37 AM


All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration