LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   System freezes in X (http://www.linuxquestions.org/questions/linux-newbie-8/system-freezes-in-x-103842/)

shaun_bakker 10-14-2003 12:07 PM

System freezes in X
 
I am running a K6-2 500MHz system with a VooDoo3 video card, and a usb Logitech mouse. I installed debian 3.0r1 with the 2.4 kernel option. After installation, x wouldn't start. I realized this was due to it not being installed. I installed xserver-common and xserver-xfree86, and then got x to start. But, my system accepts no input from the keyboard or mouse after x starts. Not to reboot or switch terminals. Now, My system loads gdm (and the x server) upon bootup and I don't know how to stop/change that.

So, 2 questions:

1. How can I keep my system from loading gdm on startup?
2. How do I fix the freezing problem once I do?

lugoteehalt 10-14-2003 01:44 PM

Don't quite understand but if the problem is you can't get out of X to a black screen because when you logout of X it immediately starts up again. Then perhaps you could try starting top inside a terminal emulator, eg xterm. Then hit k and it says 'which pid to kill?'. You type the pid, the number to the far left of gdm. Then return. Then return again. If that doesn't work instead of the last return do TERM return. If that doesn't then KILL return.

This kills gdm and you go to the black screen with alt-ctrl-F1 say.

Then fiddle about to stop it buggering up at starup - hours of joy.

TigerOC 10-14-2003 02:18 PM

Use Ctrl+Alt+Backspace to exit from X. To setup the keyboard, screen and mouse you need to do dpkg-reconfigure xserver-xfree86 from the console. This will take you through a menu driven system whereby your hardware settings will be configured. Before you start get the the hsync and vsync settings for your monitor.

shaun_bakker 10-14-2003 05:30 PM

Clarification
 
OK, so to clarify, the first problem is that my system is completely useless because at boot time, it automatically starts gdm, and I haven't been able to stop it. Once in gdm, the system becomes unresponsive to the keyboard and the mouse. This means I can't use ctrl-alt-backspace to et out of X, or even alt-ctrl-del to reboot. Everytime, I have to use a hard reboot. Any ideas on how to get my system from starting gdm so I can actually have a prompt to work from?

TigerOC 10-15-2003 01:34 AM

Apart from doing a re-install you have 2 options;
1. get Knoppix mount your drive and edit /etc/X11/XFree86Config-4 with at least your keyboard type.
2. Try doing the same with your install cd under rescue. (I don't think this will work because it loads the kernel from the drive and then continues the boot process).

shaun_bakker 10-15-2003 07:37 AM

Done and done
 
> 1. get Knoppix mount your drive and edit /etc/X11/XFree86Config-4 with at least your keyboard type.

I had this same thought, but instead decided to just do an HD install of knoppix. For anyone who wants debian, but doesn't have the time to put up with all the hardware config, this is a great answer. Worked perfectly for me, including my usb mouse which is something that debian had problems with. Now, I can take my time and personalize my system as I like.

Thanx!

:D

lugoteehalt 10-15-2003 12:12 PM

For completeness as 'twere:

Could have started in single user mode, 'failsafe', runlevel ?1. This, I assume, is what you are supposed to do.

Shadow_7 06-06-2007 07:23 AM

Well, if you could get into the system you have a few options. The main clincher being able to uninstall gdm, kdm, wdm, xdm, or whatever is starting X at boot. Debian boots into run level 2, but runs X if you have any of those or probably some others installed.

Option 1) If your keyboard was responsive you could Cntrl+Alt+Backspace several times until the ?dm gives up the ghost and puts you in a console. About 15 or so times. This doesn't work for all distros as init is geared to restart it indefinitely, except on debian.

Option 2) From an xterm, just killall ?dm, where ? is the alphanumberic associated with your ?dm and not ?.

Once out of X uninstall the display manager and you'll boot into the console. At the next boot/reboot.

Option 3, the one that should work for you is to boot into recovery aka single mode. If you're running grub it's not that difficult if you know what you're doing. "c" at the menu (assuming you have enough delay to use the keyboard). Then type in the root/kernel parms from your grub.conf manually. Grub does have "help" as a command option. It even has tab completion so if you're not sure what exactly you named that thing, grub will help a fellow out. The kernel line should end something like root=/dev/hd?? ro single.

Option 4, boot into another linux (console only) and chroot into your linux installion. Then uninstall your ?dm (or disconfigure it) from your distrobution that way.

Needless to say I've had to do these a few times when I upgrade the video driver, but it doesn't quite go as planned. To vesa or not to vesa, that is the question. Although I've had a few chipsets where even vesa didn't want to work. (except in very specific DefaultDepth's and Modes)


All times are GMT -5. The time now is 11:41 AM.