LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-30-2008, 10:03 AM   #1
paullaubscher
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
symbolic link not allowed or link target not accessible


To whom it may concern


I am using SLES 10 SP1.1 , am getting an symbolic link error when executing a file to my Apache server see under mentioned.

[Wed Jul 30 14:55:04 2008] [error] [client 10.30.57.7 ] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/gwclnt/SetupIP.fil

I did an symbolic link to #ls -l setupip.fil SetupIP.fil and a
#chmod -R a+r * to give the user rights to execute the file to my Apache server.

Could somebody pls. tell me what I am I doing wrong ?


Paul
 
Old 07-30-2008, 10:34 AM   #2
ne pas
Member
 
Registered: Jul 2008
Posts: 55

Rep: Reputation: 23
May be you need to add +FollowSymLinks option to your Directory directive? See Apache Core Feautes - Options directive
 
Old 08-13-2008, 02:06 AM   #3
paullaubscher
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Original Poster
Rep: Reputation: 0
symbolic link error

Thanks

It is working

Paul
 
Old 10-19-2009, 01:26 PM   #4
cowanpf
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
I also have this problem

Quote:
Originally Posted by paullaubscher View Post
Thanks

It is working

Paul

Where did you put this in the httpd.conf file?
 
Old 03-10-2010, 07:47 AM   #5
pantera975
LQ Newbie
 
Registered: Mar 2010
Posts: 3

Rep: Reputation: 1
I know this is old but someone will find it useful if your SSL doesn't work but HTTP does

edit /etc/httpd/conf.d/ssl.conf and add it in there

<Directory "/var/www/html">
Options Indexes FollowSymLinks
AllowOverride None
Allow from from all
Order allow,deny
</Directory>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error 403 Forbidden symbolic link not allowed vree13 Linux - Software 8 02-14-2008 09:58 PM
How to create symbolic link to html file and avoid page link problem? haxpor Linux - General 2 01-29-2008 08:40 AM
Symbolic link not allowed gambrinus777 Linux - Server 3 09-07-2007 07:16 AM
Not a symbolic link ?? attockonian Linux - Newbie 4 06-30-2006 09:09 PM
help with a symbolic link mykrob Linux - Software 6 11-22-2004 11:01 AM


All times are GMT -5. The time now is 03:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration