LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   symbolic link not allowed or link target not accessible (http://www.linuxquestions.org/questions/linux-newbie-8/symbolic-link-not-allowed-or-link-target-not-accessible-659251/)

paullaubscher 07-30-2008 10:03 AM

symbolic link not allowed or link target not accessible
 
To whom it may concern


I am using SLES 10 SP1.1 , am getting an symbolic link error when executing a file to my Apache server see under mentioned.

[Wed Jul 30 14:55:04 2008] [error] [client 10.30.57.7 ] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/gwclnt/SetupIP.fil

I did an symbolic link to #ls -l setupip.fil SetupIP.fil and a
#chmod -R a+r * to give the user rights to execute the file to my Apache server.

Could somebody pls. tell me what I am I doing wrong ?


Paul

ne pas 07-30-2008 10:34 AM

May be you need to add +FollowSymLinks option to your Directory directive? See Apache Core Feautes - Options directive

paullaubscher 08-13-2008 02:06 AM

symbolic link error
 
Thanks

It is working

Paul

cowanpf 10-19-2009 01:26 PM

I also have this problem
 
Quote:

Originally Posted by paullaubscher (Post 3245578)
Thanks

It is working

Paul


Where did you put this in the httpd.conf file?

pantera975 03-10-2010 07:47 AM

I know this is old but someone will find it useful if your SSL doesn't work but HTTP does

edit /etc/httpd/conf.d/ssl.conf and add it in there

<Directory "/var/www/html">
Options Indexes FollowSymLinks
AllowOverride None
Allow from from all
Order allow,deny
</Directory>


All times are GMT -5. The time now is 05:35 AM.