LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2001, 02:53 PM   #1
zhenwu
Member
 
Registered: Jul 2001
Location: Taiwan (ex-Victoria BC)
Distribution: RH 9.0
Posts: 126

Rep: Reputation: 15
Switching Window managers?


Could some tell me how to make KDE the default manager instead of Gnome? I am having a crapload of trouble with Gnome (keep getting that "Not running a Gnome compliant window manager" thing, running RH 7.1) and I can't seem to fix it.

If someone could either tell me how to make the switch to KDE or how to fix this chronic problem with Gnome, I would be extremely grateful.

thanks.
 
Old 07-27-2001, 03:10 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
'switchdesk kde' will do the obvious. As for the Gnome problem, I've no idea. I've not had any trouble with it on RH71. I'd personally stick with Gnome, cos KDE looks awful IMO.

Chris
xxxx
 
Old 07-27-2001, 03:19 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
I think if you wanted to change the default for all users would be to edit the xinitrc file I think is located in /usr/X11R6/lib/X/xinit/.... Just a tip... the other method is much quicker.
 
Old 07-28-2001, 12:43 AM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
This occurs with sawfish for some reason.

Try

gnomecc

and change window managers, then save current settings, logoff, startx again. Everything should be ok.


Then if you want to retry sawfish go to gnomecc again and change it back.

It should work.
 
Old 07-28-2001, 01:04 AM   #5
zhenwu
Member
 
Registered: Jul 2001
Location: Taiwan (ex-Victoria BC)
Distribution: RH 9.0
Posts: 126

Original Poster
Rep: Reputation: 15
thanks, but

When I type gnomecc I get the control panel, but I have no ability to change the settings. The eterm window says:

GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

** WARNING **: an initialization error occurred while starting 'wm-properties-capplet'.
aborting...



Any suggestions? I must say, I've installed and re-installed RH 7.1 about four times in the past ten days due to many strange errors, and although I go through the same process each time, each install seems fraught with its own batch of errors and problems.

I have a:
Asus i440 bx mb, celeron 333a, 192mb RAM, Intel i740 8mb vid card.
 
Old 07-28-2001, 01:08 AM   #6
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Try it as root
 
Old 07-28-2001, 01:16 AM   #7
zhenwu
Member
 
Registered: Jul 2001
Location: Taiwan (ex-Victoria BC)
Distribution: RH 9.0
Posts: 126

Original Poster
Rep: Reputation: 15
very odd

Well I had su'd to do it the first time, so I "su -" ed and it did the same thing. When I clicked on 'window manager' all that happened was another Gnome Control Centre popped up, and so on ad infinitum.

Maybe I should go back to 6.2, or try a different distro? I've had very little sleep the past week or so, trying to get this running smoothly...
 
Old 07-28-2001, 02:46 AM   #8
Isitme
LQ Newbie
 
Registered: Jul 2001
Distribution: redhat
Posts: 3

Rep: Reputation: 0
Click the foot go to programs, then system and you should the desktop switching tool in the list of apps.
 
Old 07-28-2001, 02:53 AM   #9
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
in the gnome menu, you can get to the window manager like this. This is for 7.1 maybe not yours.



Programs/settings/desktop/window manager
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
switching window managers in live CD distros Hosiah Linux - General 4 10-20-2005 01:14 AM
switching window managers LSherman Slackware 4 05-02-2004 01:51 PM
Switching Window Managers Brother Michael Debian 5 04-17-2004 11:49 AM
Window Managers vs. Desktop Managers mikeshn Linux - General 4 02-11-2004 12:31 PM
Switching Window managers... Brother Michael Linux - Newbie 1 12-20-2003 01:16 AM


All times are GMT -5. The time now is 04:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration