LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2003, 09:40 AM   #1
esage
Member
 
Registered: Dec 2002
Location: N.W. Pennsylvania
Distribution: Simply Mepis 6.0 Final
Posts: 43

Rep: Reputation: 15
Question Switching KDE & Gnome


Mnk 9.1. On boot, I go to KDE desktop. How can I go to Gnome [it *is* installed] w/o logging out? And then can I get back to KDE? Appreciate help on this. Thanks.
 
Old 06-19-2003, 09:51 AM   #2
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Rep: Reputation: 30
um.. as far as i know you can not without loggin out..
unless you kill all gnome processes and run the kde
desktop; but that's sloppy and i do not know how.
 
Old 06-19-2003, 10:30 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
1. Open a Terminal (e.g. <Ctrl><Alt><F2>).
2. Log in (probably with a different ID).
3. Type startx -- :2 (blanks as shown)
4. Log out after changing your default window manager to Gnome.
5. Goto 2.

At least worth a try...

Oh btw., after you established your sessions, you switch between them with <F1> and <F7> (<F8>?).
 
Old 06-19-2003, 09:55 PM   #4
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
I've put a second line in /etc/X11/xdm/Xservers --
:1 /bin/nice -n 10 /usr/X11R6/bin/X :1 vt08 -deferglyphs 32
When X is started up, you are looking at vt7, CTRL-ALT-F8 takes you to a second login screen where you can select GNOME, CTRL-ALT-F7 takes you back to the KDE desktop.
One thing I've just noticed is that I only have a user login and I need to be able to login as root. I think I've seen where to sort it out, but must hunt for it again later.
 
Old 06-20-2003, 02:39 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
Interesting. Learned something new .

SuSE doesn't show a root icon. Just type root and your password. I think you can change it to show a root icon with YAST2.

I would appreciate it, if you could explain the options (e.g. -deferglyph 32). It's still early here, and I had no coffee yet .

Last edited by JZL240I-U; 06-20-2003 at 02:42 AM.
 
Old 06-20-2003, 07:08 AM   #6
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
I've seen it on Mandrake 9.1, I don't see it in the manpage for X and wonder if it is a way of defining the colour depth (32) that folows it. On my SuSE 8.1 machine, I have ---
:0 local /usr/X11R6/bin/X :0 vt07
:1 local /usr/X11R6/bin/X :1 vt08
On SuSE I can login as root, but on Mandrake you don't get the option to type in the user, it just presents icons. There is somewhere you can allow a root icon to appear, shouldn't be too difficult to find again.
Sid.
 
Old 06-20-2003, 07:25 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
That comes form your SuSE /etc/X11/xdm/Xservers I presume? Its nice, that you posted it too, since I use SuSE 8.1, I'll try it soonest.

Sorry, no experience with Mandrake.
 
Old 06-23-2003, 07:35 PM   #8
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
Quote:
Originally posted by JZL240I-U
That comes form your SuSE /etc/X11/xdm/Xservers I presume? Its nice, that you posted it too, since I use SuSE 8.1, I'll try it soonest.

Sorry, no experience with Mandrake.
OK, the original response was for Mandrake, the latter two lines are for SuSE 8.1. SuSE 8.0 used to have a "Start New Session" in the menu, was missing for 8.1 and is back on 8.2. I worked this out quite a while ago when
I had need for 2 sessions, one GNOME and one KDE or one for root and one for user and figured out that if :0 would start one Xserver, then :1 should start a second, before that, long ago, I used xnest, but laterly that didn't do quite what I wanted. There are a few neat things you can do also, e.g "X :2 -query <hostname/IPaddress> vt09 &" to another Linux box or Sun Server to get a desktop login to that machine; "krfb" also allows you to permit someone to take over your desktop, also permit takeover of keyboard and mouse, while you can follow exactly every move they make, great for some remote support and nicer than straight VNC server.
Sid.
 
Old 06-23-2003, 07:55 PM   #9
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
Quote:
Originally posted by JZL240I-U
That comes form your SuSE /etc/X11/xdm/Xservers I presume? Its nice, that you posted it too, since I use SuSE 8.1, I'll try it soonest.

Sorry, no experience with Mandrake.
It's the same file on both Mandrake and SuSE 8.1.
I forgot to mention that you can start other Xservers also, I usually amaze colleagues that I can look at 3 Solaris domains (:2 :3 and :4, vt's 9, 11 and 12), that's 3 Solaris workstations if you needed to access them often, or one Solaris workstation, logging out from each and logging in again to the one you want at the time. Just one of many goodies available in Linux that makes you realise Solaris is a dog to administer comparatively.
Sid.
 
Old 06-30-2003, 09:22 AM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
Well, I tried your trick, and it doesn't work .

-----------------------------------------
:0 local /usr/X11R6/bin/X :0 vt07
:1 local /usr/X11R6/bin/X :1 vt08
-----------------------------------------

Just give me a blank (black) screen on <CTRL>+<ALT>+<F8>, with a blinking white block-cursor. No further reactions when I type something...

Everything else works okay. What am I missing, or did you do anything else?
 
Old 06-30-2003, 05:26 PM   #11
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
I forgot to add that you need to restart X. You can also do a quick check, "X :2" from a terminal and you'll see it switches to an X screen, no login, just the mouse cursor, then CTRL-ALT-Backspace to kill it and back to the original session or CTRL-F7, CTRL-F8 to switch back to the new X server.
 
Old 07-01-2003, 05:25 AM   #12
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
Quote:
Originally posted by sidboyce
I forgot to add that you need to restart X.
...
CTRL-F7, CTRL-F8 to switch back to the new X server.
I did not only that, I booted (several times) and still no change from what I wrote above . <CTRL>+<ALT>+<F7> works perfectly like before.

Do you know whether and where there is a message / error log of the xserver? Perhaps I can find any hint there...

Last edited by JZL240I-U; 07-01-2003 at 05:27 AM.
 
Old 07-01-2003, 09:25 AM   #13
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
That's strange, I have both servers running and logged in here. /var/log/xdm.errors or /var/log/XFree86.0.log or /var/log/XFree86.1.log perhaps. What do you get if you do "X :1 &", it should switch to vt08 and display an X screen with only the cursor. On SuSE 8.1, it's working fine, on 8.2 "Start New Session" menu item does it fine as it did on 8.0. On 8.1 this is all of my /etc/xdm/Xservers file.
# $XConsortium: Xserv.ws.cpp,v 1.3 93/09/28 14:30:30 gildea Exp $
#
#
# $XFree86: xc/programs/xdm/config/Xserv.ws.cpp,v 1.1.1.1.12.2 1998/10/04 15:23:14 hohndel Exp $
#
# Xservers file, workstation prototype
#
# This file should contain an entry to start the server on the
# local display; if you have more than one display (not screen),
# you can add entries to the list (one per line). If you also
# have some X terminals connected which do not support XDMCP,
# you can add them here as well. Each X terminal line should
# look like:
#
# XTerminalName:0 foreign
#
# Note: The vt07 is required to start the local X server on the virtual
# console 7. This avoids conflicts with gettys of /etc/inittab.
#
:0 local /usr/X11R6/bin/X :0 vt07
:1 local /usr/X11R6/bin/X :1 vt08
--------------------------------------------------------------
With both Xservers running, I did "X :2 &" and it started a third Xserver on vt09.
 
Old 07-02-2003, 05:33 AM   #14
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,950

Rep: Reputation: Disabled
Well, /var/log/xdm doesn't exist on my machine, /var/log/XFree86.0.log and /var/log/XFree86.1.log show no error (though I don't understand their finer details). My /etc/xdm/XServers file is identical with yours. And yes, I'm using SuSE 8.1.

X :1 & works just like you say, and I get that screen with the cursor. But what then? It's unusable that way ... without that <ALT><F8> just shows a black screen with a white blinking cursor and no further reaction.

Same with X :2 &, just like you describe.

Just for clarity: Is that all that is expected to happen? I thought I would get a second possibility to log in (via kdm) and so establish two graphical sessions (one root and one user)?
 
Old 07-02-2003, 12:29 PM   #15
sidboyce
Member
 
Registered: Jan 2003
Location: Halesowen, West Midlands, UK
Distribution: SuSE 10.0/Mandriva 2006/gentoo
Posts: 87

Rep: Reputation: 15
That's OK, the only way I've so far found is to do "xterm -display :1 &", then switch CRTL-ALT-F8 and "kde (Enter)" in the xterm there works. I can't explain why it doesn't start with the
:1 local /usr/X11R6/bin/X :1 vt08 line in /etc/X11/xdm/Xservers, I just noticed I said /etc/xdm/Xservers above - it was past my bedtime when I posted perhaps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from KDE to Gnome Frenzy56 SUSE / openSUSE 11 06-09-2006 12:14 AM
SuSE 10 KDE & GNOME switching ? SuSE8x Linux - Hardware 1 11-18-2005 04:24 AM
KDE/GNOME switching? And how to connect to the internet in GNOME SuSE 10.0 Cards_STL SUSE / openSUSE 14 10-29-2005 08:21 PM
switching from gnome to kde alpert Slackware 3 02-19-2003 08:18 AM
Switching from GNOME to KDE kau Linux - Newbie 2 05-14-2002 10:41 PM


All times are GMT -5. The time now is 06:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration