LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-19-2002, 03:01 PM   #1
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Rep: Reputation: 30
switching from KDE to something faster


I'm currently using KDE 3 and it's way too slooow for my current hardware (366 Celery with 64MB RAM and 4MB video). I'm wanting to switch to something lighter to get some more speed but am not sure how to do it without erasing KDE. I'd like to not erase any files off my system, but use something else.

I heard that afterstep was relatively fast and nice but, if I remember right, it's a window manager where KDE/Gnome are not. So, if I were to use afterstep (already installed) what would it work with if not KDE/Gnome? How would I start to configure my system?

Any ideas would be appreciated!
 
Old 11-19-2002, 04:03 PM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
viniosity, hi! You sure can, but I am wondering if you are still running Debian or is this some other distro? This question is too often a distro specific one, so that would be a good bit of info to include.

The short answer though, yes you can change to whatever wm you want, and keep the KDE/GNOME apps for your enjoyment, pleasure, torture, you name it.

Cool
 
Old 11-19-2002, 04:10 PM   #3
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Hi MasterC,
Yes, I am running Debian 3's testing distribution.

Thanks!
 
Old 11-19-2002, 04:34 PM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ok, create (or edit if it exists, actually post the contents first if it exists) a ~/.xinitrc file. If you don't know what that means, create a .xinitrc file in the users home directory.

Then add this line in there:
exec afterstep

Well, actually first make sure it's installed. $:whereis afterstep

If it returns a location, you can place that, case sensitive in that file so:
exec /wherever/bin/AfterStep

Might be one idea.

Anyway, now after that, go ahead and quit X (CTRL ALT BACKSPACE), then run "startx" and see if it starts afterstep.

Cool
 
Old 11-19-2002, 04:53 PM   #5
cinders
Member
 
Registered: Aug 2002
Location: Australia
Distribution: Mdk 9, Debian 3, OpenLinux 2.3, Slackware 8.1, RedHat 8
Posts: 31

Rep: Reputation: 15
If you find that Afterstep isnt your thing, can I sugest Enlightenment?
Its very fast......and very different.
 
Old 11-19-2002, 04:56 PM   #6
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
Please let's not allow this thread to descend into 'try this WM, try that WM, this one's better, no this one is' kind of thread. Let it just be sufficient to say that there are many WMs around, almost all are faster and lighter than KDE/Gnome, and there are many threads that are still alive that have arguments both for and against the different WMs, and even one that shows screenshots, so you can get an idea of what to expect!

Good luck.
 
Old 11-20-2002, 09:01 AM   #7
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
It didn't work.. I typed:

vi .xinitrc

and put:
exec /usr/bin/afterstep

I wrote the file, quit vi, and then logged out of KDE. Logged in as root, typed 'shutdown -r now' and waited for the system to come up.

It came up with the familiar login screen (though it's set to init3 so why that's happening is beyond me) and then KDE 3 launches when I login.

Any other ideas?
 
Old 11-20-2002, 10:17 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well the .xinitrc will only be read if you run "startx", i.e you are booting to runlevel 3, not runlevel 5. to try that, type "init 3" as root and then exit kde. then run startx.

please... don't use something other than KDE because it's faster, use it because it's BETTER.
 
Old 11-20-2002, 11:26 AM   #9
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
I have much strangeness to report..

When I hit cntl-alt-backspace it quits x and then brings me back to the graphical login. So I went to another screen and type init 3 as root. It told me it was switching to run level 3 but then didn't do anything further. Next I tried switching the runlevel to 5 in the inittab and restarting. That still brings back the graphical login at boot. Hitting cntl-alt-backspace quits x and then brings me back. Perhaps this is the crux of my problem? Whether I set the runlevel to 3 or 5 in inittab I get the graphical login and I don't know why..
 
Old 11-20-2002, 11:32 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
if you set to boot at runlevel 3 you will NOT get kdm loading. you have not said what happens after pressing ctrlaltback after changing to runlevel 3
 
Old 11-20-2002, 12:15 PM   #11
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Well, inittab is set to run level 3 (tried 5 too but switched it back to 3). When I hit cntl-alt-backspace it quits X and then brings me back to a graphical login. So I have two choices:
1) type init 3 from konsole (this does nothing)
2) type init 3 from a different non-graphical screen (cntl-alt-F1)

When I do #2, it says Switching to run level: 3 but then the cursor just stays there.. i.e. nothing happens! So on that screen I can't type anything b/c I don't have a prompt.. it's frozen.
 
Old 11-20-2002, 02:27 PM   #12
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Can you post for us the contents of your inittab, maybe something is defined differently on yours

Either way, let's try this:
switch to a console and login as the user in which you have placed the .xinitrc file, then type:
startx -- :1

This will startx on the tty8 console, and at least show you if the xinitrc is working correctly.

From there we can deal with your inittab problem.

Cool
 
Old 11-20-2002, 02:32 PM   #13
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
"1) type init 3 from konsole (this does nothing)"

yes it DOES. there is nothing to see, you are simply changing a setting with no imediate effect. I have said you should do these two things in order. please try them BOTH before saying we are wrong.
 
Old 11-20-2002, 02:38 PM   #14
viniosity
Member
 
Registered: Oct 2001
Location: Washington, DC
Distribution: Debian, Archlinux, Ubuntu, Sidux
Posts: 244

Original Poster
Rep: Reputation: 30
Typing startx --:1 from console 1 gave me an error saying that the server was already active for display 0.
Here's the /etc/inittab file:

# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.8 1998/05/10 10:37:50 miquels Exp $

# The default runlevel.
id:3:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."

# What to do when the power fails/returns.
pf:owerwait:/etc/init.d/powerfail start
pn:owerfailnow:/etc/init.d/powerfail now
po:owerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
# <id>:<runlevels>:<action>:<process>
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3
 
Old 11-21-2002, 01:10 AM   #15
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
There is a space there:
startx(SPACE)--(SPACE):1
So, without the bold and the space marker:
startx -- :1

As for your computer still starting at the Login Manager while in run level 3, that is beyond me. But like Chris said, typing "init 3" won't really do anything except kill X. If you press CTRL ALT F7 after that, you shouldn't return to your Login Manager, or any X session at that point. Nonetheless, the 'startx -- :1' should startx on the next available tty, or display1 will start on the next tty. Either way, it is most likely going to be CTRL ALT F8 to get to that window now...

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE 3.3 Bad Monitor Switching on Desktop Switching Inchoate Linux - Software 1 05-25-2005 02:00 PM
Gnome or Kde which is faster? greppinFunk Linux - General 2 12-15-2003 07:42 AM
KDE faster with more stuff enabled? CryptDragoon Linux - Newbie 0 10-09-2003 01:16 PM
To load KDE much faster! wonderpun General 4 10-17-2002 03:33 PM
console keyboard configuration\ terminal switching off \ faster booting jamaso Linux - Newbie 5 10-27-2001 08:59 AM


All times are GMT -5. The time now is 04:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration