LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-10-2009, 08:37 AM   #1
vishal.gokhale
LQ Newbie
 
Registered: Jun 2009
Posts: 1

Rep: Reputation: 0
switching from gnu jvm to sun jvm without uninstalling gnu jvm


Hi,

I am newbie.
I am trying to run Kettle(Pentaho Data Integration) on Linux FC5 and am getting below exception when I run the ./spoon.sh command.
I am running spoon for the first time....

This is really urgent. thanks in advance...

Vishal.


---------------------------------------------------------------------

[vishal@km data-integration]$ ./spoon.sh
Exception in thread "main" java.lang.NoClassDefFoundError: org.pentaho.di.ui.spoon.Spoon
at java.lang.Class.initializeClass (libgcj.so.7)
at java.lang.Class.forName (libgcj.so.7)
at gnu.java.lang.MainThread.run (libgcj.so.7)
Caused by: java.lang.ClassNotFoundException: java.lang.Enum not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./,file:./lib/kettle-core.jar,file:./lib/kettle-db.jar,file:./lib/kettle-engine.jar,file:./lib/kettle-ui-swt.jar,file:./libswt/jface.jar,file:./libswt/runtime.jar,file:./libswt/common.jar,file:./libswt/commands.jar,file:./libext/jakarta-oro-2.0.8.jar,file:./libext/ognl-2.6.9.jar,file:./libext/js.jar,file:./libext/jackcess-1.1.18.jar,file:./libext/edtftpj-2.0.2.jar,file:./libext/jxl.jar,file:./libext/janino.jar,file:./libext/mail.jar,file:./libext/JDBC/derby.jar,file:./libext/JDBC/db2jcc_license_cu.jar,file:./libext/JDBC/ifxjdbc.jar,file:./libext/JDBC/LucidDbClient.jar,file:./libext/JDBC/jt400.jar,file:./libext/JDBC/vertica_2.5_jdk_5.jar,file:./libext/JDBC/postgresql-8.3-603.jdbc3.jar,file:./libext/JDBC/jtds-1.2.jar,file:./libext/JDBC/xdbjdbc.jar,file:./libext/JDBC/jaybird-full-2.1.0.jar,file:./libext/JDBC/interclient.jar,file:./libext/JDBC/hsqldb.jar,file:./libext/JDBC/db2jcc.jar,file:./libext/JDBC/sapdbc.jar,file:./libext/JDBC/h2.jar,file:./libext/JDBC/rdbthin.jar,file:./libext/JDBC/unijdbc.jar,file:./libext/JDBC/mysql-connector-java-3.1.14-bin.jar,file:./libext/JDBC/monetdb-1.7-jdbc.jar,file:./libext/JDBC/derbyclient.jar,file:./libext/JDBC/orai18n.jar,file:./libext/JDBC/kingbasejdbc.jar,file:./libext/JDBC/sqlitejdbc-v037-nested.jar,file:./libext/JDBC/ojdbc14.jar,file:./libext/JDBC/iijdbc.jar,file:./libext/webservices/wsdl4j.jar,file:./libext/webservices/wstx-asl-3.2.0.jar,file:./libext/webservices/jsr173_api.jar,file:./libext/webservices/qname.jar,file:./libext/trilead-ssh2-build213.jar,file:./libext/ldapjdk.jar,file:./libext/salesforce/salesforce-1.0.jar,file:./libext/salesforce/commons-discovery-0.2.jar,file:./libext/salesforce/saaj.jar,file:./libext/salesforce/jaxrpc.jar,file:./libext/salesforce/axis.jar,file:./libext/jug-lgpl-2.0.0.jar,file:./libext/javadbf.jar,file:./libext/pentaho/pentaho-vfs-browser-i18n.jar,file:./libext/pentaho/libformula-0.1.18.2.jar,file:./libext/pentaho/pentaho-versionchecker.jar,file:./libext/pentaho/pentaho-database-2.0.2-SNAPSHOT.jar,file:./libext/pentaho/pentaho-xul-framework-1.7.1-32194.jar,file:./libext/pentaho/pentaho-vfs-browser.jar,file:./libext/jaxen-1.1.1.jar,file:./libext/jsch-0.1.38.jar,file:./libext/jfree/jfreechart-1.0.1.jar,file:./libext/jfree/jcommon-1.0.14.jar,file:./libext/kettle-version-checker-0.1.0.jar,file:./libext/dom4j-1.6.1.jar,file:./libext/feeds/xml-apis.jar,file:./libext/feeds/nekohtml.jar,file:./libext/feeds/rome-0.9.jar,file:./libext/feeds/jdom.jar,file:./libext/feeds/xercesImpl.jar,file:./libext/feeds/feed4j.jar,file:./libext/feeds/georss-rome-0.9.8.jar,file:./libext/mondrian/commons-math-1.0.jar,file:./libext/mondrian/eigenbase-resgen.jar,file:./libext/mondrian/eigenbase-xom.jar,file:./libext/mondrian/mondrian.jar,file:./libext/mondrian/javacup.jar,file:./libext/mondrian/eigenbase-properties.jar,file:./libext/mondrian/saxon8-xom.jar,file:./libext/junit-4.1.jar,file:./libext/web/jetty-util-6.1.9.jar,file:./libext/web/jetty-6.1.9.jar,file:./libext/web/servlet-api-2.5-6.1.9.jar,file:./libext/web/jetty-plus-6.1.9.jar,file:./libext/web/simple-jndi-0.11.1.jar,file:./libext/web/activation.jar,file:./libext/commons/commons-dbcp-1.2.1.jar,file:./libext/commons/commons-beanutils-1.7.0.jar,file:./libext/commons/commons-collections-3.1.jar,file:./libext/commons/commons-net-1.4.1.jar,file:./libext/commons/commons-vfs-1.0.jar,file:./libext/commons/commons-digester-1.8.jar,file:./libext/commons/commons-httpclient-3.0.1.jar,file:./libext/commons/commons-pool-1.3.jar,file:./libext/commons/commons-fileupload-1.0.jar,file:./libext/commons/commons-logging-1.1.jar,file:./libext/commons/commons-codec-1.3.jar,file:./libext/commons/commons-validator-1.3.1.jar,file:./libext/commons/commons-lang-2.2.jar,file:./libext/spring/spring-core.jar,file:./libext/log4j-1.2.8.jar,file:./libext/saxon8.jar,file:./libext/JDBC/asjava.zip,file:./libswt/linux/x86/swt.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass (libgcj.so.7)
at java.lang.ClassLoader.loadClass (libgcj.so.7)
at java.lang.ClassLoader.loadClass (libgcj.so.7)
at java.lang.VMClassLoader.defineClass (libgcj.so.7)
at java.lang.ClassLoader.defineClass (libgcj.so.7)
at java.security.SecureClassLoader.defineClass (libgcj.so.7)
at java.net.URLClassLoader.findClass (libgcj.so.7)
at java.lang.ClassLoader.loadClass (libgcj.so.7)
at java.lang.ClassLoader.loadClass (libgcj.so.7)
at java.lang.Class.forName (libgcj.so.7)
at java.lang.Class.initializeClass (libgcj.so.7)
...2 more
 
Old 06-10-2009, 09:14 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,592

Rep: Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559Reputation: 2559
Quote:
Originally Posted by vishal.gokhale View Post
Hi,

I am newbie.
I am trying to run Kettle(Pentaho Data Integration) on Linux FC5 and am getting below exception when I run the ./spoon.sh command.
I am running spoon for the first time....
This is really urgent. thanks in advance...
Vishal.
Nope, this ISN'T really urgent, for anyone but you. Don't tell us to hurry, when we volunteer our time to answer questions. If you want an "urgent" answer, pay for support.

First, FC5 is ancient...the latest Fedora Core is 10, soon to be 11. Not surprising you're having problems installing something new. Check which version of Java you have installed, and upgrade it if you need to. Since this is "urgent", you've probably already read the installation guide on their site (http://wiki.pentaho.com/display/EAI/...talling+Kettle), that tells you which Java to install, and where to get it, right??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to install 1.3.1 Sun JVM on RH Enterprise v 4.5 OOsorio Linux - Newbie 2 01-31-2008 11:44 AM
JVM Settings in sun one app server rajaniyer123 Solaris / OpenSolaris 0 08-27-2007 01:00 AM
sun JVM installation on fedora and tomcat kumar.craja Linux - Server 2 05-27-2007 12:45 PM
Problems with Tomcat 5 and JVM SUN 1.5.0 Update 4 in Fedora 4 cassao Fedora 5 09-21-2005 08:23 AM
Sun JVM and Konqueror webterractive Linux - Distributions 4 04-11-2004 02:28 AM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration