LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2003, 04:42 PM   #1
migraineboy
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
swig not found on configure


hi,

installed swig 1.3.19 according to instructions. swig executable was placed in default usr/local/bin.
Then...
tried to install gnu solfege 1.4.10 according to instructions:
./configure rendered this:
=====================
loading cache ./config.cache
checking for python... /usr/bin/python
checking python version... 2.2
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking whether make sets ${MAKE}... yes
checking for swig... no
configure: error:
*** You need to install swig. You can find it at *****ww.swig.org
*** and it is probably available in a binary package from the CD or
*** ftp site of your favourite linux distro.
=====================================
swig is installed and solfege's configure script doesnt allow a path option for swig's location.


did how do i make solfege recognize the existence of swig??

thanx
 
Old 07-28-2003, 06:48 PM   #2
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
First of all make sure /usr/local/bin is in your path
echo $PATH
export PATH=$PATH:/usr/local/bin
if the package has shared libs they were prolly installed in /usr/local/lib make sure it is under $LD_LIBRARY_PATH
echo $LD_LIBRARY_PATH
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
or in /etc/ld.so.conf in this case you need to run /sbin/ldconfig to update /etc/ld.so.cache
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure Lost+Found? AnnJS Linux - Newbie 4 06-15-2005 02:30 AM
query regarding installing swig on Red hat Linux9 shweta12 Linux - Software 4 04-27-2005 11:44 PM
Swig sailu_mvn Programming 1 03-24-2005 08:20 AM
Configure error: QT not found marsonist Linux - Software 3 04-26-2004 12:48 AM
'configure' command not found invinciblemk Linux - Newbie 4 02-02-2004 04:39 PM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration