LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2003, 06:50 AM   #1
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Rep: Reputation: 15
Swat??


I ame using SWAT and did what the book and what I found on the net. But when I conect to http://localhost:901 it gives this

The operation timed out when attempting to contact www.localhost.com

I checked /etc/services file. and it is set to swat 901/TCP

I am using samba 3.0

thank you
 
Old 03-31-2003, 11:17 AM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Do you have a firewall running? What distro are you using?
 
Old 03-31-2003, 04:00 PM   #3
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
I have a firewall on and my distro is redhat 8.0
 
Old 03-31-2003, 05:01 PM   #4
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
You should check to see if your firewall is blocking port 901 and also take a look at /etc/hosts.deny and /etc/hosts.allow to make sure your not getting blocked there.
 
Old 03-31-2003, 08:22 PM   #5
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
ok I turned of the firewall and looked in both places both /etc/hosts.deny and /etc/hosts.allow were blank except for the # and the words describing what it is after the # sign
yet it gives the same problem error
 
Old 03-31-2003, 08:56 PM   #6
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Is Samba and Swat on? Do:

netstat -l

thats a lowercase L to see if the Swat port is listening for connections.
 
Old 03-31-2003, 10:58 PM   #7
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
I was having the same problem. The standard firewall tool (lokkit) does not work. I use Guarddog instead. It is here.
 
Old 03-31-2003, 11:01 PM   #8
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
the only thing I see there that relates to "Swat port" is

tcp 0 0 *:swat *:* LISTEN
 
Old 03-31-2003, 11:02 PM   #9
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Okay so swat is listening for connections. I'm not sure if it matters but I would assume that Samba must also be listening in order to use Swat.

Is Samba listening as well?

How exactly did you shut off the Firewall?

Last edited by Crashed_Again; 03-31-2003 at 11:03 PM.
 
Old 04-01-2003, 09:00 PM   #10
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
Ok samba is not listed and I used lokkit to turn it of but I went back to lokkit just now. I saw that it was back on I will try Guarddog as green_dragon37 stated.
 
Old 04-01-2003, 11:07 PM   #11
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
I tried the guarddog got it installed and used it to disable the firewall then I went to lokkit to see if it was disabled. And it was not after it states that it was disabled in the terminal it says this

[root@loocalhost guarddog-2.0.0] # Mutex destroy failure: Device or resource busy
kdeinit: Fatal IO error: client killed
Kdeinit: sending SIGHUP to children
Kdeinit: sending SIGTERM to children
Kdeinit: Exit

this is where I enter guarddog
[root@loocalhost guarddog-2.0.0] # guarddog

also it looks like there are three ways to install it
./configure
make
make install
not knowing what I was doing at the time I did all three lol
 
Old 04-02-2003, 12:18 AM   #12
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
The "Mutex destroy failure..." error message has no bearing on anything. And in lokkit, it will always say High, no matter what the actual firewall settings are. If guarddog says it is off, then it is off. Did you try swat after you disabled the firewall in Guarddog?
 
Old 04-02-2003, 12:59 AM   #13
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
ok I have been typing http://localhost:901 in Mozilla and yet it gives this.

The operation timed out when attempting to contact www.localhost.com

Is there another way to get into swat I did try typing swat in /usr/local/samba/bin also swat 901/tcp but it just goes to the next line and it is blanke somthing like this
[root@localhost bin] swat 901/tcp

the next line is blank like the line above this line shows. Also if I enter somthig nothing happens.
 
Old 04-02-2003, 01:40 AM   #14
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
Have you tried 127.0.0.1:901 to see if that works? It points to the same place... How about another browser?
 
Old 04-02-2003, 05:51 AM   #15
FireWolf
Member
 
Registered: Dec 2002
Posts: 36

Original Poster
Rep: Reputation: 15
I tried both ways on three deferent browsers and I am doing all this in the root yet no luck. also I have samba 3.0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Swat namit Linux - Networking 5 12-02-2005 07:38 PM
Swat delalynd Red Hat 12 01-12-2005 07:16 AM
Swat Hone101 Linux - General 1 03-22-2003 08:33 AM
Swat jwithers1 Linux - Networking 2 09-26-2002 02:48 PM
SWAT in RH 7.3 xgtr Linux - Newbie 1 05-31-2002 10:51 PM


All times are GMT -5. The time now is 02:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration