LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Swaret only prints version number (http://www.linuxquestions.org/questions/linux-newbie-8/swaret-only-prints-version-number-4175437813/)

curious95 11-19-2012 11:11 AM

Swaret only prints version number
 
hi, i installed swaret on my slackware machine but every time i launch it all it does is print the version. No matter what commands i use. Uninstalling and reinstalling swaret did not work either. Please help me find the problem. Downloading and installing swaret-tools didn't not fix this either. The command
Code:

swaret --update
...outputs
Code:

swaret 1.6.3-2

RobertP 11-19-2012 11:38 AM

The swaret command needs some parameters to do much else:
SYNOPSIS
swaret --ACTION [KEYWORD] [OPTION]


Type man swaret for details such as,
ACTIONS - OPTIONS
--update
Retrieve the latest List Files

--upgrade
NO_OPTION : Upgrade all installed Packages manually
-a : Upgrade all installed Packages automatically


curious95 11-19-2012 11:58 AM

That's just it ALL the commands output the swaret version number even those that do require optional parameters
Code:

swaret --update -a
and
Code:

swaret --update package_name
and
Code:

swaret --update
still output
Code:

swaret 1.6.3-2

RobertP 11-19-2012 12:20 PM

If swaret is actually doing nothing it must be broken or misconfigured.

Try cat /etc/swaret.conf, swaret --set or swaret --config to see what might need changing.

Looking at swaret.conf, offhand, you could be pointed to a non-existent repository, an unusable NIC or the wrong proxy server, but I would still expect some error-messages to give a clue.

curious95 11-20-2012 04:50 AM

Quote:

Originally Posted by RobertP (Post 4832720)
If swaret is actually doing nothing it must be broken or misconfigured.

Try cat /etc/swaret.conf, swaret --set or swaret --config to see what might need changing.

Looking at swaret.conf, offhand, you could be pointed to a non-existent repository, an unusable NIC or the wrong proxy server, but I would still expect some error-messages to give a clue.

Will do so and report back.

curious95 11-20-2012 04:59 AM

yup that's the problem lack of a swaret.conf file. After creating it Now swaret tells me that i lack a package called bc.
Code:

swaret
outputs
Code:

swaret 1.6.3-2
You need 'bc' in order to use swaret!
'bc' can be found in the Slackware Packages Directory: slackware/ap!


curious95 11-20-2012 06:41 AM

installed bc and now swaret works :)


All times are GMT -5. The time now is 11:55 AM.