LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   svn checkout -bash svn command not found (http://www.linuxquestions.org/questions/linux-newbie-8/svn-checkout-bash-svn-command-not-found-636348/)

Anauj0101 04-18-2008 07:59 PM

svn checkout -bash svn command not found
 
I've been using linux for a while now but im just now trying to compile something. I need to use the command svn checkout http://some site.
Im using Centos 5, what am i missing?

weibullguy 04-18-2008 09:27 PM

Do you have subversion installed?

Peacedog 04-18-2008 09:38 PM

Hi Anauj0101, Do you have subversion installed? Try this.
Code:

yum install subversion
Good luck. ;-)

Anauj0101 04-20-2008 12:22 PM

Well that worked, but my next issue is the actual compile. Im using a tutorial made for ubuntu and the commands are not working in Centos (go figure).
when i do the command autoreconf --install i get the error

dep/src/g3dlite/Makefile.am:25: library used but `RANLIB' is undefined
dep/src/g3dlite/Makefile.am:25:
dep/src/g3dlite/Makefile.am:25: The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'
dep/src/g3dlite/Makefile.am:25: to `configure.ac' and run `autoconf' again.
dep/src/sockets/Makefile.am:27: library used but `RANLIB' is undefined
dep/src/sockets/Makefile.am:27:
dep/src/sockets/Makefile.am:27: The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'
dep/src/sockets/Makefile.am:27: to `configure.ac' and run `autoconf' again.
dep/src/zlib/Makefile.am:27: library used but `RANLIB' is undefined
dep/src/zlib/Makefile.am:27:
dep/src/zlib/Makefile.am:27: The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'

this only part of it, im lost

The commands i am using are from this site, this is what im trying to do http://wiki.udbforums.org/index.php/Howto_compile
the linux directions are at the bottom. If I can accomplish this ill put out a Centos verson to help other people in my situation. Thanks.

Anauj0101 04-20-2008 12:53 PM

...........

weibullguy 04-20-2008 01:26 PM

New problem, you should have started a new thread.

Does the autoreconf throw any errors? You not posting enough output, just the snippets that you thought were important. Actually they are important...to you. The tell you exactly what to do. Did you try?
Quote:

Originally Posted by program Anauj001 is trying to install
The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'
to `configure.ac' and run `autoconf' again.

If not, why don't you? If so, what is the result?

Anauj0101 04-20-2008 05:50 PM

I found i needed to update my autoconf but it only was able to goto 2.59 now the only error I get is

configure.ac:173: error: possibly undefined macro: AC_TYPE_UINT64_T
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

Im assuming this is because i need autoconf 2.6(latest ver) but Centos 5 does not support it, I found an rpm for


All times are GMT -5. The time now is 08:24 PM.