LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2006, 08:44 PM   #1
jan.linux
LQ Newbie
 
Registered: Aug 2006
Location: Merelbeke, Belgium
Distribution: Slackware
Posts: 13

Rep: Reputation: 1
Suspend2: Swapwriter: No swap signature found


Hi Everyone

I can't get Suspend2 working :-(
This is a part of my dmesg:

Suspend2 Core.
Suspend2 Compression Driver loading.
Suspend2 Encryption Driver loading.
Suspend2 Swap Writer loading.
Suspend2 FileWriter loading.
ACPI wakeup devices:
RP01 USB1 USB2 USB3 USB4 USB7 MODM
ACPI: (supports S0 S3 S4 S5)
Replacing swsusp.
Suspend2 2.2.7.6: Swapwriter: No swap signature found at specified location.
Suspend2 2.2.7.6: Missing or invalid storage location (resume2= parameter). Please correct and rerun lilo (or equivalent) before suspending.
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 152k freed
input: AT Translated Set 2 keyboard as /class/input/input1
input: DualPoint Stick as /class/input/input2
input: AlpsPS/2 ALPS DualPoint TouchPad as /class/input/input3
psmouse.c: DualPoint TouchPad at isa0060/serio4/input0 lost sync at byte 1
input: DualPoint Stick as /class/input/input4
input: AlpsPS/2 ALPS DualPoint TouchPad as /class/input/input5
Unable to find swap-space signature
EXT3 FS on hda3, internal journal
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:02:00.0 to 64
sky2 v1.6.1 addr 0xb0000000 irq 16 Yukon-EC (0xb6) rev 1
sky2 eth0: addr 00:0f:b0:8f:f0:8e
ACPI: PCI Interrupt 0000:00:1e.2[A] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:00:1e.2 to 64
intel8x0_measure_ac97_clock: measured 52106 usecs
intel8x0: clocking to 48000
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:01:00.0 to 64
NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-8774 Tue Aug 1 20:54:08 PDT 2006
Unable to find swap-space signature
sky2 eth0: enabling interface
sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
Unable to find swap-space signature
Adding 1052248k swap on /dev/hda4. Priority:-1 extents:1 across:1052248k

My lilo.conf:

image = /boot/vmlinuz-dev
# initrd = /boot/initrd.gz
root = /dev/hda3
label = Linux-2.6-dev
append = "resume2=swap:/dev/hda4"
# append = "resume2=file:/dev/hda3:0xad4bc8"
read-only

I'm sure that /dev/hda4 is my swap space. Why does swapwriter not detect this? Is it because swapwriter is started before the swap partition is activated? And if so, how do I change this?

Jan
Slackware-current, 2.6.17.13 kernel

Last edited by jan.linux; 09-21-2006 at 08:46 PM.
 
Old 09-23-2006, 04:54 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,540

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
How (when) did you format the swap ???.
IIRC Pats instructions will format it as v0.
Issue a mkswap (without the -v keyword) from your 2.6 kernel against your swapspace, and then see how you go.
 
Old 09-23-2006, 10:32 AM   #3
jan.linux
LQ Newbie
 
Registered: Aug 2006
Location: Merelbeke, Belgium
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: 1
No luck with v1

Hibernating works, but resuming not.

Suspend2 2.2.7.6: Missing or invalid storage location (resume2= parameter). Please correct and rerun lilo (or equivalent) before suspending.

Thanks for your reply, any more ideas?
 
Old 09-23-2006, 04:55 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,540

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Two things I'd look at;
- did you rerun /sbin/lilo after any changes to the lilo conf ??.
- have a look for an update for suspend2; 2.2.8 is mentioned for 2.6.18 on the homepage.
 
Old 09-24-2006, 04:53 AM   #5
jan.linux
LQ Newbie
 
Registered: Aug 2006
Location: Merelbeke, Belgium
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: 1
- did you rerun /sbin/lilo after any changes to the lilo conf ??.
Yes I did.

- have a look for an update for suspend2; 2.2.8 is mentioned for 2.6.18 on the homepage.
I know there's a new version available, but do I have to compile a new kernel for that? (It took me 2 nights to build a custom 2.6 kernel for my Toshiba laptop )
The version I have is 2.2.7.6-for-2.6.17 from 15-Sep-2006.
 
Old 09-28-2006, 09:46 AM   #6
jan.linux
LQ Newbie
 
Registered: Aug 2006
Location: Merelbeke, Belgium
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: 1
Same error with the 2.6.18 kernel
 
Old 09-28-2006, 12:48 PM   #7
jan.linux
LQ Newbie
 
Registered: Aug 2006
Location: Merelbeke, Belgium
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: 1
append="devfs=mount acpi=on resume=/dev/hda2 splash=silent nolapic"
# Change the /dev/hda2 to your swap partition"

This did the trick :-)
http://www.linuxquestions.org/questi...d.php?t=422217
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspend2 rob666 Linux - Software 4 07-07-2006 07:56 PM
no setup signature found sharad durgawad Linux - Software 1 12-09-2005 04:06 PM
No medium found: cant mount swap part Dark Elf Linux - Hardware 5 06-02-2005 11:52 PM
No setup signature found ... ter_roshak Linux - General 3 09-01-2004 07:38 PM
no setup signature found Hybrid Blue Linux - Software 0 10-01-2003 08:14 PM


All times are GMT -5. The time now is 12:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration