LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-06-2004, 05:51 PM   #1
nez
LQ Newbie
 
Registered: May 2004
Posts: 7

Rep: Reputation: 0
Suse9.1, root can't connect to X-server


Hi, I just installed Suse 9.1,

When I'm not logged into root, I can access the X-server easily.

But when I'm root, it won't let me

linux:/usr # emacs hi
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :0.0.
Check the DISPLAY environment variable or use `-d'.
Also use the `xhost' program to verify that it is set to permit
connections from your machine.

Can someone help me set up the X-server for root?

Sorry I'm a newbie ^^;;
 
Old 05-06-2004, 05:53 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
as your normal user, run "xhost +root@localhost"
 
Old 05-06-2004, 06:03 PM   #3
nez
LQ Newbie
 
Registered: May 2004
Posts: 7

Original Poster
Rep: Reputation: 0
I tried that but now I get this error:

tony@japan:~> xhost +root@japan
root@japan being added to access control list
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 109 (X_ChangeHosts)
Value in failed request: 0xfe
Serial number of failed request: 7
Current serial number in output stream: 9
 
Old 05-12-2004, 03:07 PM   #4
pfy
LQ Newbie
 
Registered: May 2004
Location: San Diego, CA
Distribution: SuSe 9, redhat
Posts: 1

Rep: Reputation: 0
Run "xhost +" to disable xhost authentication. Though not very secure, it's the easiest way to deal with this in my experience.

PFY
 
Old 05-31-2004, 06:05 AM   #5
wiresquire
Member
 
Registered: Dec 2003
Posts: 57

Rep: Reputation: 15
I get similar errors with 9.1.

1. user@linux:~ > xhost +root@localhost
root@localhost being added to access control list
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 109 (X_ChangeHosts)
Value in failed request: 0xfe
Serial number of failed request: 7
Current serial number in output stream: 9
user@linux:~ > xhost +root
root being added to access control list
user@linux:~ > su
Password:
linux:/home/user # /opt/gnome/bin/gedit test
Xlib: connection to ":0.0" refused by server
Xlib: Invalid XDM-AUTHORIZATION-1 key (failed key comparison)

(gedit:24100): Gtk-WARNING **: cannot open display:

-->No gedit.
...and...

2. user@linux:~ > xhost +localhost
localhost being added to access control list
user@linux:~ > su
Password:
linux:/home/user # /opt/gnome/bin/gedit test
Xlib: connection to ":0.0" refused by server
Xlib: Invalid XDM-AUTHORIZATION-1 key (failed key comparison)

(gedit:24670): Gtk-WARNING **: cannot open display:

-->No gedit.
...and...

3. user@linux:~ > xhost +
access control disabled, clients can connect from any host
dburt@linux:~ > su
Password:
linux:/home/user # /opt/gnome/bin/gedit test

(gedit:24978): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

-->Here gedit opens.

I have always received that last "WARNING" in previous SUSE versions. But I have always used xhost +localhost.
 
Old 06-23-2004, 03:44 PM   #6
NexusMandrake
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 1
I ran into the same problem under Gentoo. All of the following worked:

1)
su - root
xauth merge ~youruser/.Xauthority

2)
su - root
export XAUTHORITY=~youruser/.Xauthority

3)
ssh -X root@localhost
 
1 members found this post helpful.
Old 08-01-2004, 10:20 PM   #7
opioid
Member
 
Registered: Jul 2003
Location: Chicago
Distribution: Ubuntu
Posts: 124

Rep: Reputation: 15
Wink Sweet!

Thanks... LQ to the rescue AGAIN.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to wireless network when SSID broadcast is disabled, Atheros card/SuSE9 baters Linux - Wireless Networking 19 01-15-2007 07:56 AM
can't install suse9.0 server golfavr SUSE / openSUSE 2 09-05-2005 06:18 AM
Networking Suse9.3 with Mac X.2 Server sound_p|p|ng Linux - Networking 0 06-02-2005 12:37 AM
cant connect to internet on fresh install of suse9.1 springdog Linux - Newbie 13 12-27-2004 04:47 PM
root cannot connect to an X server in a terminal GameboyHippo Linux - Software 4 02-09-2004 11:25 AM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration