LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-30-2004, 04:47 PM   #1
drcyber
Member
 
Registered: Mar 2003
Distribution: Fedora Core 2
Posts: 31

Rep: Reputation: 15
SuSE X86 problems


Hi.

I installed SuSE 9.1 on my machine and it was working fine. I didn't touch anything on the configuration, is totally original.

But yesterday, when I tried to run SuSE it doesn't start the X's. The prompt ask me to login and password. When I'm logged in, I tried tiping: startx, but it shows me this error MSG:

Data incomplete in file /etc/X11/XF86Config
Undefined modes section "Modes [1]" referenced by Monitor "Screen [1]".

(EE) Problem parsing the config file.
(EE) Error parsing the config file.

Fatal server error:
no screens founds.

Why if I didn't touch anything?... how can I fix this?

Thanks in advance.

PD: I have installed the XFree86 Version: 4.3.99.902.
PD2: If you need the complete log, (var/log/XFree86.0.log) how can I access this from the prompt?
PD3: I have ATI RADEON 7500, Pentium 4 2.6GHz.

Last edited by drcyber; 08-30-2004 at 04:48 PM.
 
Old 08-30-2004, 05:20 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
login as root from the command line and re-run sax2.
 
Old 08-30-2004, 06:20 PM   #3
drcyber
Member
 
Registered: Mar 2003
Distribution: Fedora Core 2
Posts: 31

Original Poster
Rep: Reputation: 15
Well, just perfect. But... I have to change my runlevel to 3 before do that. Just typing: init 3 on the command line.

Best regards and thankz!
 
Old 08-30-2004, 06:54 PM   #4
amfoster
Member
 
Registered: Aug 2004
Distribution: debian, SuSE
Posts: 365

Rep: Reputation: 35
Even if X bombs out you still have other terminals to type the command from. Just do ctrl-alt-F2

X's config file is /etc/X11/XF86Config You may be able to just fix the modes there rather than running Yast or sax2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 10.0 x86-64 fortran compiler pkuer SUSE / openSUSE 2 11-16-2005 10:30 AM
Suse 10.0 Eval x86 64 Uoldo SUSE / openSUSE 1 11-02-2005 07:16 AM
Boot x86 target from flash, with the image and file system on the x86 host. batsayan Linux - Software 2 08-23-2005 01:09 AM
Setting Up apt-get for SuSE 9.3 x86 - 64 nonsense28sal Linux - Software 2 06-09-2005 06:08 PM
X86 startup problems toosdedoos Linux - Newbie 7 09-25-2003 04:07 AM


All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration