LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2007, 05:32 AM   #1
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Rep: Reputation: Disabled
Suse won't boot after fstab changes - fstab not editable


Dear Community,
I wanted two partitions that were'nt mounted at boot, to be mounted automatically. Root could mount them by right-click mount, users had to mount via the Terminal.
So I played around with fstab, and rebooted. Boot worked fine, but the partitions were still not mounted. Then I tried editing fstab with YaST, reboot again, and the system would'nt load, not even in Failsafe.
Right now I am working with a kubuntu live cd, which won't let me edit the fstab anymore, due to missing rights. I tried various editors with root, however the file is saved as a read-only, which I can't change.
Thanks for your time,
baking-a-77
 
Old 05-20-2007, 05:49 AM   #2
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
Try using the live cd to chroot into your system and edit the file:

At your live-cd command prompt make a directory in /mnt

Mount your system root drive in the new directory

chroot to that directory and edit your fstab
 
Old 05-20-2007, 06:45 AM   #3
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Use Slax Live CD

It even allows you to boot to the desktop as a root user.

The latest version 6.0.0 allows you to edit and save files in a NTFS partition identically as any Linux file by drag and drop.

If your Suse's fstab file has an error the kernel will not be able to mount the files as instructed and so it won't boot. So using a Live CD to correct the error is the way forward.

Last edited by saikee; 05-20-2007 at 06:48 AM.
 
Old 05-21-2007, 12:29 AM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Missing permissions? Are you sure you trying to do this as root? If you use su - and submit the root password before you start mounting things, I don't see any reason why Suse should deny access from any liveCD.
 
Old 05-22-2007, 02:20 PM   #5
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
Hmm, I was definitely root. In anycase, I booted with SlaX and it worked immediately. No I need some help setting up the fstab again so that it works. If I try to boot suse, it stops with:
Code:
resume device /dev/sda5 not found (ignoring)
Waiting for device /dev/sda6 to appear.......................not found
This is the fstab as it lookes right now:
Code:
/dev/sda6            /                    reiserfs   acl,user_xattr        1 1
/dev/sda5            swap                 swap       defaults              0 0
/dev/sda4            /mnt/FAT32112        vfat       auto,users,rw,umask=0002 1 2
/dev/sda7            /mnt/reiserFS39      reiserfs   auto,users,rw,acl       1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs /proc/bus/usb usbfs noauto,devmode=0666 0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
Thanks in advance,
baking-a-77
 
Old 05-26-2007, 01:21 PM   #6
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
What changes do I have to make, so that it will boot and mount sda4 & sda7?
 
Old 05-26-2007, 07:18 PM   #7
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
If you are booting the latest Kubuntu there is a possibility that its installer still sees your Pata as hda but the installed kernel, 2.6.20 and later, sees all Pata as Sata disks.

Use Ubuntu and post here the output of
Code:
fdisk -l
See also if you could post /boot/grub/menu.lst in sda6. You need to mount it first if Ubuntu does not mount it for you
Code:
sudo mkdir /mnt/sda6
sudo mount /dev/sda6 /mnt/sda6
cat /mnt/sda6/boot/grub/menu.lst
 
Old 05-29-2007, 05:07 AM   #8
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
It is a SATA drive, so obviously it is recognized as one by the installed SuSE, Slax and also kubuntu (edgy) live cds.
Here is the information you wanted:
fdisk
Code:
ubuntu@ubuntu:~$ fdisk -l

Disk /dev/sda: 521 MB, 521240064 bytes
255 heads, 63 sectors/track, 63 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          64      508992    e  W95 FAT16 (LBA)
Partition 1 has different physical/logical endings:
     phys=(62, 254, 63) logical=(63, 94, 30)

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        3824    30716248+   7  HPFS/NTFS
/dev/sdb2            3825       11855    64509007+   5  Extended
/dev/sdb3           11856       15680    30724312+   7  HPFS/NTFS
/dev/sdb4           15681       30401   118246432+   b  W95 FAT32
/dev/sdb5            3825        4206     3068383+  82  Linux swap / Solaris
/dev/sdb6            4207        6817    20972826   83  Linux
/dev/sdb7            6818       11855    40467703+  83  Linux
ubuntu@ubuntu:~$ cat /media/usbdisk-1/boot/grub/menu.lst
menu.lst
Code:
ubuntu@ubuntu:~$ sudo cat /media/usbdisk-1/boot/grub/menu.lst
# Modified by YaST2. Last modification on Fr Jan 12 19:32:13 CET 2007

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,5)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE Linux 10.1
    root (hd0,5)
    kernel /boot/vmlinuz root=/dev/sda6 vga=0x317    resume=/dev/sda5  splash=si
    initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    chainloader (hd0,0)+1

###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN
    root (hd0,5)
    kernel /boot/xen.gz
    module /boot/vmlinuz-xen root=/dev/sda6 vga=0x317    resume=/dev/sda5  splas
    module /boot/initrd-xen

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE Linux 10.1
    root (hd0,5)
    kernel /boot/vmlinuz root=/dev/sda6 vga=normal showopts ide=nodma apm=off ac
    initrd /boot/initrd
Thanks for the help so far,
baking-a-77
 
Old 05-29-2007, 06:13 AM   #9
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
How can you boot sda6 when there isn't any sda6??? Just look at the output of fdisk -l...

You need root=/dev/sdb6 instead.
 
Old 05-29-2007, 11:38 AM   #10
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Disconnect the pen drive and try again.

Your bios is giving the pen drive first bootable status and it robs the sda disk designation from the internal hard disk.

Changing the Bios to boot the internal disk first also another alternative.

If in doubt, fire up a Live CD and activate a Grub shell and ask Grub to tell you the disk order as seen by it by
Code:
grub
geometry (hd0)
geometry (hd1)
The current setting is (hd0) has only one fat16 partition of type e and that to me is a pen drive.

Your Grub didn't work because it was installed in sda but a clever user stuck a pen drive in and told the Bios "please boot my pen drive first". So the internal hard disk has been relegated as sdb.
 
Old 06-02-2007, 11:51 AM   #11
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
Sorry, that I did not respond until now, because before the last two replies I tried to boot again and it worked, without me changing anything. sda4 and sda7, as SuSE recognizes them, are even mounted automatically.
Thanks again,
baking-a-77
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
newbie vs fstab. fstab wins :( blop Linux - Newbie 3 01-07-2005 06:54 AM
Suse 9.1: Not all entries in fstab are mounted at boot. why? BrianK Linux - General 9 08-23-2004 02:45 PM
(version 5.1 chapter 08 fstab) vs (man fstab) rgiggs Linux From Scratch 2 06-03-2004 06:55 PM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration