LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2007, 02:37 AM   #1
freyqqman
LQ Newbie
 
Registered: Mar 2007
Posts: 9

Rep: Reputation: 0
suse problem


I'm running suse 10.2. I was setting up multimonitors and it said to restart...so I did control + alt + backspace to do the quick restart thing. It got stuck in the middle so I did a hard restart. Now when I load suse it gives me a terminal screen and no gui. In the terminal, it asks for my name and password..after that its a regular terminal. How do I get my gui back? Thanks.
 
Old 03-12-2007, 03:24 AM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 32
Do a 'startx' command at the prompt and report any errors.
 
Old 03-12-2007, 12:52 PM   #3
freyqqman
LQ Newbie
 
Registered: Mar 2007
Posts: 9

Original Poster
Rep: Reputation: 0
tried that...it said that a startx server was already running

what I'm thinking is that the gui is up but not showing for some reason. For a split second between booting and switching to the terminal window, you can see a mouse pointer in the thinking animation.
 
Old 03-13-2007, 01:03 PM   #4
freyqqman
LQ Newbie
 
Registered: Mar 2007
Posts: 9

Original Poster
Rep: Reputation: 0
anyone know?
 
Old 03-13-2007, 02:22 PM   #5
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Your xorg.conf is now misconfigured. Maybe only a bit but that's all it takes I'm afraid.

If you restore it to what it was before you tried the dual monitor thing, I'm perfectly sure it will work again.
 
Old 03-13-2007, 02:24 PM   #6
freyqqman
LQ Newbie
 
Registered: Mar 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73
Your xorg.conf is now misconfigured. Maybe only a bit but that's all it takes I'm afraid.

If you restore it to what it was before you tried the dual monitor thing, I'm perfectly sure it will work again.
how would i do that though without any GUI? idk how to do that from the terminal =\
 
Old 03-13-2007, 02:57 PM   #7
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Sorry, but you really should 've made a back-up first (always always!). I could show you how to reach xorg.conf from a terminal but I suppose you're not familiar enough with Linux yet to write one from scratch or to identify what is wrong with your current one.

Your last hope is configuring a basic xorg.conf with some assistance from the OS; all you'd have to do is answer a number of questions and make selections from a few lists - but this does presuppose you're familiar enough with your hardware. For example, you'll need to know enough about
- the refresh rate(s) of the monitor
- screen resolution
- supported video card drivers
- type of mouse and keyboard
Just to mention a few.

Please note I cannot guarantee this will actually work for Suse (one distribution simply isn't the next one). If you're willing to take the plunge anyhow:
- boot up and select Suse from GRUB; do not press enter but e
- select the vmlinuz line and press e
- append the number 3 (preceded by a space) and press enter
- select the vmlinuz line and press b; you'll now boot into a terminal
- sign in as root
- first back-up your current xorg.conf (may be of little use as it is but it's good practice):
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
- then start up the configuration process by typing:
/usr/bin/xorgcfg (I believe you could also use /usr/bin/xorgconfig)
- go through the list of questions
- at the end, confirm you want the new file to be written out
- verify whether you were succesful by typing init 5 or startx

If you make any mistakes you can simply start over.

Again, I cannot guarantee that this will work; but I'm afraid it's really your last option so you may as well give it a try. It won't break any hardware (unless you do some utterly foolish things such a setting your refresh rates way way higher than your screen supports): the worst that could happen is that you end up where you started from.

Last edited by jay73; 03-13-2007 at 02:58 PM.
 
Old 03-13-2007, 03:44 PM   #8
spirit receiver
Member
 
Registered: May 2006
Location: Frankfurt, Germany
Distribution: SUSE 10.2
Posts: 424

Rep: Reputation: 33
In that terminal, log in as root, then type "init 3".

Use the command "yast2" to start the configuration program that you know already from the installation. It won't look as fancy in the console, but it'll work nonetheless. In the hardware section, you can try and configure your screen and graphics card settings. After that, you'll hopefully be able to start the graphical environment again with "init 5" or simply by rebooting. (You can reboot when you're logged in as root by using the command "reboot".)

Good Luck.
 
Old 03-13-2007, 04:22 PM   #9
freyqqman
LQ Newbie
 
Registered: Mar 2007
Posts: 9

Original Poster
Rep: Reputation: 0
eh nothing worked =\

i reinstalled suse but I'm having trouble getting xgl working again. I forgot how I did it. I'm stuck on the part where your suppose to install the radeon drivers (I have a 9600xt radeon). I got the drivers installed, but it says no 3d support. Anyone know how to fix this? THanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 02:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration