LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2004, 07:24 AM   #1
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Rep: Reputation: 15
SuSe personal 9.1 only boots from CD


I've just installed suse linux and I can boot the system from the CD and everything works fine. However, it won't boot from the hard disc - It loads something called GRUB in text mode and I just get a flashing cursor. Anybody know how to fix this? Linux is the only OS on the PC so it's not dual boot.


This is my first experience with Linux so really need help
 
Old 11-14-2004, 09:10 AM   #2
diddi_1013
LQ Newbie
 
Registered: Nov 2004
Distribution: suse 9.1
Posts: 6

Rep: Reputation: 0
hi there,

please post what type of hd you're using (scsi or ide) and the settings of the disks in the bios.
 
Old 11-14-2004, 09:31 AM   #3
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
HDD details

Err... I think its IDE, at least its plugged into the primary IDE slot. I'm afraid you'll need to explain the bios stuff in really simple language as I'm not sure what I'm looking for. The details of the hdd from belarc advisor are below. Is this any help?

SAMSUNG SV0431D [Hard drive] (4.30 GB) -- drive 0, rev MA10
Primary Bus Master IDE controller (dual fifo)
Secondary Bus Master IDE controller (dual fifo)
VIA Bus Master PCI IDE Controller
BIOS: Award Software International, Inc. 4.51 PG 10/15/99
 
Old 11-14-2004, 10:41 AM   #4
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
more hdd details

OK, I've checked and its definately IDE. In the bios its set to primary master, type AUTO, and mode LBA.

In the auto detect hd menu I found these settings

options size precomp landz sector mode
2(Y) 4310 0 8911 63 LBA
1 4312 65535 8911 63 Normal
3 4312 65535 8911 63 Large


Hope this means more to you than it does to me
 
Old 11-14-2004, 11:33 AM   #5
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
So you say you can get into the system, using the CD?!

Then try the following: Open a shell, login as root and type 'fdisk -l', this gives you all recognised partitions on your disk. Then have a look at /etc/fstab, which tell the system where to mount your filesystems to. Next, look at /boot/grub/menu.lst, where grub loads the kernel from. If you post the output of all three commands, we may get it running together

If you would like to try it yourself, make sure that the entry in grub (menu.lst) matches the location of the kernel. Grub uses a little different syntax, where hd0,0 is the first partition on the primary controller, from linux mostly recognised as hda1. hda2 would then be hd0,1.

Maybe you just installed the bootloader to the wrong location. The bootloader (grub) should be installed into the master boot record (MBR) of your primary harddisk. Have a look in Yast -> System -> Boot Loader Configuration and install it, if necessary.
 
Old 11-14-2004, 12:44 PM   #6
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
latest

OK, I finally figured out how to open the shell and entered fdisk -1. I got the following

fdisk [-bSSZ] [-u] DISK Change partition table
fdisk -1 [-b SSZ] [-u] DISK list partition tables
fdisk -s partition
fdisk -v give fdisk version

Here disk is something like /dev/hdb or /dev/sda and partitions are something like /dev/hda

Tried running other commands but got a permission denied message for all, even though I logged in as root.

I then looked in YAST at the boot loader configuration. It said its located at 1.IDE, 4.01 GB, dev/hda
The activate boot loader partition is set to 'no', and the replace code in MBR option is set to 'leave untouched'.

I used YAST to find the partitions and there seems to be two:
/dev/hda2 3.7 GB/for with reiser
/dev/hda1 293.6MB (for swap)

Any help??
 
Old 11-15-2004, 03:15 AM   #7
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
What I meant was fdisk -l (with a small 'L' like in 'small').

The other 'commands' weren't commands but configuration files. You need to open them in an editor. To simply show their content, you could type

cat /etc/fstab or less /etc/fstab
cat /boot/grub/menu.lst or less /boot/grub/menu.lst (The later command shows a scrollable output)

The important part in Yast is the entry 'Boot Loader Location' This should point to the HDD you have installed Linux on (looks good in your case). If you highlight the entry and press 'Edit', the option should be set to 'Master boot record of <your drive>'. I am not sure about this option 'Leave untouched', maybe you need to set it to 'replace'. But check first fstab, fdisk -l and menu.lst, if those entries are okay.
 
Old 11-15-2004, 12:06 PM   #8
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
next attempt

Sorry about the confusion but I've now managed to do what you asked. Output as follows:

fdisk -l
Disk /dev/hda: 4311 MB, 4311982080 bytes
15 heads, 63 sectors/track, 8912 cylinders
Units = cylinders of 945 * 512 = 483840 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 637 300951 82 Linux swap
/dev/hda2 * 638 8903 3905685 83 Linux
linux:/home/Steve #

less /etc/fstab
/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda1 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,
nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,
nosuid,sync 0 0

less /boot/grub/menu.lst
color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,1)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2 vga=0x31a splash=silent desktop r
esume=/dev/hda1 showopts
initrd (hd0,1)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
root (fd0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2 showopts ide=nodma apm=off acpi=o
ff vga=normal noresume nosmp noapic maxcpus=0 3
/boot/grub/menu.lst lines 1-21/22 95%

Hope this helps
 
Old 11-15-2004, 12:52 PM   #9
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Everything looks perfect!

From this data I cannot see why it is not working. Maybe you should reinstall grub. I am sorry that I do not have any other ideas...wait, you could check if /boot/grub/device.map shows the correct record of you drive. It should look like this:

Code:
(hd0)	/dev/hda
(fd0)	/dev/fd0
Have a look at this for further information.

Good luck!
 
Old 11-15-2004, 01:59 PM   #10
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
Hi again, thanks for your help so far. The output lists what you said it should. I ran the yast repair system and reloaded the boot loader, but no difference.

Oh well, if you think of something......

Thanks anyway
 
Old 11-15-2004, 02:30 PM   #11
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Maybe something...:

I found the chapter 'Possibilities of the Grub Boot Menu' in my link from above quite interesting. Maybe you could use the TAB trick or find the kernel with 'find /vmlinuz'

If you could boot the kernel from the grub command line, it would be a good starting point at least.
 
Old 11-15-2004, 02:40 PM   #12
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
I tried the find /vmlinux command and find /boot/vm linux and for both I got a file not found message

 
Old 11-16-2004, 03:29 AM   #13
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
I am running out on ideas. We have a similar thread where someone seems to have an installation without kernel ?!?

Sorry!
 
Old 11-16-2004, 12:19 PM   #14
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
Thumbs up Good News

OK, its now all sorted out. Someone at work suggested that Linux miight not like my hdd set to LBA - whatever that actually means - so I went into the bios and changed the mode to Normal. I rebooted and almost immediately got the grub graphical boot menu on screen. I chose linux and it loaded without a problem.

Thanks for all the help and advice along the way. I might even consider loading suse on my main xp machine in a dual boot setup now. However, I think I'll first buy some software to backup the disc image.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 8.2 Boots to CLI not to GUI porkchopexpress Linux - Newbie 5 06-22-2005 09:27 AM
SUSE 9.2 boots to Bash lt_wentoncha Linux - Newbie 6 04-13-2005 05:49 AM
Need Help installing SUSE 9.1 Personal, after install and boot Windows boots krko Linux - Software 0 01-07-2005 09:26 AM
Installed SuSE, XP no longer boots Cloud Linux - General 4 07-14-2004 12:26 AM
Windows ME no longer boots after SuSe 9.0 personal installed succesfully... 75monkeys Linux - Newbie 12 05-23-2004 07:34 PM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration