LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2004, 12:56 AM   #1
riguy
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
Question Suse Linux 9.1 yast root logon??


I recently installed Suse linux 9.1 onto my windows me computer, and it has been working perfectly for this whole time, until now. I accidentally pressed some key combination (or at least I think) while logged on as the root, and it took me to a screen that just had yast on it. I tried all kinds of key combinations that could've got me in there, and nothing worked. I tried restarting my computer and logging back into the root account, but it would give me the same window. I can't get to the desktop, or anything, but yast. Does anyone know how I can get back to using my root account normally?

Thanks
Riguy
 
Old 08-10-2004, 04:29 AM   #2
Marius2
Member
 
Registered: Jan 2004
Location: Munich
Distribution: SuSE 9.2, 10.2, 10.3, knoppix
Posts: 276

Rep: Reputation: 31
1. You're probably talking of key combination Ctrl+Alt+F[n], which takes
you through the different consoles and X Display (F7). Hit Ctrl+Alt+F[1-6]
and you should end with a console.

2. To end YaST: As root, type pstree -p. Search all the lines where the process
belongs to yast (like YaST, y2base...). Get the related number in brackets (the
PID) and type kill <PID>, and if that doesn't help, kill -9 <PID>.

HTH
 
Old 08-10-2004, 01:07 PM   #3
riguy
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for your help, but sadly, that did not work. I got to the console, and I found the yast2 pid, but when I killed it, it just logged me off and when I logged back in, it would still be the yast screen. I tried killing a number of other programs related to yast (the yast control console, kdm, processes above in the directory) but none of them worked. Every time I ended one of the yast programs, it logged me off. I also ended kdm, and that left me in the console, though it did end yast. Since I don't have any files or anything important on my computer, is there a way I can reinstall linux and overwrite the old information? Do all I need to do is run the installation process again from the cd?

Riguy
 
Old 08-10-2004, 01:25 PM   #4
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
then this would be a simple configuration issue
does this happen when u log in as normal user?
whats in your /etc/profile and /root/.bash_profile and /root/.bashrc

<EDIT>
I don't mean paste the entire files, just is there anything ina ny of those relating to YaST?
</EDIT>
 
Old 08-10-2004, 04:11 PM   #5
riguy
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
All of those directories had an error opening, and I couldn't get any information from them. I think I'm just going to try reinstalling.
 
Old 08-21-2004, 07:38 PM   #6
Shaddow
LQ Newbie
 
Registered: Aug 2004
Distribution: Suse 9.1 Pro
Posts: 2

Rep: Reputation: 0
I have also been having this exact same problem (also running Suse 9.1 Pro). I've tried checking those files, but there's no mention of YAST in /etc/profile, and /root/.bash_profile and /root/.bashrc don't exist on my system. With those /root/bash* files, it's not the case that they're simply hidden and I'm not seeing them, but I know that they really aren't there since I can see other /root/.* files including .bash_history. Is there anything else you'd recommend I check?

I've also looked at all the different kdm and xdm config files and everything looks as though it should load KDE for every user. If possible, I would _really_ like to not have to re-install, since I've already put a lot of effort into getting my system just like I want it.

As a side note - This first happened for me when I was logged in as my normal (non-root) user, but then tried to use the "Switch User" action on the main KDE panel menu and switch to root. Once I did that, it loaded YAST (which confused me like crazy, since I wasn't expecting that), and my system has done that every time I've tried to log in as root. Thanks in advance for your help!!!

---Brian (a newbie)
 
Old 08-22-2004, 07:26 AM   #7
deko
Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
When you switch user, if you click on the "administrator" button and then enter your password, you will be taken straight to the YAST window. For all subsequent login's as root in the future you'll end up going the same way. So try this.

At the login screen, login as root/yourpassword and before pressing enter, go to the menu drop down and select session type > kde

Now login and you should be back in full KDE mode.

Hope that helps

d.
 
Old 08-22-2004, 11:57 PM   #8
Shaddow
LQ Newbie
 
Registered: Aug 2004
Distribution: Suse 9.1 Pro
Posts: 2

Rep: Reputation: 0
Sweet! That seems to work wonderfully! I haven't taken the time to see if that's a more permanent fix or if I'll have to do that every time, but it suits my needs for now. Thanks again!!!

---Brian
 
Old 08-23-2004, 03:11 AM   #9
DonaldUK
Member
 
Registered: Apr 2004
Posts: 97

Rep: Reputation: 15
Hello,

I've been having the same problem. Trouble is the menu drop down menu does not contain an option to set for kde. It only has - restart Xserver and shutdown as the options.

Donald
 
Old 08-23-2004, 03:04 PM   #10
deko
Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
Quote:
Trouble is the menu drop down menu does not contain an option to set for kde. It only has - restart Xserver and shutdown as the options.
Look to right of session type, you should see a flyout arrow, hover over it and another menu will appear, you should see KDE here.

Quote:
I haven't taken the time to see if that's a more permanent fix or if I'll have to do that every time
When you do it once it remembers. As proof you can just try clicking the administrator button again, logging in, and bam! Back in YAST. Close YAST and login again as root whilst selecting KDE from the session type flyout and you'll end up back in the full KDE environment (Bomberman wallpaper and all!)

d.
 
Old 08-24-2004, 01:30 AM   #11
DonaldUK
Member
 
Registered: Apr 2004
Posts: 97

Rep: Reputation: 15
Deko,

I'm sorry but there is no menue item called session type in the menu list - only restart X server and shutdown.

Donald
 
Old 08-24-2004, 04:19 AM   #12
deko
Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
Weird...what about trying to login as root from the start? (i.e. not through switch user once logged in)

Can you see the session type from there?
 
Old 08-24-2004, 12:18 PM   #13
remotemate2003
LQ Newbie
 
Registered: Aug 2004
Location: India
Distribution: all linux
Posts: 21

Rep: Reputation: Disabled
Thumbs up

This is what I just posted on Suse forum

To all the people who gets to YaST when logging in as 'root' in suse 9.1

1. At the GUI log in prompt
2. ctrl+alt+F1
3. Log in as root
4. rm /tmp/.X0-lock (if you get file not found, srun startx command and then rm /tmp/.X0-lock)
5. startx
6. You've done it!! you are in KDE as 'root'

Another solution:

1. Changing option in /etc/opt/kde3/share/config/kdm/kdmrc

HideMenu = true (it was false, this gives list of DEs at the login prompt)

in the secton in kdmrc :

[X-:*-Greeter]
AdminSession= (I removed YastAdminSesion)
HideMenu=true

This helped.

:-)
 
Old 08-25-2004, 01:16 AM   #14
DonaldUK
Member
 
Registered: Apr 2004
Posts: 97

Rep: Reputation: 15
Thanks remote, a nice way of getting around the problem. Your first idea worked fine for me, but changing the kdmrc file doesn't seem to havedone anything.

Donald
 
Old 08-26-2004, 02:49 AM   #15
remotemate2003
LQ Newbie
 
Registered: Aug 2004
Location: India
Distribution: all linux
Posts: 21

Rep: Reputation: Disabled
Oops!

Sorry make that:

HideMenu=false

Cheers!

Jigish
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing YAST-2 on SUSE/Linux 10 csaba911 Linux - Networking 1 11-13-2005 08:22 AM
Frustrated Newbie: Mouse doesn't start on boot & can't logon except as root. SuSE 9.3 archiesmiley Linux - Newbie 2 06-09-2005 02:37 PM
SuSE 9.2; 'root' default's to YaST jimbrook SUSE / openSUSE 1 06-04-2005 05:15 AM
Suse dontīt boot X; donīt ask for root passwd, YAST donīt work... carrie Linux - Newbie 4 10-08-2004 07:46 AM
only yast at suse root login Tinny Linux - Distributions 1 09-04-2004 01:29 PM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration