LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-30-2005, 07:57 PM   #1
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Rep: Reputation: 15
Unhappy SUSE--Can't connect to the internet


I just installed opensuse 10.0. I seem not to be able to connect to the internet at all. I have a sbc yahoo local network (wife's pc, my laptop, now my desktop with SUSE). How do I go about configuring my desktop to allow me to connect to the net with my browser/email, etc?

Thanks.
 
Old 11-30-2005, 07:59 PM   #2
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
I go into Yast, network card overview . . .

Actton EN-1207D Fast Ethernet Adapter, started automatically at boot

but I can't seem to connect. I'll try to reboot and mess around some more, but if anyone has suggestions I'd appreciate 'em.
 
Old 11-30-2005, 08:06 PM   #3
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Well more info is needed, how are the machines connected to the net? which device do you use? router, modem etc.

You may have to set DHCP (should be in Yast somewhere), or if the device doesn't support it you could assign a manual ip address use the router ip as the gateway and DNS if you dont know them for your IP.
 
Old 11-30-2005, 08:59 PM   #4
cousinlucky
Member
 
Registered: Nov 2005
Location: Staten Island N.Y.
Distribution: Antix 16 and PCLinuxOS Mate
Posts: 242

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
At http://cdb.novell.com you can do an express search to find the modem your machine would need to connect to the Internet through SUSE Linux 10.

Good Luck!

cousinlucky
 
Old 11-30-2005, 09:42 PM   #5
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
SBC Yahoo DSL w/ router, modem, wifi in one (wireless package), all set up and working (both other computers connect fine).

PPPoEthernet


I'm afraid that's about all I know . . . I'm in the dark here.
 
Old 11-30-2005, 09:57 PM   #6
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
what does ping 72.14.207.99 give? (Google - to see if it's a DNS problem)

check the network settings to make sure the machine is on the right subnet.
login as root with path:

su -
<password>

ifconfig

post the output for a machine that works and the one that doesn't
 
Old 11-30-2005, 10:53 PM   #7
cousinlucky
Member
 
Registered: Nov 2005
Location: Staten Island N.Y.
Distribution: Antix 16 and PCLinuxOS Mate
Posts: 242

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
I am new to SUSE Linux 10 but while configuring the system I remember it saying there was a wall between networks while a computer was connected to the Internet. I could/very well might be very wrong here but try to set up you desktop to the Internet without the other computers on board.

cousinlucky
 
Old 11-30-2005, 11:11 PM   #8
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
I'm going to try to install 10.1a3 to see if that can correct the problem. If so, I'll check the network configs to see what the difference is . . . if it helps and I can figure it out, I'll try to reinstall 10.0 and go from there. Thanks for the help so far guys.
 
Old 12-01-2005, 03:26 AM   #9
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
a3? as in alpha?? before beta?? :P

It may fix your problem, it may cause a load more too. It looks to me something as simple as network settings but if you want to try a newer version then post back how you got on.
 
Old 12-01-2005, 07:19 PM   #10
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
I installed 10.1a3 and had the same issue, so I reinstalled 10.0 and gave this another shot.


In Konsole, I tried to ping google, and I received "connect: Network is unreachable"

My ifconfig for the desktop is:

eth0 Link encap: Ethernet HWaddr 00:10:B5:F2:BA:3B
inet6 addr: fe80::210:b5ff:fef2:ba3b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4707 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:291001 (284.1 Kb) TX bytes:1314 (1.2 Kb)
Interrupt:5 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr" ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:212 errors:0 dropped:0 overruns:0 frame:0
TX packets;212 errors:0 dropped:0 overruns:0 carrier:0
collisions:- txqueuelen:0
RX bytes:14240 (13.9 Kb) TX bytes:14240 (13.9 Kb)

I've seen several other threads that have similar questions (including one just asked today), but I can't seem to get this working. Thanks for the help so far!!
 
Old 12-01-2005, 07:25 PM   #11
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Looks like there's no ip/subnet set. Probably because it's set to recieve them via DHCP and if your device doesn't do that you will need to go into the yast networking part and configure a manual IP/subnet mask (ipconfig in windows on another machine to find the info).

My apologies, i have never used Suse, so i am sketchy about what Yast can do for you
 
Old 12-01-2005, 07:31 PM   #12
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
Alright, I've checked ipconfig in windows and have
Connection-specific DNS suffix
IP address
subnet mask
default gateway

As soon as I get back (I'm head out in a minute), I'll open up yast and see what I can do in there.
 
Old 12-01-2005, 07:44 PM   #13
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
you should have a radio button for DHCP or manual, choose manual enter the data
 
Old 12-01-2005, 10:39 PM   #14
cartwright
LQ Newbie
 
Registered: Nov 2005
Distribution: openSUSE 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
Hm, I'm not sure I'm doing this in the right place. In yast, I go to Network devices, Network card, then click on the Accton ethernet adapter . . . change from automatic address setup (via DHCP) to manual static address . . . enter in the IP address/subnet mask . . . then changed the gateway to the default gateway.

Then I saved all configs, opened up firefox . . . and nothing, couldn't connect. Am I missing a step here?
 
Old 12-02-2005, 01:34 PM   #15
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Make sure you changed it for the right interface (eth0) then reboot.

do ifconfig again and post it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot connect to internet with suse 9.2 randon SUSE / openSUSE 2 08-08-2005 01:10 PM
SUSE 9.2 Connect to the Internet! limp15000 Linux - Networking 11 12-14-2004 02:58 AM
Suse: Can't connect to internet hlinux Linux - Software 3 08-01-2004 05:28 PM
How to connect SUSE to internet? dweller Linux - Newbie 2 07-09-2004 02:48 PM
HELP!!! can't connect to the internet w/ SuSE msh81 Linux - Networking 1 06-19-2003 04:23 PM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration