LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-15-2005, 04:41 AM   #1
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Rep: Reputation: 30
suse 9.3 pro: turning off swap - missing


Hello?

In SuSE 9.3 Pro, during a system turn off process
at the logout, I always get "turning off swap - missing"
message.

How can I correct this? That is, how can I make sure
I have my swap partition on automatically to begin with
during the boot up process so that I do not get this missing
message at the swap turn off process during system off stage.

Thanks.
 
Old 05-15-2005, 08:53 PM   #2
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
If you have a swap partition it should be added to fstab:
/dev/hda3 none swap sw 0 0
 
Old 05-16-2005, 12:35 AM   #3
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi Moloko,

Thanks for your input. Actually, I have two swap partitions;
one from FC3 and another from SuSE 9.3 Pro. Each distro
exists on its own separate hard drive.

However, it is from SuSE 9.3 Pro that displays this "turning off
swap - missing" message during a logout process. I have the
following lines from /etc/fstab (SuSE 9.3 Pro):

(for FC3 swap partition)
/dev/VolGroup00/LogVol01 swap swap pri=42 0 0

(for SuSE 9.3 Pro swap partition)
/dev/hdd1 swap swap pri=42 0 0

But, I do not know what's wrong with these lines.

Could someone comment? Or, any other idea how I can correct
the message during the logout process from SuSE 9.3?

Thanks.
 
Old 05-16-2005, 02:04 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,832

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
Try the following and see if you have swap working o.k.
Code:
dmesg | grep swap
swapon -s
 
Old 05-16-2005, 11:14 AM   #5
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi syg00,

Thanks for your interest in this issue.

I believe my swap's working fine. The following
is the result from your asked commands:

dmesg | grep swap
Adding 2031608k swap on /dev/VolGroup00/LogVol01. Priority:42 extents:1
Adding 1052216k swap on /dev/hdd1. Priority:42 extents:1

swapon -s
Filename Type Size Used Priority
/dev/mapper/VolGroup00-LogVol01 Partition 2031608 0 42
/dev/hdd1 Partition 1052216 0 42

But still, I get the same "truning off swap - missing" message during
logout process in SuSE 9.3 Pro.

I'd appreciate if anyone has any idea where this message's coming from,
or how to resolve this issue such that I do not have that "missing" message
during the logout process.

Thanks much.
 
Old 05-16-2005, 11:53 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
I thing the message comes from the attempt to use both available swap partitions the same time. Are you using the same /etc/fstab for both OS's? Otherwise try to delete the FC3 swap from SUSE's fstab.

EDIT: I don't know if it is possible to use two swap partitions on one system, but the error comes most probably from the FC3 device-node (/dev/mapper/VolGroup00-LogVol01) that does not exist on SUSE (or has another identifier).

Last edited by abisko00; 05-16-2005 at 11:56 AM.
 
Old 05-16-2005, 03:07 PM   #7
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi abisko00,

Thanks for your insigtful feedback.

Actually, I initially thought along your line of reasoning,
but I decided not to play with what SuSE had already
configured in the /etc/fstab during its installation.

Now, I just tried what you suggested, but this still doesn't
resolve the issue. That is, I still have the "turning off swap -
missing" message during the logout process.

Basically, FC3 was in existence first on my system and later
came the SuSE 9.3 Pro. Now, SuSE 9.3 Pro's Grub lives in
my system's MBR.

Does anybody have any idea or solution?

Thanks.
 
Old 05-16-2005, 05:58 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,832

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
Try doing a swapoff for the FC3 swap, then shutdown.
If the message goes away, comment out the line from fstab. There's no reason to consider it sacred, just because an installer created it...
 
Old 05-16-2005, 08:00 PM   #9
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi syg00,

Thanks for your feedback.

Actually, there's no FC3 swap partition to turn off now as
there's only one SuSE swap partition in the /etc/fstab.

But, still the "turning off swap - missing" message is displayed
during the system shutdown.

I'm also noticing the following message during the startup:

waiting for device /dev/VolGroup00/LogVol01 to appear ...
resume /dev/VolGroup00/LogVol01 not found (ignoring)

This message could've been there all along from the beginning,
but I just noticed it now.

Could this be the reason why I'm getting the "missing" message
during the shutdown? If so, where's this line coming from? Kernel?
System?

By the way, when I tried to mount this swap partition to "swap"
in Yast's LVM tool, I get an error that says, "could not set up swap
partition /dev/VolGroup00/LogVol01".

Can Linux have multiple swap partitions? If so, can a swap partition
be a logical partition in an extended volume as in this case of FC3/SuSE 9.3 Pro?

Thanks.
 
Old 05-16-2005, 09:52 PM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,832

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
Linux can handle multiple swaps, and they can be in an extended partition.
Can't advise about LVM, as I haven't, as yet, bothered with it.

I did a quick check of the source tree (2.6.11), and couldn't find any obvious candidate for your message - I wonder if it's being issued by a Suse shutdown script.
I don't do Suse, so I don't know what they use, or where you could look.
 
Old 05-16-2005, 10:04 PM   #11
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi syg00,

Thanks for your prompt reply. Great!

So, the issue now is the message at the boot and
shutdown as follows even without the mentioning
of the FC3 swap partition in SuSE 9.3 Pro's /etc/fstab:

[boot]
waiting for device /dev/VolGroup00/LogVol01 to appear ...
resume /dev/VolGroup00/LogVol01 not found (ignoring)

[shutdown]
turning off swap - missing

Here, the VolGroup00 is the extended volume created
by FC3 automatically by default during its installation
as well as the LogVol01 logical partition.

And, why SuSE 9.3 Pro's Yast LVM tool doesn't allow
FC3's logical swap partition as swap when LVM itself
sees the logical partition of FC3's.

Does anyone have any idea or solutions?

Thanks.
 
Old 05-17-2005, 05:10 PM   #12
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
If Suse only uses the /dev/hdd1 as swap it shouldn't even attempt to use the swap of FC3. It's either in the fstab file or a startup script. Unfortunately, I'm also not familiar with the quirks of Suse.

Could you post your fstab file?
 
Old 05-17-2005, 11:15 PM   #13
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi Moloko,

Thanks for your interest in this issue.

Actually, I found out why I got the following message
during boot:

Waiting for device /dev/VolGroup00/LogVol01 to appear: ...
resume /dev/VolGroup00/LogVol01 not found (ignoring)

This is because of SuSE's default kernel option such as
resume=/dev/VolGroup00/LogVol01.

If I delete this resume kernel option, I no longer see
that message during boot.

However, it's still a puzzle why SuSE displays the message
"turning off swap - missing" during system reboot/shutdown.

Here is my current /etc/fstab:

#SuSE 9.3
/dev/hdd2 reiserfs acl,user_xattr 1 1

#FC3's boot partition
/dev/hdc1 /data1 auto noauto,user 0 0

#WinXP
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0

#SuSE 9.3 - swap
/dev/hdd1 swap swap pri=42 0 0

devpts /dev/pts devpts mode=0620,gid=5 0 0

proc /proc proc defaults 0 0

usbfs /proc/bus/usb usbfs noauto 0 0

sysfs /sys sysfs noauto 0 0

/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nodev,
exec,iocharset=utf8 0 0

/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,
nosuid,sync 0 0

#FC3
/dev/VolGroup00/LogVol00 /fc3 ext3 defaults 1 2

And, when I do dmesg | grep swap, I get the following result:
Adding 1052216k swap on /dev/hdd1. Priority:42 extents:1

And, swapon -s gives me the following result:
/dev/hdd1 Partition 1052216 0 42

So, I hope this gives some hints for resolving my issue.

Thanks.
 
Old 05-18-2005, 04:07 PM   #14
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hello?

In the /etc/init.d/boot.d, I found two script files:
K17boot.lvm and S07boot.lvm. These files appear
to turn on logical partitions, and FC3's swap partition
happens to be a logical partition.

Not knowing the difference in K-something and S-something
scripts, I looked at the contents of these files, and they look alike.

Just out of curiosity, I executed some command lines out of K17boot.lvm file,
and they indeed turn on FC3's swap partition, I think. So, could this be
the reason why FC3's swap partition is turned on automatically even though
I do not reference it in the /etc/fstab? But then, how come turning it off doesn't
work if the FC3's swap is turned on automatically during boot?

Also, when the resume kernel option for FC3's swap partition is included
during boot, how come SuSE reports it as not found and ignore it eventually?

I'm a bit perplexed now ...

Anyway, I hope someone could pinpoint where and what to look in startup/
shutdown scripts and correct any anomalies to correct this "turning off swap -
missing" message.

If Linux allows multiple swap partitions even if they're logical partitions under
extended volumes, I'd like to leave them untouched as SuSE had found them
during the boot process.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Turning off swap! jackelin Linux - General 1 06-01-2005 11:46 PM
Swap Partition in SuSe 9.1 Pro is increasing radicaly and causing system to crash tontito_tx Linux - Newbie 3 02-28-2005 01:47 PM
How can I check whether I have a swap partition in Suse Linux 9.2 pro? pujolasdf Linux - Software 10 02-13-2005 06:24 PM
Suse 9.1 Pro not using my swap partition ToBe SUSE / openSUSE 12 12-09-2004 03:05 PM
SUSE 9.0 Pro - Blank Install Screen & Missing Memory Xriva Linux - Laptop and Netbook 4 03-16-2004 01:18 PM


All times are GMT -5. The time now is 06:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration