LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2005, 10:26 AM   #1
njdouglas
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
SUSE 9.2 Prof wont boot into X


Hi,

I've just installed SUSE 9.2 Prof and am using it as a file server with SAMBA. After it was all up and running I decided to update the graphics card driver (an onboard SIS 730) using the RPM from the SIS website as the current driver was producing ghosting on the monitor. I installed the RPM using YAST and then rebooted. Now instead of arriving at a GUI login prompt, i just get a command line prompt to login and I'm told that runlevel 5 has been skipped. I can still login to a command prompt and SAMBA still works fine. I tried the command "startx" and the prompt and recieved an error stating that the system couldnt find the config file and that a fatal server error had occurred. I know linux keeps log files of all these erors but i dont know where to look and also how do I repair X?

Please be gemtle as im new to linux!!

Thanks in advance

njdouglas
 
Old 03-23-2005, 11:52 AM   #2
8years@Linux
LQ Newbie
 
Registered: Mar 2005
Location: PA
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
try xorgconfig or xf86config that rubuilds your X config file.

or try telinit 4 for X login
 
Old 03-23-2005, 12:07 PM   #3
youngtom
Member
 
Registered: Feb 2005
Location: Rio de Janerio
Distribution: suse 9.1, suse 9.2, redhat enterprise, ubuntu, kubuntu
Posts: 104

Rep: Reputation: 15
sounds like you need to reconfigure for you new video card

login as root and run 'sax2 -l' to reconfigure the display then type 'init 5' and hopefully X should start up.

This might be useful - http://portal.suse.com/sdb/en/2002/01/wessels_sax2.html

Last edited by youngtom; 03-23-2005 at 12:12 PM.
 
Old 03-23-2005, 01:33 PM   #4
njdouglas
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks to all who replied, youngtom you is the man, worked a treat using sax2 -l. However I still get ghosting and im not sure how to check the new driver is in use and not the default linux one. Any ideas??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot boot SuSE v9.3 Prof or XP Jongi SUSE / openSUSE 5 09-09-2005 05:49 AM
Problem with SUSE 9.2 Prof/Windows XP Prof Dual Booting sm000ve Linux - Newbie 1 11-29-2004 08:21 PM
suse 9.1 prof to suse 9.2 prof update? ronss SUSE / openSUSE 4 11-04-2004 08:54 AM
SuSE prof 9.0 upgrade: X wont work Recirqie SUSE / openSUSE 2 10-26-2004 07:49 PM
install Suse, xp wont boot, repair xp suse wont boot Tangz Linux - Newbie 10 07-16-2004 06:37 PM


All times are GMT -5. The time now is 01:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration