LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2005, 10:12 AM   #1
klodoma
LQ Newbie
 
Registered: Nov 2004
Posts: 12

Rep: Reputation: 0
Suse 9.1 prof, special characters problem


Hi to all,

I have just installed Suse 9.1 Prof, we were using until this moment 8.2 professional. We make a php management software which is used in German and French languages.

Now the problem is that since I installed 9.1 the "" and other special characters from French language are not displayed correctly. If I look with MC in the translation file (we use gettext for translation) then I don't see the char correctly. if I look from a windows system the character is correctly in the file.

I read on the Internet that 9.1 uses the UTF 8 encoding by default. I deactivated it, and after this with MC(midnight commander) I saw correctly the character in the file. But over APACHE it is still not shown correctly. So we have a problem.

I read some articles on the Internet over this but couldn't find any right solution.

Need some help.

Thanks in advance.
Andy.
 
Old 09-25-2005, 11:01 AM   #2
cheesus
Member
 
Registered: Jan 2005
Location: Munich, Germany
Distribution: SuSE
Posts: 184

Rep: Reputation: 25
if you have apache2, check that the mime conf sais
AddDefaultCharset Off
(default is latin1!)
or else your HTTP-EQUIV charset setting will be overridden by
the stupid apache2 default setting.

(or set it to whatever ALL of your files are encoded with...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Special characters problem MartinZ SUSE / openSUSE 5 07-12-2011 10:21 PM
problem with c++ in Suse Prof. 9.3 crapodino Programming 3 09-25-2005 10:54 AM
cups problem - special characters kentri9 Linux - Software 2 02-23-2005 05:08 AM
grep problem in extracting special characters imppayel Programming 8 12-02-2004 08:28 AM
Problem with SUSE 9.2 Prof/Windows XP Prof Dual Booting sm000ve Linux - Newbie 1 11-29-2004 08:21 PM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration