LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2004, 11:08 AM   #1
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Rep: Reputation: 0
suse 9.1 networking problems


i've done a lot of searching, and nothing seems to answer this question/problem:

i have a home network of 2 computers, one dual-boot suse/xp laptop and an emac running osx. networking works fine on the emac and windoze side of the laptop. pinging local machines also works fine on suse. however, when i try to get at a machine outside my network (google.com, whoever), i can't reach it.

ifconfig brings up normal stuff, shows me sending and receiving packets, etc., but at the bottom it says "Interrupt:11" for eth0.

route is also normal, except the gateway column is all starred out.

any help? i would post the direct output of those bash commands for you guys, but i'm running low on cd-rs and that's the only way i can get the files from my laptop to my mac...
 
Old 08-27-2004, 11:32 AM   #2
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
Set your gateway route by using the 'route add' command, along with the network information and proper switches. It sounds like your not having a problem with your IP address, but if you are, I suggest using the dhcpcd or dhclient scripts, that is if your using DHCP.

Good luck, Hope that was helpful
 
Old 08-27-2004, 11:42 AM   #3
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
sorry... i'm kinda (well, really) a newbie at linux. so you'll have to walk me through bash commands exactly...
 
Old 08-27-2004, 12:20 PM   #4
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
no problem.

Check your /etc/sysconfig/network. make sure there is an enrty for GATEWAY=x.x.x.x
 
Old 08-27-2004, 12:24 PM   #5
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
i assume you mean to check via konqueror in that directory, yes?
when i do, i can't find anything about a gateway, even in any of the config files.
 
Old 08-27-2004, 12:41 PM   #6
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
ok, you want to add and entry in that file that says:
GATEWAY=192.168.1.1
or whatever your gateway is.
 
Old 08-27-2004, 12:53 PM   #7
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
which file? there are a bunch of files in the directory your pointed to.
 
Old 08-27-2004, 01:02 PM   #8
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
/etc/sysconfig/network the file is called network
 
Old 08-27-2004, 01:04 PM   #9
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
sorry, I forgot your using Suse. here is a link that will describe how to configure your settings. http://portal.suse.com/sdb/en/2002/0...network80.html
 
Old 08-27-2004, 02:02 PM   #10
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
Post the exact contents of ifconfig -- you should see an IP address associated with eth0. If not, try bouncing eth0
Code:
ifconfig eth0 down
ifconfig eth0 up
ifconfig
Hopefully you will see an IP address. If not, another possibility is that DHCP isn't running. I'm working from memory here but to restart it
Code:
dhcpcd -r eth0
Note I may not have that right so please check the man pages first. It may look like things are just waiting; if so, Ctl-Z to get out of it and return to the prompt. Rerun ifconfig and see (again) if you have an IP. Good luck with it -- J.W.
 
Old 08-27-2004, 02:14 PM   #11
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
sorry, but that help address may as well be in french... i can't figure out what to do with its instructions at all
 
Old 08-27-2004, 02:23 PM   #12
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
this is what ifconfig says:

eth0 Link encap:Ethernet HWaddr 00:0BB:943:80
inet addr: x.x.x.x Bcast:24.150.127.255 Mask:255.255.240.0
inet6 addr: fe80::20b:dbff:fe94:d380/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2338 errors:0 dropped:0 overruns:0 frame:0
TX packets:786 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:654370 (639.0 Kb) TX bytes:81974 (80.0 Kb)
Interrupt:11

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:126 errors:0 dropped:0 overruns:0 frame:0
TX packets:126 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8908 (8.6 Kb) TX bytes:8908 (8.6 Kb)

Last edited by zed13; 08-27-2004 at 02:28 PM.
 
Old 08-27-2004, 03:54 PM   #13
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
what does your route output look like type: route and post what you see.
 
Old 08-27-2004, 04:07 PM   #14
zed13
LQ Newbie
 
Registered: Aug 2004
Distribution: suse 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
i don't want to waste another cd to get files from my laptop to this computer, so...
Code:
destination    gateway        genmask             flags      metric      ref          use      Iface
24.36.x.x        *                   255.255.254.0   U           0           0         0        eth0
link-local       *                   255.255.0.0       U           0          0           0       eth0
loopback       *                   255.0.0.0           U            0           0         0       lo
default         24.36.x.x       0.0.0.0               UG         0           0          0        eth0

Last edited by zed13; 08-27-2004 at 04:08 PM.
 
Old 08-27-2004, 05:16 PM   #15
dallas121979
LQ Newbie
 
Registered: Aug 2004
Location: Texas
Distribution: Slackware 10.0
Posts: 12

Rep: Reputation: 0
route add -net 192.168.1.0 -netmask 255.255.255.0 -gw 192.168.1.1 dev eth0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSe Ethernet Networking Problems jacobt SUSE / openSUSE 18 11-02-2005 11:06 PM
Networking problem after SuSE 8.1 to SuSE 9.3 upgrade chiyoung_ku SUSE / openSUSE 2 06-02-2005 11:14 AM
suse 9.2 networking problems nettoon Linux - Networking 11 03-15-2005 09:33 AM
suse 9.2 networking on a laptop problems trainer0242 SUSE / openSUSE 1 12-10-2004 06:22 AM
problems with Networking with SUSE 9.1 guest on VMWARE on W2K host blackbirddh Linux - Networking 1 08-04-2004 06:56 PM


All times are GMT -5. The time now is 06:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration