LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-26-2004, 04:41 AM   #1
DATA_OK
LQ Newbie
 
Registered: Sep 2001
Location: Stuttgart, Germany
Distribution: Debian (2.6 Kernel)
Posts: 25

Rep: Reputation: 15
SuSe 9.0 --> Start without Xserver? (in console mode?)


Hi,

Iīm looking for the option to start my SuSe 9.0 without the XServer in console mode!
Unfortunatly i didnīt find the option in yast.

Where can I configure this?

Also when KDE starts my first user is logged in. I donīt want that.
How can i change this?


Thanks for help
 
Old 08-26-2004, 04:59 AM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hi there DATA_OK!

Quote:

Iīm looking for the option to start my SuSe 9.0 without the XServer in console mode!
Unfortunatly i didnīt find the option in yast.
Where can I configure this?
To login in text mode, open a terminal, login as root (type "su") and edit your file called "inittab", located at /etc.

You'll find a line like this:
Code:
id:5:initdefault:
Changing the number from "5" to "3" will give you a text login next time you boot into SuSE.
Quote:

Also when KDE starts my first user is logged in. I donīt want that.
How can i change this?
About the user auto-login thing, go to YaST2 >> Security and Users >> Edit and Create Users.
When there, click into your user (the one with auto-login) and choose "Expert Options >> Login Settings". You should be able to turn the auto-login off for this user.

Hope it helps. Good luck!

Last edited by Mega Man X; 08-26-2004 at 05:04 AM.
 
Old 08-26-2004, 05:05 AM   #3
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
Edit the /etc/inittab file, and change the initdefault setting to the runlevel you want. 3 is multi-user with network on SuSE.

I think you can also change the runlevel setting in the “runlevel editor” in YaST but I may be wrong.

I can't remember where the setting to log in the first user is; it's definitely an option in the YaST installler, so I'm assuming it'll be in YaST somewhere. But it only happens if you have a default runlevel of 5 anyway (starting the X server, logging in on boot), so changing the default to 3 will stop this behaviour as well.

By the way, in console mode you can type
Code:
startx
to start X windows.
 
Old 08-26-2004, 05:33 AM   #4
DATA_OK
LQ Newbie
 
Registered: Sep 2001
Location: Stuttgart, Germany
Distribution: Debian (2.6 Kernel)
Posts: 25

Original Poster
Rep: Reputation: 15
Hi,

thanks for your quik answer.

That was a great help. TANKS AGAIN.

some additional infos for people who maybe looking for the same:

1. autologgin:
- the config File is:
/etc/opt/kde3/share/config/kdm/kdmrc
- log in with root in KDE and there is a controll center / system management / loggin management / "make it easy" (sorry bad translation from German, is the last "page") and there is the autologgin button (enable / disable)

2. in yast (with root again) is the register system / runlevel editor / and then set xdm (X Display Manager) to activate "no"

have a nice time.

greetings from the cold Germany

DATA_OK
 
Old 08-26-2004, 05:39 AM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Cool! I'm glad you've also shared info. That's the Linux spirit of sharing

Bitte schön. Vom kalten Schweden
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get debian to start in console mode? nebdy Debian 17 08-17-2005 06:42 PM
Mandrake 9.2's boot process entirely done in console mode before loading in X mode... mishmash Mandriva 6 02-17-2004 10:19 PM
how to start suse linux in shell mode danny1975uk Linux - Newbie 1 01-14-2004 01:55 PM
Boot in console mode or Launch X at start, how to config.? nutshell Linux - General 4 06-01-2002 11:54 PM
Start up in console mode omarswan Linux - General 3 05-21-2002 04:12 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration