LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-06-2003, 09:47 PM   #1
smittycb10
LQ Newbie
 
Registered: Mar 2003
Location: Chicago
Distribution: Suse 8.1 pro
Posts: 21

Rep: Reputation: 15
suse 8.1 integrated Es1869 sound card


Hello I am a hardcore newbie.
I have just insalled suse 8.1 on a compaq 5190. Everything works pretty well except that suse will not reconize my Es1869 sound card, the computer being a crappy compaq has the sound card integrated into the mother board.
I ran lspci and this confirmed that the system is not finding the card.
I have tried manually configuring the card with yast2 also, still no dice.
I searched the forum and tried a few of the things you guys have suggested yet it still does not work.
Suse claims to support this card.
I have a ensoniq pci card which i could install but there appears to be no way of disabling the integrated card in the system BIOS.
What do you think my best option is.
I am running a dual boot with win 98
 
Old 03-07-2003, 11:12 AM   #2
Palin
Member
 
Registered: Feb 2003
Location: A Meatlocker, well feels like one
Distribution: Gentoo
Posts: 292

Rep: Reputation: 30
Have you checked on Alsa yet?

www.alsa-project.org

Helped me get my integrated sound working.
 
Old 03-07-2003, 11:34 AM   #3
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Is ther a BIOS option to disable plug'n'play?
 
Old 03-07-2003, 02:45 PM   #4
smittycb10
LQ Newbie
 
Registered: Mar 2003
Location: Chicago
Distribution: Suse 8.1 pro
Posts: 21

Original Poster
Rep: Reputation: 15
there is no setting to change the pnp os option in the BIOS of this incredibly crappie compaq computer.
I did try alsa and still no luck, it probbed for cards and performed two different searchs, even asked which card to look for.
If I tried agian with yast2 and used the advanced option could I tell it which IO and IRQ settings to use?
Is this the reason why linux cannot see this card or should I just try putting in a PCI card?
 
Old 03-07-2003, 03:06 PM   #5
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
I think that's probably your best option. Try and borrow a simple pci Soundblaster and see if it works, then buy one if it does.
 
Old 03-07-2003, 03:09 PM   #6
Palin
Member
 
Registered: Feb 2003
Location: A Meatlocker, well feels like one
Distribution: Gentoo
Posts: 292

Rep: Reputation: 30
did you try to use win98 to help you figure out what exactly the card is called? this is what i did for my integrated sound card
 
Old 03-07-2003, 03:25 PM   #7
smittycb10
LQ Newbie
 
Registered: Mar 2003
Location: Chicago
Distribution: Suse 8.1 pro
Posts: 21

Original Poster
Rep: Reputation: 15
sound card

windows showed me that the card is a plug and play Es1869,
its a common type of card and is supported by Suse linux. Maybe I will disable it in windows and try putting in a pci card.
 
Old 03-07-2003, 04:24 PM   #8
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
Install the newest alsa-driver.rpm

Run alsaconf

Select your driver, test it and enjoy!

Isa-pnp can be disabled by using Control Centre -> System Administration -> Linux Kernel

Have a lot of fun

Last edited by aherm; 03-07-2003 at 04:27 PM.
 
Old 03-07-2003, 05:52 PM   #9
smittycb10
LQ Newbie
 
Registered: Mar 2003
Location: Chicago
Distribution: Suse 8.1 pro
Posts: 21

Original Poster
Rep: Reputation: 15
I will give this a try, lets keep those digits crossed.
 
Old 03-08-2003, 08:49 AM   #10
AndyJ
LQ Newbie
 
Registered: Feb 2003
Location: Milton Keynes, UK
Distribution: Suse 8.1 Pro
Posts: 10

Rep: Reputation: 0
I had a similar problem. Old PC with a really old SB16 card in it. Suse 8.1. said it couldn't find the card so I set it up manually.

Use the advanced options in Yast 2 and enter the relevant configuration options. TURN OFF any plug and play option as it seems to interfere with your own config items. It took me a while to realise this: I was sure I was entering the right config values but no joy. I was leaving the options that I had no info for alone and when I changed the pnp everything started working.
 
Old 03-08-2003, 04:22 PM   #11
philsta
Member
 
Registered: Feb 2003
Location: Bath England
Distribution: Fedora Core 5, Slackware 10.2
Posts: 38

Rep: Reputation: 15
Have you had a look to see if there is a BIOS update for the PC? If there is you may find you can then turn PnP off. Also check out what module the sound card needs and load it up, that should get your sound working and then all you have to do it uncomment or enter the module name into where ever Suse keeps that information............/etc/rc.modules?
 
Old 03-09-2003, 06:24 PM   #12
smittycb10
LQ Newbie
 
Registered: Mar 2003
Location: Chicago
Distribution: Suse 8.1 pro
Posts: 21

Original Poster
Rep: Reputation: 15
sound card

I finally fixed it, after playing around with alsa and yast2 i decieded to disable the on board card with windows, went out and brought a sound blaster 16 pci, suse picked it up, for some reason installed the drivers for the 128 version....but who cares because it works now phehhhh only took me about a week to sought that out. can anyone recomend a good cd playing module, I am using kde 3.0 .....sorry but I am fresh over from windows!
 
Old 04-02-2003, 03:37 PM   #13
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
noatun is fine, it is integrated nicely with KDE. Just need new skins tho. Get it somewhere at

http://kdelook.org/

xmms is cool too.

Search it here:

http://rpm.pbone.net
www.rpmseek.com


Have a lot more fun :-)
 
Old 07-26-2003, 09:30 AM   #14
mike321
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
I have a Compaq EN 6400 with ESS 1869 on board sound. I had to disable the option ISA-PNP detection (snd-isapnp=0).
Then the YaST2 (at SUSE 8.2) detected the sound correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux and integrated ES1869 audio controller kevinbenko Linux - Hardware 4 06-12-2005 11:35 PM
Es1869 Sound Card: Mute gani Slackware 15 09-26-2004 11:14 PM
ES1869 Sound Card / HSF 5k Modem rehmansherazi Linux - Hardware 1 03-18-2004 08:23 AM
ES1869 Sound Card problem -- Slackware!! HHHHEEEEEEEELLLLLLLLPPPPPPP digiwired Linux - Hardware 3 04-26-2003 07:18 PM
Need help finding a sound card driver (ES1869) calimer Linux - Hardware 3 04-23-2003 02:16 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration