LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-06-2006, 11:09 AM   #1
mrgreaper
Member
 
Registered: May 2006
Posts: 167

Rep: Reputation: 15
suse 10 and tight vnc


ok i started a new thread for this.

i have suse 10 installed and a network of 2 windows pcs 1 windows laptop and a bt wireless network 1250 router

connecting to the internet and the network is now (thanks to the wonderful people here) no problem but the vnc thing that is bugging me

if i type on any browser on another pc http://(my local ip):5801 i get a password prompt then a login prompt then A desktop (not sure if what i do in this satys active when i log out of this for example if i start a bf1942 server and logout does it stay active?)

i downloaded tight vnc and tried to install and it tells me i need sbins/service (after a lot of googling i found suse doesnt use or support that)

now in yast tightvnc is listed as installed but i cant find a link to its configuration in the programms list any ideas how to run the server for it (preferably automaticly at system boot)
but if i tick tightvncserver in yast it says it needs sbin/service

oh i must point out the http way is LIGHTNING fast non of the vnc programms i have tried among the windows machins were that ast i just hope when (or even if) i get tight vnc to work it will be as fast

Last edited by mrgreaper; 05-06-2006 at 12:33 PM.
 
Old 05-07-2006, 03:12 AM   #2
mrgreaper
Member
 
Registered: May 2006
Posts: 167

Original Poster
Rep: Reputation: 15
i`m absolutly desperate to resolve this one remaining problem has any one else had this issue?
 
Old 05-07-2006, 07:23 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Lets see if I can point you in the right direction here:

Quote:
now in yast tightvnc is listed as installed but i cant find a link to its configuration in the programms list any ideas how to run the server for it (preferably automaticly at system boot)
Assuming that Yast is right and tightvnc is already installed, each user will have his/her own configuration file (in /home/user/.vnc/xstartup) that allows each user to tailor what environment they use. I think by default, VNC usually uses twm, which is a horribly minimalist environtment.

To start tightvnc, all you need to do is run vncserver at a command prompt. That should start a vnc session on the first available screen. From the sounds of it, since you are able to connect over port 5801, this must be happening somewhere on your system. By the way, this is using the Java client for VNC and you should remember that NONE of the traffic is encrypted. If you are working across the internet, this is a horrible security problem.
Quote:
not sure if what i do in this satys active when i log out of this for example if i start a bf1942 server and logout does it stay active?
As long as the vncserver for that screen stays active, the session you're working on will be available. That means you can start a session on one computer and then pick it up later from a different computer.

A couple of other things to think about...If you are going to be accessing your vncserver from outside your LAN, do some searching here on how to run VNC over an SSH tunnel. It isn't that difficult to do and it provides good security for VNC.

An alternative to VNC is FreeNX, which natively runs over SSH and is designed to be fast and lightweight.
 
Old 05-07-2006, 11:32 AM   #4
mrgreaper
Member
 
Registered: May 2006
Posts: 167

Original Poster
Rep: Reputation: 15
all this is done over the lan (the server pc is on top of a kitchen cupboaard and its monitier needs to be removed)
every time i do http://(mylocalip):5801/ i get a new login if i close the browser and reload the link its a new login screen, are you saying that when i connect to the computer and log in this way it creates a screen in the server pc and thier is someway of re doing the command to get back to that screen ? i`ve been working on the assumption that if i disconnect or close the window its the same as logging out (and therefore would close any bf1942 servers im running)

i typed vncserver into gnome terminal and it asked for password (which i created) and then said it was running but tightvnc client cant seem to see it im thinking its a port thing but i dont know to be honest

my xstartup file contains
#!/bin/sh
xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &
 
Old 05-07-2006, 01:08 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
every time i do http://(mylocalip):5801/ i get a new login if i close the browser and reload the link its a new login screen, are you saying that when i connect to the computer and log in this way it creates a screen in the server pc and thier is someway of re doing the command to get back to that screen ?
When you log into port 5801, you are connecting to screen :1 (the way vncserver works is that it listens on port 5800 + screen #, so screen :1 listens on 5801, screen :2 listens on 5802, etc.). Any thing that is running on vnc when you disconnect (such as bf1942) should still be running unless you shut down the vncserver. So the next time you connect to 5801, you should see things exactly as you left them when you quit the previous time. Quitting a vnc session is not quite the same as logging out since all you are really doing is closing the client (browser)- server connection. You're not actually shutting down the vncserver itself.

Quote:
typed vncserver into gnome terminal and it asked for password (which i created) and then said it was running but tightvnc client cant seem to see it im thinking its a port thing but i dont know to be honest
When you start a vncserver, you need to remember what screen it is on so you can figure out what port to connect to as I described above.

Now this is the part I don't get. You seem to be able to connect to a vncserver on port 5801 before you start vncserver. That seems to suggest that someone has it running already. Are you the only one using this computer or could someone else have started vncserver?

Quote:
my xstartup file contains
#!/bin/sh
xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &
That looks fine with the exception of the last line. The twm & bit means that when you start vncserver, it is going to use the twm window manager. My personal opinion is that twm is the worst X environtment ever written. If you replace the twm & with the startup command for your favorite X environment, vncserver will use that instead. For example, to use kde, you would enter startkde & and to use fluxbox you would use fluxbox &.
 
Old 05-07-2006, 04:03 PM   #6
mrgreaper
Member
 
Registered: May 2006
Posts: 167

Original Poster
Rep: Reputation: 15
ok this is wierd then
i am the only user of the pc no one lese would access it
i use the same port each time and always have to log in it doesnt renember my settings (not sure why but i assure you i only ever use http://172.16.1.37:5801/ its even bookmarked lol)(no other ports work for me)

the other thing is its the gnome enviroment when i connect is thier another .vnc folder somewhere?

ok i changed it kde as above
went to terminal typed vncserver
it started it as 4
so i did http://172.16.1.37:5804/
it asked a password .....its not the same password as 5801 !!! now it say too many attempts lol im locked out of my pc (over vnc atleast) how do i reset the password ?
i get the feeling that theres a feww too many vnc applications running maybe susee and gnome have one of thier own thats running straight away?

Last edited by mrgreaper; 05-07-2006 at 07:53 PM.
 
Old 05-07-2006, 07:53 PM   #7
mrgreaper
Member
 
Registered: May 2006
Posts: 167

Original Poster
Rep: Reputation: 15
sorry thought i was editing didnt mean to double post
 
Old 05-08-2006, 07:18 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
i am the only user of the pc no one lese would access it
i use the same port each time and always have to log in it doesnt renember my settings
Well, you should have to log in each time, that is the way VNC works. Now, if you leave a program open when you quit VNC, it should be there next time you log in. Is that not happening?

Quote:
the other thing is its the gnome enviroment when i connect is thier another .vnc folder somewhere?
Each user running a vncserver will have their own .vnc folder. Probably the easiest way to figure this out is to log in to port 5801, open a console, and then enter whoami. That will tell you the user that starts that vncserver.

Quote:
it asked a password .....its not the same password as 5801 !!! now it say too many attempts lol im locked out of my pc (over vnc atleast) how do i reset the password ?
No, its not the same password and it shouldn't be. Each user will set their own password for vncserver, so this should be the password you set the first time you ran vncserver as that user. If you need to unlock the password, get into the .vnc directory for that user and delete the passwd file, or just delete the whole .vnc directory. The next time you run vncserver for that user, it will be re-created and will ask you for a new password.
Quote:
i get the feeling that theres a feww too many vnc applications running maybe susee and gnome have one of thier own thats running straight away?
Well, since yours started on screen 4, that means there are 3 other instances of vncserver running. They may not be from different users however. Every time you run the command vncserver, it starts a new session, even if that user already has one running (in other words, the same user can have multiple vnc sessions running). When vncserver starts, it always grabs the first available screen, starting with :1. By the way, if you want to stop a particular vncsession, the command is:

vncserver -kill :X Where you replace X with the screen number you want to start. So to stop your screen :4, the command would be vncserver -kill :4

I suppose it is possible that Suse has set up a vncserver to run by default. That strikes me as a weird thing to do, but I suppose it is possible. Like I said earlier, I would find out which user is running the one on 5801 with whoami and we can go from there.

Last edited by Hangdog42; 05-08-2006 at 07:20 AM.
 
  


Reply

Tags
suse, tightvnc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 9.3 w/ tight VNC and windows. roofninja SUSE / openSUSE 7 04-13-2006 10:07 AM
Tight VNC issue excidy Linux - General 2 04-02-2005 09:40 PM
Tight Vnc on Redhat 9 ®åD\° Linux - Software 2 09-03-2004 08:41 AM
Same session in Tight VNC? fiacobelli Linux - Networking 1 08-07-2004 10:03 AM
Using Tight VNC hornet74 Linux - Networking 4 11-14-2003 10:00 AM


All times are GMT -5. The time now is 08:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration