LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-21-2006, 11:16 AM   #1
dhirsolo
Member
 
Registered: Apr 2005
Location: India
Distribution: RHEL, Fedora Core , SUSE, Ubuntu, etc
Posts: 54

Rep: Reputation: 15
SUSE 10.0 Not Starting X (graphics mode)


Hi

Just installed SUSE 10.0 OSS on my intel 845 chipset based machine.

All the installation was done in graphics mode and my usb mouse was perfectly working well.

But after installation when i log in, it leave me in text mode. And after starting X it gives some errors related to mouse and display and came back to text mode.

How can i start X server(gui)?


Regards

Last edited by dhirsolo; 05-21-2006 at 11:18 AM.
 
Old 05-21-2006, 11:40 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Please, tell us what the errors are!
 
Old 05-21-2006, 12:05 PM   #3
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
The tool in Suse for setting up the video card (and other stuff) is yast or yast2. When you get into text mode, log in as yourself, then do "su" and give the root password. Try typing "yast2" wihout the quotes, and see if you can set up the video card.

For more specific information we need to know the type of video card (NVidia 4200, ATI Radeon, etc.).

It also might be useful if you read through the contents of /etc/X11/xorg.conf. The easy way is to do "cat /etc/X11/xorg.conf" in a shell.

Good luck.

C
 
Old 05-22-2006, 12:40 PM   #4
dhirsolo
Member
 
Registered: Apr 2005
Location: India
Distribution: RHEL, Fedora Core , SUSE, Ubuntu, etc
Posts: 54

Original Poster
Rep: Reputation: 15
Thanks for reply

My configuration is
Monitor = Philips 104B

Video Card = On board Intel chipset 845 With 8 MB shared Ram

Rest 2.44 Ghz Celeron, 256MB Ram, 80GB Hdd.

I tried to run xconfigurator/xconfig and it asked me some questions about monitor and video card (my VGA was not listed there only intel 810 and intel 7xx was listed )

I also tried Simpele VESA But it never worked just screen got blanked even not coming back to text mode like before the last option was to switch off or reset.

Regards

Last edited by dhirsolo; 05-22-2006 at 12:43 PM.
 
Old 05-22-2006, 12:49 PM   #5
jeelliso
Member
 
Registered: Oct 2005
Location: Knoxville, Tn (USA)
Distribution: OpenSUSE, Ubuntu
Posts: 250

Rep: Reputation: 30
Quote:
Originally Posted by Nylex
Please, tell us what the errors are!
Here's an idea - do what Nylex suggested and post the error messages that it is giving you. The X server doesn't really give that many different common error messages. Depending on the error, there may be an easy solution, such as changing the driver, etc.

I'm not trying to sound harsh, but it makes it a lot easier on you and us if we can see your error messages.

~Justin
 
Old 05-22-2006, 12:50 PM   #6
Ryuji Yamazaki
Member
 
Registered: Oct 2004
Location: Singapore
Distribution: Slackware, FreeBsd
Posts: 43

Rep: Reputation: 15
It would be easier to figure out whats wrong if you could post the error message that you received while starting x ,
 
Old 05-22-2006, 01:17 PM   #7
dhirsolo
Member
 
Registered: Apr 2005
Location: India
Distribution: RHEL, Fedora Core , SUSE, Ubuntu, etc
Posts: 54

Original Poster
Rep: Reputation: 15
Hi

I tried Yast and it detect my card. But while running X it displayed the cursor as 'X' and a bright netted screen seems to be working but there is no icon no desktop no bar etc. (i tried it with different color depth i.e 800x600 (VESA) 16 bit and 1024 x 800 24 bit. But same screen appears

Now the exact error displayed is

(WW)I810(0):Failed to setup write cmbining range (0xd0000000,0x8000000)
and two errors related to some missing font files.

Regards
 
Old 05-22-2006, 06:42 PM   #8
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
Do you have any other information about your video card? An Intel 845 chipset is the motherboard chip, not the video chip. This is the information on it:

http://www.intel.com/products/chipsets/845/index.htm

Now you do have X running. That is possibly the TWM window manager you are seeing. Does it have a single window in it? That would be an x terminal. Type something like "xmms" in it and hit Enter. Tell us what happens.

You are closer to making this work. Reboot, and at the command line after you log in (where you usually type "startx") try using "startkde" and see what happens.

Good luck.

C
 
Old 05-23-2006, 02:37 AM   #9
teluguswan
Member
 
Registered: Oct 2005
Posts: 116

Rep: Reputation: 15
I think the same that you need correct drivers of rpm
 
Old 05-23-2006, 12:13 PM   #10
dhirsolo
Member
 
Registered: Apr 2005
Location: India
Distribution: RHEL, Fedora Core , SUSE, Ubuntu, etc
Posts: 54

Original Poster
Rep: Reputation: 15
HI

startx fially run and the all the icons and taskbar are displayed. But there is still a problem is there, it set my monitor frequency to 86Hz which is maximum limit. And the active screen is appearing little shorter then the monitor area. It have a black border around the screen.

I know that my monitor will work fine at 75hz. But in display property it has only one option available indicating 86 hz. How can i reduce this? so the correct image is shown.

Regards
 
Old 05-25-2006, 06:25 AM   #11
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
Can you tell us what you did to make it work?

To reduce the monitor frequency it would be easiest to log in as root, and edit the /etc/X11/xorg.conf file. while logged in as root be careful not to do anything else.

When you are root, open an editor and open /etc/X11/xorg.conf. Immediately save it as /etc/X11/xorg.confWORKING. This is very important. you want a copy of the orking file incase something goes wrong and you have to put it back.

Close xorg.confWORKING, and re-open xorg.conf in the editor. Look for the part of the text that starts with the line "Section "Monitor"", and find these lines:

Section "Monitor"
(alot of otherstuff here)
Identifier "Chinese Monitor"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
EndSection


Your Identifier and ranges will be different. Your 86Mhz should be in those lines.

Change the correct range to 75Mhz and save the file. Use the key combination Control-Alt-Backspace to restart X, and your monitor rate is reset.

Good luck.

C
 
Old 05-25-2006, 12:44 PM   #12
dhirsolo
Member
 
Registered: Apr 2005
Location: India
Distribution: RHEL, Fedora Core , SUSE, Ubuntu, etc
Posts: 54

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by lotusjps46
Can you tell us what you did to make it work?
Hi

Just executed the yast utility and it detect and configure my video card and monitor. First try was a fail because i selected to run on 1024x1200 resolution (it displayed as default) .The screen go blank. But next time i selected 800x600 resolution and it worked.



Regards

One more questions what is diff. between x startx and startkde. on my system only startx is working.

Last edited by dhirsolo; 05-25-2006 at 01:01 PM.
 
  


Reply

Tags
display, startup, xserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
switch text to graphics mode fayax Linux - General 2 11-06-2005 05:36 AM
graphics, starting with new smilies aldimeneira LQ Suggestions & Feedback 10 10-23-2005 05:20 PM
Old-style graphics in terminal mode rs_woods Linux - Software 3 02-10-2005 05:23 PM
Graphics mode in GCC alexiezt Programming 1 01-28-2005 06:56 AM
Booting in text mode versus graphics mode LChalupa Linux - Newbie 3 01-15-2005 07:53 PM


All times are GMT -5. The time now is 08:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration