LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2015, 04:52 PM   #1
muratc
LQ Newbie
 
Registered: Mar 2015
Posts: 3

Rep: Reputation: Disabled
sumo-gui file is not created after installation of sumo-0.22.0 on ubuntu 14.04


Hi Everyone,

I have instaleed sumo-0.22.0 succesfully but there is no sumo-gui.exe file in bin folder. I would be grateful if anyone help me.

Best,
Murat
 
Old 03-03-2015, 05:56 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Welcome to LQ.

Ubuntu 14.04 : Is it a 32bits OS or is it 64bits ?


The executable for "sumo GUI is named 'sumo-gui' . Not sumo-gui.exe
* The package 'libfox-1.6-dev' must be installed to create GUI.

Sumo :
$ sudo apt-get install libgdal-dev libxerces-c-dev libproj-dev libfox-1.6-dev



-

Last edited by knudfl; 03-03-2015 at 10:23 PM.
 
Old 03-04-2015, 04:26 PM   #3
muratc
LQ Newbie
 
Registered: Mar 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
Dear knudfl,

Thank you for quick reply. The OS is 64 bits. I've installed all required packets as libgdal-dev libxerces-c-dev libproj-dev libfox-1.6-dev before sumo installation but the sumo-gui file was not created.
 
Old 03-04-2015, 06:35 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Look for sumo-gui file & link to /usr/bin.
In fact you said it wasn't in /bin check in /usr/bin.
 
Old 03-04-2015, 06:39 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Ubuntu 14.04 - 64bits.

HOWTO sumo-0.22.0 :
$ tar xvf sumo-src-0.22.0.tar.gz
http://softlayer-ams.dl.sourceforge....-0.22.0.tar.gz
$ cd sumo-0.22.0/
$ ./configure
The 'configure' should end with this line for "enabled" :
Enabled: InternalLanes DoublePrecision Subsecond TRACI PROJ GDAL GUI

$ make : No issues here.
$ make install
.... Will result in these files in sumo-0.22.0/bin/ :
{ activitygen dfrouter duarouter emissionsDrivingCycle emissionsMap
trrouter marouter netconvert netgenerate od2trips polyconvert
sumo sumo-gui TraCITestClient }

$ sudo make install
... Then you have the same 14 files in /usr/local/bin/.

*** If you did anything different from the above :
Could have caused your error(s).

-
 
1 members found this post helpful.
Old 03-14-2015, 11:31 AM   #6
muratc
LQ Newbie
 
Registered: Mar 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
The configuration ends with "disabled: PROJ GDAL GUI" although gdal and proj have been installed.
 
Old 03-15-2015, 02:57 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
<<< Ref. #6.

? May be you anyway did something different from post #5 ?

Please start from scratch, and follow #5 strictly.


-
 
Old 05-01-2015, 11:18 PM   #8
phucdv11
LQ Newbie
 
Registered: Oct 2014
Posts: 19

Rep: Reputation: Disabled
Sorry for interrupt,
I'm using ubuntu 14.04-desktop-i386. That is 64 bit right?
and i have install done with MOVE , but Does MOVE have support for SUMO 0.22. or i need to instal MOVE and SUMO with another version?
Please help.
Thank a lot!
 
Old 05-02-2015, 02:54 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Re #8, @phucdv11.

`i386' is a name used by Debian, Ubuntu for historical reasons.
The OS is i686 for 32bits, which is the OS architecture required for ns2.

( The Debian, Ubuntu nick name for 64bits (x86_64) is amd64.)


MOVE / Sumo : The latest update of the Manual still says 'sumo-0.12.3' :
http://lens1.csie.ncku.edu.tw/MOVE/E...ep-by-step.pdf

MOVE : There is one version only, MOVE.jar. And an application.jar requires no install !

Sumo-0.12.3 cannot be built with Ubuntu 12** ... 15*.
Please use the Ubuntu package sumo-bin-0.12.3-u1110_i386.deb ,
ref. the "Sumo INFO" http://www.linuxquestions.org/questions/tags/sumo/
>>> post #72 here http://www.linuxquestions.org/questi...294/page5.html
1) sudo apt-get install libxerces-c28
2) Download 'sumo-bin-0.12.3-u1110_i386.deb', click the package to install it.
3) $ sumo-gui


-

Last edited by knudfl; 05-02-2015 at 04:39 AM.
 
Old 05-04-2015, 10:56 AM   #10
phucdv11
LQ Newbie
 
Registered: Oct 2014
Posts: 19

Rep: Reputation: Disabled
#9, @knudfl
thank you for your time
i have donwload the sumo-bin-0.12.3-u1110_i386.deb and instanll by click( you can see in the picture i have attach)
but when type this
Code:
phuc@ubuntu:~$ sumo-gui
sumo-gui: error while loading shared libraries: libproj.so.0: cannot open shared object file: No such file or directory
it have error like that. what can i do next. please help me.
i have read the #72 you have show me in #9, if you dont mind, could you show me a step to install Sumo on my ubuntu 14.04 to work wiht MOVE.
thank you so much!
Attached Thumbnails
Click image for larger version

Name:	SUMO.png
Views:	29
Size:	23.9 KB
ID:	18354  
 
Old 05-04-2015, 03:51 PM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Re #10.

Post #8 seems to be also about Sumo ?
So if you ever considered building sumo, you would also need the build prerequisites.
... Read this very thread. Read post #2 : $ sudo apt-get install [prerequisites]
 
Old 05-05-2015, 09:30 AM   #12
phucdv11
LQ Newbie
 
Registered: Oct 2014
Posts: 19

Rep: Reputation: Disabled
#10, thank you so much,
i have installed it successfully.
 
Old 10-21-2015, 12:05 AM   #13
Alpa Barad
LQ Newbie
 
Registered: Sep 2015
Posts: 23
Blog Entries: 1

Rep: Reputation: Disabled
hii
I have used ubuntu 14.04 -64bits
I want to install sumo for that can I install sumo-0.24 for win64 bit?
Thank u in advance
 
Old 10-21-2015, 06:14 AM   #14
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Re #13 : "..install sumo-0.24 for win64 bit".

May be ...

Sumo-0.24-svn/src/windows_config.h, line 29 : "This file is for MSVC compilation only."
(But: I have never seen any text / comment from anybody actually building a "Windows sumo".)

*** There is a 64bits binary : sumo-win64-0.24.0.zip >>
>>> http://prdownloads.sourceforge.net/s...0.zip?download
Ref. http://sumo.dlr.de/wiki/Downloads

Getting the latest source ...
$ svn so https://svn.code.sf.net/p/sumo/code/trunk/sumo

-
 
Old 10-22-2015, 11:45 PM   #15
Alpa Barad
LQ Newbie
 
Registered: Sep 2015
Posts: 23
Blog Entries: 1

Rep: Reputation: Disabled
hello sir,
I m working on VANET so i want to create mobility models so that which traffic simulator is better for creating mobility model BONNMOTION or SUMO?
Thank u in advance..
 
  


Reply

Tags
sumo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] sumo,move nd ns2.35 installation in ubuntu 12.4 praveensalagar Linux - Newbie 7 08-20-2014 09:39 AM
installation sumo-0.14.0 on ubuntu 10.10 nourunix Linux - Newbie 2 02-04-2014 11:09 AM
Sumo installation in Ubuntu yashu Linux - Networking 4 04-04-2012 04:53 AM
Sumo simulator gui problem in ubuntu 8.04 vidhoon Linux - Newbie 9 08-30-2011 01:39 PM
SUMO simulator GUI pronlem with ubuntu 8.04 vidhoon Linux - Networking 1 06-01-2010 02:21 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration