LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   sudo googleearth - weird (http://www.linuxquestions.org/questions/linux-newbie-8/sudo-googleearth-weird-638150/)

greengrocer 04-27-2008 06:17 AM

sudo googleearth - weird
 
Hi everyone,

Running Ubuntu Hardy Heron (8.04),

I have just installed Google Earth and have found some weird behaviour with it. Wondering if someone knows the solution.

When I launch Google Earth from either a desktop icon or from the application menu, the Google Earth splash screen appears, then the application appears but then something odd happens. The 'tips' window does not appear and not planet Earth appears. I can see the stars and move around what appears to be the universe, but there is no planet Earth to be found.

Also, the options are all greyed out in the options menu.


BUT...If I type in: sudo googleearth from a command line, then Google Earth works perfectly.

I have tried chmodding /usr/local/google-earth with 777 but that makes no difference. I still find myself having to sudo googleearth.

Strange, hope someone here can help.

Regards,
Greenie

pwc101 04-27-2008 07:01 AM

I think you're seeing the stars and sky because you're in the "sky" mode. Click on View > Switch to Earth. That should get you back to the default setting of looking down, rather than up.

The reason it works OK when you run it with sudo is that you're then running it as root, using root's google earth preferences (which haven't been changed to "sky").

greengrocer 04-27-2008 07:24 AM

Quote:

I think you're seeing the stars and sky because you're in the "sky" mode
No its not. Besides why would all the options be greyed out if that was just the case.

Quote:

The reason it works OK when you run it with sudo is that you're then running it as root, using root's google earth preferences (which haven't been changed to "sky").
No thats not the reason.

I accept that there is a permissions problem somewhere, but I have chmodded all the files directly related to googleearth that I know of, which should resolve permissions problems, but alas, I cannot run Google Earth properly from the applications menu, I can only run it properly by typing sudo googleearth.

Also, when Google Earth appears to be having this problem, it appears that it cannot sign in to the Google Earth server either. But it will sign in when running Google Earth with sudo.

pwc101 04-27-2008 08:27 AM

Have you tried removing ~/.googleearth?

pixellany 04-27-2008 08:34 AM

In the GUI, look at the actual command that is being used--it may be passing some parameters. You can typically see the actual command by rt-clicking on the launcher and going to properties or configure.

greengrocer 04-27-2008 11:39 AM

Looked at the Launcher settings for the icon. No parameters are being passed.

Do you think it could be permissions on a device in /dev that could be causing the problem? It seems it doesn't want to or rather cannot, contact the Google Earth server.

greengrocer 04-30-2008 01:18 AM

After a bit of googling, it appears that other users are also having this problem.

Example, see this thread: http://groups.google.com/group/earth...a0fe2595f18de#

In the above thread, someone mentions to install lib32nss-mdns. But this is in the case of a 64 bit version of Ubuntu.

This package does not exist for the 32 bit version, which package would be the equivalent for the 32bit version of Hardy Heron?

Also hoping that someone else may have seen this problem by now and know of a fix.

anthonyjudd 08-14-2008 07:59 PM

sudo googleearth - wierd
 
Hi found this answer at tombuntu.com.

Here’s how to fix the “only works with sudo” problem
in your homedir, cd .config/Google, then do ’sudo chown [you user name] GoogleEarthPlus.conf’

Next time you run googleearth, it’ll show you an error message about not being able to write to /root/.googleearth, and that it will use your homedir instead…

This worked great for me on Hardy.

Braiinless 08-03-2010 02:19 PM

Quote:

Originally Posted by anthonyjudd (Post 3248021)
Hi found this answer at tombuntu.com.

Here’s how to fix the “only works with sudo” problem
in your homedir, cd .config/Google, then do ’sudo chown [you user name] GoogleEarthPlus.conf’

Next time you run googleearth, it’ll show you an error message about not being able to write to /root/.googleearth, and that it will use your homedir instead…

This worked great for me on Hardy.

It worked for me too. Using Ubuntu 10.04 - the Lucid Lynx

Thanks


All times are GMT -5. The time now is 07:58 PM.