LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2013, 10:51 AM   #1
americast
Member
 
Registered: May 2012
Location: Kolkata, India
Distribution: Ubuntu, OpenSUSE
Posts: 91
Blog Entries: 1

Rep: Reputation: Disabled
Suddenly, no sound in Ubuntu


Hi all,
I have Ubuntu 12.04.3 LTS. Everything worked fine. I had installed wine and yesterday, I started the application 'pockettanks.exe' on my Ubuntu with wine (Pocket Tanks is a simple and small Windows game). After a restart, there is no sound anymore. I have tried re-installing alsa and pulseaudio but in vain. Please help.

Thanx in advance...
 
Old 11-14-2013, 11:31 AM   #2
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Have you had the chance to go into the system settings and select your audio output, I think you can select from there sound out of your headphone jack or from speakers.
 
Old 11-14-2013, 12:02 PM   #3
americast
Member
 
Registered: May 2012
Location: Kolkata, India
Distribution: Ubuntu, OpenSUSE
Posts: 91
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
I tried it but it didn't work. I use speakers in-built into my monitor. But when I plug in my headphone, I can hear sounds. Only my speakers are not working. I had experienced such a problem earlier with Xubuntu 11.10 and that was with the very same game. I think this problem is common with Ubuntu. I can't remember how I had solved the problem...

Thanx...
 
Old 11-14-2013, 12:33 PM   #4
saivinoba
Member
 
Registered: Oct 2007
Distribution: Gentoo, Gentoo ~amd64, Linux Mint 17
Posts: 48

Rep: Reputation: 9
Did you only reinstall alsa or tried to configure it with 'alsamixer'?

I don't know about the game you mentioned, but in my experience, there were instances when I was not been able to set/rectify volume with pulseaudio/default-icon/whatever... in the GUI. However, when I tried 'alsamixer' command I could see some of the controls (Master/Headphone/Speaker/PCM) set to 'MM'. Navigating to those controls and pressing m (to toggle between mute and unmute) which changes 'MM' to '00' and adjusting volume has _always_ worked.

Unless you have already tried, may be your 'Speaker' is set to 'MM'.
 
Old 11-14-2013, 12:55 PM   #5
americast
Member
 
Registered: May 2012
Location: Kolkata, India
Distribution: Ubuntu, OpenSUSE
Posts: 91
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Nope. None of them have MM. All are full volume. I also navigated through the other options by pressing the TAB key. None of them are muted.


Thanx again...
 
Old 11-16-2013, 09:28 AM   #6
americast
Member
 
Registered: May 2012
Location: Kolkata, India
Distribution: Ubuntu, OpenSUSE
Posts: 91
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Now, when I plug in my headphone, I get an unending beep of extremely high frequency...
 
Old 11-16-2013, 11:44 PM   #7
Andre.Smit
LQ Newbie
 
Registered: Nov 2013
Location: Bronkhortspruit
Distribution: SuSE - Kubuntu - OpenWRT
Posts: 22

Rep: Reputation: Disabled
Had many similar sound issues and switched to SuSE after using kubuntu for 5 years. ubuntu/kubuntu has sound issues. I do not say it is not a good OS, but don't feel alone. SuSE has other problems.... BUT I would rather be a penguin fighter than a common sheep {:->)

You might want to look at pulseaudio help on google...
 
Old 11-17-2013, 05:53 AM   #8
saivinoba
Member
 
Registered: Oct 2007
Distribution: Gentoo, Gentoo ~amd64, Linux Mint 17
Posts: 48

Rep: Reputation: 9
Quote:
Originally Posted by americast View Post
Now, when I plug in my headphone, I get an unending beep of extremely high frequency...
I think it's hardware issue. Do you have only Ubuntu on this computer or do you also have other linux/windows. If so can you check if sound is working OK with them? If not can you try with LiveCD? May be you still have Ubuntu CD/USB used for installation. Try in LiveCD mode.

Last edited by saivinoba; 11-17-2013 at 05:58 AM. Reason: laptop->computer
 
Old 11-19-2013, 01:31 PM   #9
americast
Member
 
Registered: May 2012
Location: Kolkata, India
Distribution: Ubuntu, OpenSUSE
Posts: 91
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
So stupid of me not to have tried this before....!!!!

I unplugged my inbuilt speaker socket and plugged it in again... everything solved...!
Sorry for disturbing you guys...

But its true...Ubuntu does have sound problems.... Even I use OpenSUSE..

Thanx...
 
Old 11-19-2013, 06:12 PM   #10
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
americast

can you now mark this post as solved pls?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suddenly no sound nappy501 Linux - Software 13 08-21-2009 09:49 AM
suddenly no sound in kubuntu 9.04 edgjerp Linux - Software 1 05-29-2009 08:25 AM
Ubuntu 8.04 - suddenly no sound tigertim71 Linux - Software 3 03-05-2009 12:53 PM
Sound suddenly not working? Chex Linux - Newbie 5 12-03-2006 04:17 PM
Suddenly sound gone on Ubuntu abeerdey Ubuntu 3 11-06-2006 02:36 AM


All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration