LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2014, 07:21 AM   #1
khaz
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Rep: Reputation: Disabled
Suddenly, I can't log into my session anymore?


Distribution: Elementary OS Luna (based on Ubuntu 12.04 LTS) x64

The computer starts and bring the login screen seemingly without error. If I input my password and hit Enter, the screen flashes black with some text on it, then the login screen comes back. I can't read anything on what may be error messages as it's too brief. It does look similar to the text I have when I shutdown properly.

My session and any other, including guest, are unavailable this way.

I can log into TTY and do whatever needs to be done. When I do login with the command line, no error is printed. I read somewhere on the internet that .xsession-errors may hold a clue as to what may be broken, but I can't decipher it. You can find it here.

I tried using the previous kernel, but it didn't help.

Before it was broken I wanted to connect an ipad to the computer and solve the trust bug. Using the package provided gave me a dependency problem: libusbmuxd2 couldn't be installed on my system, and I went out of my way to download and install an incorrect version of it. It was obviously a dumb move but I'm surprised it broke my system as much as it did. I removed the packages as best as I could but it didn't solve the problem.

I am now clueless as to what I can do. What do you think?
 
Old 04-21-2014, 12:00 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
From the error messages it seems your system is very unhappy with the state of Gnome. Gnome is what you use for a desktop environment, yes? One possibility would be to reinstall gnome and see if that solves the problem.
jdk
 
Old 04-28-2014, 05:20 AM   #3
khaz
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Well, elementaryOS doesn't use Gnome so I'm not quite sure it would solve my problem. From what I can gather from blinking very quickly at the error message it seems the OS can't write something. Is there any place where I can gather log of what's happening at session close (as it seems this is what I'm witnessing, my session closing with errors)
 
Old 04-28-2014, 05:44 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Then I don't understand why the error messages contain repeated references to a gnome-settings-daemon. Do you?
If you're not using gnome then what DE are you using?
jdk
 
Old 04-28-2014, 05:50 AM   #5
khaz
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
It's Pantheon, a new DE specifically made for this project.
 
Old 04-28-2014, 10:43 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Same advice: try a reinstall and see if that changes something. Is it possible that Pantheon is buggy?
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] suddenly ca-cert isn't trusted anymore - msmtp problem? gorillus Slackware 3 09-29-2011 10:47 AM
Suddenly it wont work anymore... brownie_cookie Linux - Newbie 4 04-28-2011 02:55 AM
codecs suddenly don't work anymore theonebeyond Linux - Software 14 07-30-2005 05:43 PM
External serial modem suddenly not connecting anymore kaens Linux - Hardware 2 07-26-2005 11:07 PM
KDE suddenly won't run as user anymore simon.bach Slackware 2 02-29-2004 10:33 AM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration