LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-02-2004, 06:43 PM   #1
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Rep: Reputation: 32
Subdomains


Can some one answer some thing for me please. I am alittle lost, but i'm doing well with Linux. just tried out white box enterprise. which i'm using now.

Subdomains
I have create the VH under the httpd.config file
the sub in question is community.rockinghamgateway.com

ok here is a Q for you.

when surfing to the site, this still works
http://www.rockinghamgateway.com/community/

and this works
http://community.rockinghamgateway.com/

should one beable to see the first link ?,
and yes all links are fix in the phpnuke admin.and set to ( community.rockinghamgateway.com )

would this be because its still with in the /var/www/html/ and should i put that out side the /var/www/html/ then set the permissons

i hope some out there can under stand what i mean !

TT
 
Old 02-02-2004, 07:02 PM   #2
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
It is possible to see both URLs if the DocumentRoot for one is contain within the other (ie /var/www/html and /var/www/html/community).
 
Old 02-02-2004, 07:11 PM   #3
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
I see, so one should create a sub domain out side the root folder.
so only the subdomain link works.

that sound right, just trying to under stand it, the way i see it is, one should not be able to see both links , only the sub domain.

TT
 
Old 02-03-2004, 02:28 AM   #4
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
ok i've been at this a while.

can any one tell me if its right please, or fill me in the why it's wrong if it is.

Step 1.

What i was going to do is create two groups one called midway and the other webbies, then i create two users, add 1st user to midway then do this ( chgrp R midway /path/to/midwayfiles then chmod R g+rw /path/to ) thats for the directory /var/ww/html which is main part of site.

the do the same thing for webbies with a different user, then add user to that group, then i think i have to set each user permissons.if i go more than one account
their folder would be /var/www/vhosts/ so me thinking if i had another say paid user with new domain it would be like so

/var/www/vhost/www.yoursite.com

or

I create my new user ( called midcom ) and add midcom to webbies.
then
mkdir /var/www/vhost/midcom.mydomain.com

then

chown midcom.midcom /var/www/vhost/midcom.mydomain.com

then

chmod 755 /var/www/vhost/midcom.mydomain.com

then under the httpd.config i would add the sub domain to point to that folder

<VirtualHost *:80>
ServerAdmin webmaster@midcom.mydomain.com
DocumentRoot /var/www/vhost/midcom.mydomain.com
ServerName midcom.mydomain.com
</VirtualHost>

me thinks thats right

hope that makes sence ?
any one help please.

TT

Last edited by tommytomato; 02-03-2004 at 06:18 AM.
 
Old 02-03-2004, 09:07 AM   #5
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
I think that you're on the right track. Just be sure to test after each httpd.conf change to make sure that you've got the desire result.
 
Old 02-04-2004, 09:48 AM   #6
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
hi

ok i have got every thing going. when it comes to the subdomain.
you should see the fredora core test page.
http://community.rockinghamgateway.com/

couple of wied things happend.

1 is , surfing here http://community.rockinghamgateway.com/ gives you a Fedora Core test page right !. which i have already edited the lines it says when it pop up here ( http://localhost ). I guess this is some type of error page ? because i didn't put it there, also i have no pages in there yet.

2: the other is when i upload a nuke site nothing shows, if i upload a html file it shows, so i made a index file with only this in it <?php phpinfo(); ?> and it shows all the php info.

even after adding the user and pass to the nuke config file to contect to the database nothing shows.
am i missing some thing ?

TT
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
APACHE and Subdomains basketkase999 Linux - Software 18 05-21-2005 10:38 PM
Apache and Subdomains, Help pzorn Linux - General 2 01-27-2004 07:00 PM
Subdomains papaj Linux - General 7 04-26-2003 04:19 PM
Bind and subdomains jnsc Linux - Software 2 03-01-2003 08:43 AM
Subdomains setting up - help :) Acid_Burn Linux - General 4 12-15-2002 05:10 AM


All times are GMT -5. The time now is 04:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration