LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-01-2012, 05:00 PM   #1
gilly2
LQ Newbie
 
Registered: Oct 2012
Posts: 17

Rep: Reputation: Disabled
su root privileges password in Fedora


I've just installed Fedora Linux 17 as a virtual machine using Parallels Desktop 7 on my MacBook Pro. I have a note at the bottom of the Fedora window which says, "Parallels Tools are outdated. Please reinstall them manually". The Parallels Desktop Help page entitled 'Parallels Tools For Linux' advises me to, "start a terminal in your Linux guest OS. Type the following command to gain the root privileges: su".

I come unstuck after this step as I am asked for a password. I have tried the login password I used when I set up Fedora in Parallels but it didn't work. I'm not sure that I set up any other password that could be the one it's after.

I have tried installing the Parallels Tools by selecting Devices>Parallels in Fedora File, then clicking the 'install file' I then get a window that gives me the option to click 'run' which doesn't seem to do anything. When I choose 'run in terminal' I get the terminal which says 'Error:you do not have permissions to run this script'.

I have an administrator account. I have selected 'none' for the login password so now I don't have to enter a password to log in to Fedora. However the su command is still followed by a request for a password.

By the way I can see the Parallels Tools ISO image file for Linux (prl-tools-lin.iso) sitting at Parallels Desktop>Devices>CD/DVD1 but I don't know how to confirm that it is mounted to the Linux CD/DVD drive.

I would appreciate any assistance but I warn you not to assume that I have much knowledge in any of this.
 
Old 10-01-2012, 10:49 PM   #2
User\ Name=`echo $USER`
LQ Newbie
 
Registered: Oct 2012
Location: Oklahoma
Distribution: Red Hat, Ubuntu, Mac OS X
Posts: 25

Rep: Reputation: 4
You're admin account password is not the same as su. Try the command
Code:
sudo passwd root
This should prompt yout to set the su password.

Be warned - only use su when you are absolutely sure you need it. It makes you "super user," so any command (such as rm) will be executed, no questions asked, which can be very dangerous.

Hope this helps.

Last edited by User\ Name=`echo $USER`; 10-02-2012 at 12:31 PM. Reason: su warning.
 
1 members found this post helpful.
Old 10-01-2012, 11:19 PM   #3
suttiwit
Member
 
Registered: Aug 2012
Location: Chiang Mai, Thailand
Distribution: Kubuntu 12.10 x86_64
Posts: 192
Blog Entries: 2

Rep: Reputation: 22
One wise man once told me:
Quote:
There is no such user as "root" in Mac. Only in Linux!
 
Old 10-01-2012, 11:37 PM   #4
User\ Name=`echo $USER`
LQ Newbie
 
Registered: Oct 2012
Location: Oklahoma
Distribution: Red Hat, Ubuntu, Mac OS X
Posts: 25

Rep: Reputation: 4
Another shortcut I just though of is typing:
Code:
sudo bash
This will prompt you for your user password, and also allow you to become root. If you still need to set the root password after that, while root, just type
Code:
passwd

Last edited by User\ Name=`echo $USER`; 10-02-2012 at 12:34 PM.
 
1 members found this post helpful.
Old 10-02-2012, 08:53 AM   #5
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
Code:
sudo su
is another way to gain access as root.

Quote:
Originally Posted by suttiwit View Post
One wise man once told me:There is no such user as "root" in Mac. Only in Linux!
I am afraid to tell you that the man was not soooo wise...
Mac OS, as every Unix system, does have root user. It is just not enabled by default, see this.
 
Old 10-02-2012, 05:10 PM   #6
gilly2
LQ Newbie
 
Registered: Oct 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
Thank you User\Name='echo$USER'. Although I was advised that sudo was not active by default in Fedora I tried your suggestion of typing in 'sudo passwd root' and it worked. I was able to get to root and change my root pass word. Thank you very much.
 
Old 10-03-2012, 04:42 AM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
fedora dose NOT use "sudo" by default

it can be a major security hole if miss set up

by default fedora uses " su" and " su - "

example
Code:
su -
----- type in your root password when asked ----
yum update
and this for just "su"
Code:
./comfigure --prefix=/usr
make
su
----- type in your root password when asked ----
make install
the TWO do very different things

as to loging in AS ROOT
you do not

at least in the GUI you do not

you CAN login in TEXT ONLY run level3 AS root

edit the boot line in the 3 sec. countdown befor boot and ad a 3 ( a blank space then a 3 ) to the end of the line for the current kernel

but you CAN NOT login to Gnome3 as root

that was DISABLED back in fedora 11 ( with WARNING-- DO NOT DO THIS ) warnings sense fedora8

Last edited by John VV; 10-03-2012 at 04:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Fedora *root password* Jamesq106 Linux - Desktop 11 10-02-2012 05:19 PM
Fedora 16 root Password Lost. Novatian Fedora 6 04-20-2012 02:08 AM
GNOME: Gain privileges using current user's password instead of root's password maxkukartsev Fedora 5 02-10-2012 09:46 AM
Root Password on Fedora 10 Atwin Linux - Laptop and Netbook 7 01-12-2009 05:29 PM
no prompt for root password when program requires su privileges sgmeunier Linux - Software 2 06-26-2006 01:31 AM


All times are GMT -5. The time now is 11:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration