LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-10-2004, 10:17 AM   #1
dinkydarko
Member
 
Registered: Nov 2004
Posts: 42

Rep: Reputation: 15
Stuck in terminal - turned on text desktop by accident


This my sound like a silly question but for someone stuck in windows for so long i have never came had to worry about the terminal b4. However, i have managed to get myself stuck in the greenbackgrounded SuSE 9.1 termial on startup because i turned off the graphical desktop (rather foolishly i know see). Could someone help fix this problem?
 
Old 11-10-2004, 10:19 AM   #2
LoungeLizard
Member
 
Registered: Apr 2003
Location: Tampa, Florida
Distribution: Slackware 10 and happy,Suse,Red Hat, Vector
Posts: 274

Rep: Reputation: 30
in the /etc/inittab change the default runlevel to 5
 
Old 11-10-2004, 10:21 AM   #3
dinkydarko
Member
 
Registered: Nov 2004
Posts: 42

Original Poster
Rep: Reputation: 15
if this works i'll be forever thankfull. i spend 2hours looking at the pretty green terminal window wanting to destoy it.

thanks
 
Old 11-10-2004, 11:00 AM   #4
dinkydarko
Member
 
Registered: Nov 2004
Posts: 42

Original Poster
Rep: Reputation: 15
problem, i'm probly just doing this wrong but when i get to /etc/ and type 'cd inittab' it just says 'permission denied'
 
Old 11-10-2004, 11:25 AM   #5
Ygarl
Member
 
Registered: Mar 2004
Location: London, UK
Distribution: Ubuntu Breezy and Dyne:Bolic
Posts: 64

Rep: Reputation: 15
Hi!
Fellow Newbie here....

inittab is a file (sorry - it's the standard way files are written in Linux...)

You'll have to edit using vi or whetever editor you're familiar with. Or be really lazy and copy the file to your Windoze partition, change in on notepad and copy it back.

But that's just being REALLY noob! ;-)

Good luck - it's easy to change though.

P.S. if you want to get to the desktop, type startx - should work straightaway.
 
Old 11-10-2004, 11:30 AM   #6
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 66
inittab is not a directory, so you are not likely to have directory-change permissions on it. Edit the inittab file using an editor like nano.

Alternatively, type
Code:
startx
to get back to a GUI (this will only work until the next reboot).
 
Old 11-10-2004, 11:31 AM   #7
ror
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 583

Rep: Reputation: 33
NEVER use windows editors to change UNIX text files, especially system files.

Also, you'll have to be root to edit the file.
 
Old 11-10-2004, 11:58 AM   #8
dinkydarko
Member
 
Registered: Nov 2004
Posts: 42

Original Poster
Rep: Reputation: 15
startx didnt work as there was some problem with a link to a bin in /ver/X11R6/bin/x i think
how do u edit in the terminal? edit inittab ?
 
Old 11-10-2004, 12:04 PM   #9
ror
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 583

Rep: Reputation: 33
use vi or pico or one of the many many console edittors.
 
Old 11-10-2004, 12:11 PM   #10
dinkydarko
Member
 
Registered: Nov 2004
Posts: 42

Original Poster
Rep: Reputation: 15
tried typing 'pico inittab' in /etc/ and just got the command error message
 
Old 11-10-2004, 12:16 PM   #11
ror
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 583

Rep: Reputation: 33
try full paths, pico /etc/inittab as root should do it.
 
Old 11-10-2004, 12:25 PM   #12
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
if you cannot use startx, this probably means something is wrong with your X-windows.

try:
telinit 5
or:
init 5
if you get errors you can't use graphical mode (5), and it's pointless to edit inittab.

if you can use graphical mode login as root and alter the inittab.

pico is not the de-facto editor of linux.
you need to have pine installed in order to have pico.

better learn how to use vi.

What kind of error do u get?
 
Old 11-10-2004, 12:38 PM   #13
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Hi dinkydarko!

You could also change the runlevel using yast:

login as root
type 'yast'
select 'system' 'runlevel-editor'
change to 'expert-mode' (Alt+highlighted key)
select runlevel 5 as default runlevel
exit yast
type init 5

the netxt reboot you should get automatically into graphical mode

Maybe the options are named a little different, I do not have an english version right now.
 
Old 11-10-2004, 12:39 PM   #14
dinkydarko
Member
 
Registered: Nov 2004
Posts: 42

Original Poster
Rep: Reputation: 15
Post

i'll try going into a little more detail about the problem.
I was getting an error mesage on start up SuSE 9.1 telling me that my monitor wasnt reporing x values which might cause problems. i went into Yast and reprobled my graphics settings and then (foolishly) told it to use text decktop instead (learn from errors). at the time it told me i could change this but i was too fast with my clicking to read how. now it starts in run level 3.

when i try 'startx' i get the error message i mentioned above about the link not working,
i dont think i have pico or any other editor as having tried all the onese mentioned i get the same error message, commmand unregognised or soemting alson those lines. help
 
Old 11-10-2004, 12:52 PM   #15
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Strange since pico is usually a standard console editor in suse. What do you get when you just type pico? But anyway, you may also re-configure your graphics using yast -> hardware -> graphics (or what ever it is called in english).

But if startx doesn't work, there might be another problem. Could you post the exact error message please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching back to the Mandrake 9.1 desktop from terminal rdesktop terminal session marc218 Linux - General 6 02-08-2007 02:45 PM
vt text terminal offworld Linux - Networking 10 01-16-2006 01:26 PM
chsh accident; big accident. shinystuffrox *BSD 3 06-06-2005 07:06 AM
ls to text in terminal oldstinkyfish Linux - Software 2 12-04-2004 04:18 AM
How to open programs in terminal without being stuck to the terminal?? brynjarh Linux - Newbie 6 07-07-2004 12:52 PM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration