LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2009, 12:51 AM   #1
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
strange ssh problem


Hi all..

I am able to start qemu hypervisor in my local machine, But when i try to start it from other host by loging in to my system through ssh it will display following error why is it so...
Code:
Could not initialize SDL - exiting
Can anyone please help me...

Thanks in advance
 
Old 10-14-2009, 07:50 AM   #2
PEdroArthur_JEdi
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware | Debian
Posts: 17

Rep: Reputation: 1
Hello there

It's a simple problem. SDL is a lib used to render 3D graphics and sound effects. So, it cannot be used across a SSH session cause you will not have access to a framebuffer device by this media.

To bypass this limitation, you must just add "-nographic" at the QEmus initialization's command line. By this, QEmu will not use VGA output, but instead it will act as a standard console application.

Hope I helped you...
 
Old 10-14-2009, 10:18 AM   #3
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Great PEdroArthur_JEdi ...

Worked well but when i execute

Code:
qemu -nographic -hda /soft/fedora_qemu/fedora.img
Got an error

Code:
Could not open '/dev/kqemu' - QEMU acceleration layer not activated: No such file or directory
and /dev/kqemu is not there in my system...How can i continue with this...

Please help me....
 
Old 10-14-2009, 11:43 AM   #4
PEdroArthur_JEdi
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware | Debian
Posts: 17

Rep: Reputation: 1
For using KQEmu, you processor must have the VT (for Intel processors) or the AMD-V (obviously, for AMD processor) instruction set to work properly. If you got one of these two technologies, you may enable the KQEmu by loading the KVM kernel's module:
Code:
# modprobe kvn
And now, you may start QEmu again without seeing the error message.

If you don't have processor with any of these two instructions set, you may still using QEmu, but with little performance. And the message you continue to show every time you start QEmu.
 
Old 10-15-2009, 01:54 AM   #5
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Thanks a lot...for your reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
strange problem in ssh lin2winwin Linux - Networking 2 12-26-2007 06:56 AM
Strange SSH problem graw Linux - Networking 6 12-15-2004 05:47 PM
strange ssh problem yull Linux - Security 8 12-11-2004 03:58 PM
Strange ssh problem Inexactitude *BSD 2 04-05-2004 02:37 PM
Strange! SSH and Telnet login problem McSmooth Linux - General 7 10-03-2003 10:24 AM


All times are GMT -5. The time now is 10:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration