LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2005, 05:50 PM   #1
ExCIA
Member
 
Registered: Mar 2005
Posts: 78

Rep: Reputation: 15
Strange permission issue. Problems changing ownership.


I'm running Debian 'Sarge' with 2.6.8-2-k7 kernel and I'm using Gnome.

After I created a new user account, I cannot use the USB drive (USB pen) that is on the desktop, which kept saying I don't have permission.

I even login as 'root' hoping to change permissions without any success. I noticed that the USB drive belong to another user name 'john' and even if I login under 'john' I cannot change permissions. It kept saying that I am not the owner.

I don't know what to change in the 'group' file and I'm wondering it is the 'plugdev' that I need to add the user name 'john' in order to use the USB device?
 
Old 05-24-2005, 05:55 PM   #2
Mr. New
Member
 
Registered: Oct 2004
Distribution: Kubuntu and Mac OS X
Posts: 80

Rep: Reputation: 15
it might have something to do with fstab, maybe add a line for it in there?
this is just a guess though
 
Old 05-24-2005, 07:07 PM   #3
ExCIA
Member
 
Registered: Mar 2005
Posts: 78

Original Poster
Rep: Reputation: 15
Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               reiserfs notail         1       1
/dev/hda5       none            swap    sw              0       0
/dev/hda7       /media/backup   auto    defaults        1       2
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sda        /media/usb0     auto    rw,user,noauto  0       0
I can access the USB device under 'root' or 'john', but when I created another account and I can't access it since it kept saying "you don't have permission to view the content".

I'm sure I must add something into the 'group' file, but I don't know which?

Last edited by ExCIA; 05-24-2005 at 07:09 PM.
 
Old 05-24-2005, 09:55 PM   #4
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
Don't you normally add a umask command to the options line in fstab to set user permissions? Something like umask=002 ought to do it. Check out "man umask"
Cheers!
 
Old 05-25-2005, 04:36 AM   #5
ExCIA
Member
 
Registered: Mar 2005
Posts: 78

Original Poster
Rep: Reputation: 15
But I don't understand why I am not able to access the USB device, which I assumed that it is default for any users to access it. I mean any users can access the CD-ROM drives no problem so why not the USB device?

In my 'Computer' folder, I have usb0, usbdisk and usbdisk-1.

usbdisk and usbdisk-1 can vanish if you remove the usb device like the usb pen, usb0 stays.

I don't see usbdisk or usbdisk-1 in fstab file maybe because it is not a permanent device?

Last edited by ExCIA; 05-25-2005 at 05:34 AM.
 
Old 05-25-2005, 04:36 AM   #6
piggyaugu
LQ Newbie
 
Registered: May 2005
Posts: 24

Rep: Reputation: 15
Unhappy

I have the same problem(on ubuntu hoary 5.04) with the usb drivers. Especially with the ntfs partitions on usb HD. Changing in the fstab seems not working. always confused

Last edited by piggyaugu; 05-25-2005 at 01:11 PM.
 
Old 05-26-2005, 05:17 AM   #7
ExCIA
Member
 
Registered: Mar 2005
Posts: 78

Original Poster
Rep: Reputation: 15
Since members in here aren't smart enough , just got some advices from another linux forum and here is the solution to the problem:

- since usbdisk and usbdisk-1 are non-permanent devices, it is part of a group called hal (Hardware Abstrast Layer)

- simply add users to the hal group by using the adduser <username> hal command

- that it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
changing the ownership djh Slackware 3 11-08-2004 05:16 AM
Ownership/Permission and Delete Syntax MadDogE134 Linux - Newbie 8 06-09-2004 07:05 PM
scp - peserve file ownership and permission eyt Linux - Newbie 6 10-24-2003 04:41 PM
somes strange problems : permission freenet Conectiva 5 07-13-2003 02:41 PM
permission or ownership problems trusouthrnplaya Linux - General 6 03-03-2002 04:33 PM


All times are GMT -5. The time now is 02:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration