LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-03-2006, 03:16 AM   #1
_Lukes
LQ Newbie
 
Registered: Jun 2006
Location: Bedzin, Poland
Distribution: Debian
Posts: 16

Rep: Reputation: 0
Strange locale setting problem


Hi,

I'm trying to deal with this problem for few days but now I surrender. Few day ago I've noticed that some of my programs (xmms, aptitude, nano etc.) are in english, weird thing is that I use polish locale from the beginning. I also cannot change language in kcontrolcenter. It's quite annoying that it doesnt work as it should be To make everything clear:
in /etc/environment I have: LANG="pl_PL.UTF-8"; LANGUAGE="pl_PLl" locale generate without any error and dpkg-reconfigure locale doesn't return any error. Same thing is for ISO-8859-2. I've already done this for 1000 of times and result is still the same - English.

Maybe you know what is the problem ??
 
Old 12-05-2006, 04:31 AM   #2
noranthon
Member
 
Registered: Apr 2006
Location: Australia
Distribution: PCLinuxOS with Xfce
Posts: 301

Rep: Reputation: 30
I don't know how locale works. Not really. Is it possible that you have English versions of the software?

The latest Thunderbird persists in displaying dates in the American fashion mm/dd/yy, regardless of my locale settings. I have had to use a script to launch Thunderbird and the script contains an export command prior to the line containing the executable.

EDIT: Adding .UTF-8 to my LANGUAGE setting plays havoc with some characters. I now have it added only to the LANG setting where it seems to do no harm.

Last edited by noranthon; 12-05-2006 at 04:40 AM.
 
Old 12-05-2006, 06:14 AM   #3
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 55
And what do you have in ~/.profile (which is sourced after so might override /etc/profile)
?
Also what version of debian are you running?

I would also suggest that you give a try to the package language-env

Package: language-env
Priority: optional
Section: misc
Installed-Size: 1484
Maintainer: Tomohiro KUBOTA <kubota@debian.org>
Architecture: all
Version: 0.68
Replaces: user-ja (<< 0.29)
Depends: perl, locales, debconf-i18n | debconf-2.0
Recommends: ncurses-term, wish
Conflicts: user-ja (<< 0.29)
Filename: pool/main/l/language-env/language-env_0.68_all.deb
Size: 181902
MD5sum: 24fe40d86f5edef6b183e91b61e35ed6
SHA1: 4e9f8935de49615f1b4d14db4e140f314774715c
SHA256: df6617129e5cd0ea96fed9d25a08a6f7b796900b6b2ff373f8e267c837995ba5
Description: simple configuration tool for native language environment
This tool adds basic settings for natural language environment such as
LANG variable, font specifications, input methods, and so on into
user's several dot-files such as .bashrc and .emacs.
.
This version of language-env supports Belarusian, Bulgarian, Catalan,
Danish, French, German, Japanese, Korean, Lithuanian, Macedonian, Polish,
Russian, Serbian, Spanish, Thai, Turkish, and Ukrainian.
Tag: admin::configuring, culture::bulgarian, culture::catalan, culture::danish, culture::french, culture::german, culture::japanese, culture::korean, culture::polish, culture::russian, culture::serbian, culture::spanish, culture::turkish, culture::ukrainian, devel::i18n, interface::commandline, made-of::lang:perl, use::configuring
Task: arabic, belarusian, bengali, catalan, cyrillic, danish, french, german, greek, hindi, italian, japanese, korean, lithuanian, macedonian, norwegian, persian, polish, punjabi, romanian, russian, spanish, thai, turkish, ukrainian

Last edited by nx5000; 12-05-2006 at 06:24 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
"perl: warning: Setting locale failed." System wide problem Darek84CJ Debian 3 01-25-2006 05:22 PM
Strange Debian/Firefox locale problem... fannymites Debian 2 04-04-2005 06:12 PM
locale setting ’ mnaumanca Linux - Software 0 02-18-2005 03:39 PM
strange locale warnings in Mandrake 10.1 Mistreated Linux - Software 1 02-09-2005 10:40 AM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration