LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-11-2009, 07:58 PM   #1
reg.doug
LQ Newbie
 
Registered: Aug 2009
Location: Very far north
Distribution: openSuSE, Arch
Posts: 14

Rep: Reputation: 0
Strange lib -- libcups.so.2;4a6f870a -- causing ldconfig errors


Please read this thread as it is in some ways similar to my error.

The main difference is that while Andronik was able to delete and reinstall libs to fix his problem, I am not sure that it will work for me. When I examine /usr/lib I see that I have a normal libcups.so.2 as well as the strange 0KB libcups.so.2;4a6f870a.

I am using TinyMeLinux 2008.1 "Droplet" and have had this error ever since installing CUPS.

I am truly a linux noob (only 1.5 months with linux) and do not want to wreck my system by doing something stupid.

Any advice would be appreciated

Thanks in advance

Reggie
dominic+k+92 at inbox dot com (remove +; replace dot and at)

Last edited by reg.doug; 08-11-2009 at 08:00 PM.
 
Old 08-12-2009, 01:01 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,761

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
If you're afraid to delete the offending lib, move it somewhere else (e.g. to your homedir). After that run ldconfig (as root) and see if it stops complaining.
 
Old 08-12-2009, 03:49 PM   #3
reg.doug
LQ Newbie
 
Registered: Aug 2009
Location: Very far north
Distribution: openSuSE, Arch
Posts: 14

Original Poster
Rep: Reputation: 0
Thank you very much! ldconfig no longer complains!
 
  


Reply

Tags
ldconfig


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange current errors from ldconfig bgeddy Slackware 2 05-19-2009 06:50 PM
Slackware current - ldconfig: /usr/lib/libsmbclient.so.0 is not a symbolic link Woodsman Slackware 5 10-14-2008 07:58 PM
ldconfig /usr/local/lib/ is not a symbolic link gbowden Slackware 3 05-21-2006 08:15 PM
/sbin/ldconfig: /usr/lib/libgtkhtml-3.0.so.2 is not a symbolic link rosariowong Slackware 13 04-29-2005 03:41 PM
YUM causing strange /var/log/security errors???? zepplin611 Linux - Security 4 07-20-2004 06:10 PM


All times are GMT -5. The time now is 09:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration