LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2009, 12:40 AM   #1
kalevionni
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
Strange keyboard input issue in Xorg


This might be an easy problem for the experienced gurus here.

I have installed a base Ubuntu 8.10 using the minimal install CD on an eeepc. Then xorg, slim display manager and fluxbox. Then the "array" kernels for eeepc.

When slim starts after booting, there is no keyboard input at all. I have tried to diagnose the problem, and removed slim and after a startx I still hadn't got any keyboard input. Only after closing the X session I have realized that all my keyboard input I have typed duing the X session appeared on the CTRL+ALT+F7 (tty7?) screen.

How can I fix this?

The issue persists regardless of the kernel I use (I have kept the original generic kernels)

Here is my xorg.conf:
Code:
Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"synaptics"
	Option		"SHMConfig" "true"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Configured Mouse"
EndSection

Section "InputDevice"
	Identifier	"keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection
 
Old 02-25-2009, 12:52 AM   #2
kalevionni
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Found a fix here:
http://linux.derkeiler.com/Mailing-L.../msg02190.html


Sorry for the fuss
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sid Users - Beware of Xorg 7.3 (xserver-xorg-input-evdev) bug rickh Debian 4 10-24-2007 04:30 AM
Repeated "input: AT Translated Set 2 keyboard as /class/input/input" messages AcerKev Mandriva 2 09-16-2007 09:35 AM
Gentoo - Keyboard issue in Xorg 6.8.2 bharath_ramesh Linux - Distributions 2 10-31-2005 08:38 PM
Strange issue with a logitech cordless keyboard. Linux.tar.gz Linux - Hardware 1 05-22-2005 01:46 PM
my mouse input is takes as keyboard input in BASH e1000 Slackware 5 12-08-2003 04:00 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration