LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 11-13-2002, 12:47 AM   #1
nero64
LQ Newbie
 
Registered: Nov 2002
Location: My bedroom
Distribution: RH 7.1
Posts: 29

Rep: Reputation: 15
stopping and starting services


Hi everyone.

I have installed Red Hat 7.1 and i am studying for the Linux+ exam. I don't know much but i heard this exam is a basic level exam.

My book tells me that to stop and start a service you do the following:

#./dhcp stop
#./dhcp start

when i do it i get no such file or directory error

I am logged in as root
 
Old 11-13-2002, 12:58 AM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
for dhcp, it should be:

/usr/sbin/dhcpd

And to enable it on startup, run this:

chkconfig --level 345 dhcpd on

Now, I don't why dhcpd can't be controlled by using the /sbin/service command (ie. service dhcpd start/stop/restart) or by /etc/init.d/dhcpd start/stop/restart) but most services can be controlled using the service command

# for xinetd
/sbin/service xinetd start/stop/restart

# for mysqld
/sbin/service xinetd start/stop/restart

# for httpd
/sbin/servie httpd start/stop/restart

Some services are xinetd controlled (not standalone services) and for this services, enabling them under the corresponding files in /etc/xinetd.d/ and then restart xinetd will make them accessible. Like for wu-ftpd, to enable, edit /etc/xinetd.d/wu-ftpd and set the the 'disable=yes' to 'disable=no' and then restart xinetd:

/sbin/service xinetd restart

Or, the easiest way is:

/sbin/chkconfig wu-ftpd on

no need to restart xinetd here. once an ftp connection is made, only then you should see an ftp daemon running.
 
Old 11-13-2002, 01:00 AM   #3
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 194Reputation: 194
Have you tried the full path to it ?? And usually the dhcp has a d at the end like this:

dhcpd stop or start
 
Old 11-13-2002, 01:10 AM   #4
mayankjohri
Member
 
Registered: Mar 2002
Location: INDIA
Distribution: Mandrake Linux 9.2, Knoppix 3.0
Posts: 158

Rep: Reputation: 30
Thumbs up try this

the files you are trying are normally localted in /etc/rc.d/init.d/ folders

mayank johri
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
starting/stopping services in debian Red Squirrel Linux - Software 8 03-09-2009 02:21 PM
starting & stopping services/daemons rand0mh3ro Linux - General 4 02-16-2005 08:27 AM
disabling stopping services ganxteh Fedora 6 12-17-2004 10:24 PM
stopping services? piglingz Linux - Software 3 06-24-2003 04:26 PM
Starting / Stopping / Restarting Services in VA Linux? abell Linux - General 1 11-15-2002 01:17 PM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration