LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2005, 08:57 AM   #1
toolmania1
LQ Newbie
 
Registered: Jun 2005
Posts: 10

Rep: Reputation: 0
stop windows xp from mounting my linux partition


I have installed linux red hat 9.0 on one partition and windows xp on another partition on the same hard drive. Sometimes, Windows xp will not boot and will complain about an unmountable boot volume. It was suggested to tell windows to stop booting the linux partition. I went into the adminstrative tools in windows, but I could not find where to tell windows to stop mounting the linux partitions. Where can I do this in windows? (Windows works some of the time and linux works all of the time)
 
Old 06-15-2005, 09:29 AM   #2
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 47
Quote:
Windows works some of the time and linux works all of the time
We know that--that's why we use GNU/Linux
(sorry)

Quote:
It was suggested to tell windows to stop booting the linux partition

<snip> could not find where to tell windows to stop mounting the linux partitions.
Well, booting and mounting are essentially unrelated--can you tell me which one you mean?

Exactly how do you boot into windows? (which bootloader, which options, which config files ...)
How do you boot Linux?

At which step does the error occur?

Fiddling with the windows NT bootloader generally means editing C:\boot.ini

--Jonas
 
Old 06-15-2005, 10:04 AM   #3
toolmania1
LQ Newbie
 
Registered: Jun 2005
Posts: 10

Original Poster
Rep: Reputation: 0
The Windows XP screen will show for about 2 seconds and then reboot itself (unless windows decides to load up that time). I was told to tell windows to stop trying to mount the linux partition. Supposedly, that option is in control panel -> admin tools -> computer management somewhere. But, I cannot find where to shut off the partitions from being mounting in windows. That is all I need to know and I will be good to go.
 
Old 06-15-2005, 10:52 AM   #4
trevelluk
Member
 
Registered: Nov 2003
Location: Bristol, UK
Distribution: Debian Lenny, Gentoo (at work)
Posts: 388

Rep: Reputation: 32
Control Panel -> Administrative Tools -> Computer Management

Expand the "Storage" entry in the tree on the left, and select the "Disk Management" option. Right click the offending partition, and select "Change Drive Letter and Path" from the popup menu. Highlight the entry in the popup box displayed, and click "Remove"

I should point out that this problem may be caused by something else entirely - just don't ask me what (possibly your bootloader settings?)
 
Old 06-15-2005, 12:02 PM   #5
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
You can also change mount options through My Computer -> Network Drives IIRC
 
Old 06-16-2005, 10:01 AM   #6
toolmania1
LQ Newbie
 
Registered: Jun 2005
Posts: 10

Original Poster
Rep: Reputation: 0
For some reason, when I went into the disk management, windows would not allow the "change drive letter" option to be selected. It was greyed out. The only option it will let me do is to delete the partition. This is very odd. Also, in the boot.ini it only lists Windows as the operating system. I also forgot to mention that I used grub to set up linux. So, the boot.ini file looks to be ok. Why windows will not let me change the drive letter on the linux partitions, I am not sure????
 
Old 06-16-2005, 10:03 AM   #7
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Post you /boot/grub/grub.conf or /boot/grub/menu.lst (whichever file you have). That's what we need to help
 
Old 06-16-2005, 10:06 AM   #8
trevelluk
Member
 
Registered: Nov 2003
Location: Bristol, UK
Distribution: Debian Lenny, Gentoo (at work)
Posts: 388

Rep: Reputation: 32
The chances are that you've got a different problem then. The reason why you can only select "delete" is that Windows can't read the partition, and so doesn't let you do anything with it. I suspect that your bootloader settings may be the issue (not the Windows bootloader, but either GRUB or LILO). IIRC, RH9 uses GRUB, so the relevant file should be /boot/grub/menu.lst

Post that here, and someone should be able to spot the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting windows partition in linux prince_linux Red Hat 1 10-20-2005 03:16 AM
Mounting windows partition drguitarum2005 Linux - General 15 02-28-2005 03:53 AM
mounting linux partition on windows xp nitinbilly General 6 01-24-2005 11:20 PM
mounting a windows partition? codename000 Linux - Newbie 1 04-15-2003 09:27 PM
Mounting Linux partition in Windows? hitesh_linux Linux - General 7 10-29-2002 03:34 AM


All times are GMT -5. The time now is 05:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration