LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2014, 10:59 AM   #1
Brant
Member
 
Registered: Oct 2007
Posts: 93

Rep: Reputation: 5
stop Firefox saving tabs


Whenever I update my system it seems inevitable that Firefox insists on saving my tabs, regardless of the settings I choose in Preferences.

By now I am used to going to About:Config and changing the various browser settings to "False". I confess to being puzzled that this bug never seems to go away. but it seems a small price to pay for a program like Firefox.

However on my latest upgrade—to Linux Mint 16—that solution does not work.

The most recent posts I have found on the subject either talk about deleting a user.js file—see:
https://support.mozilla.org/en-US/questions/962971

or say that one can enter that file with a text editor and change the settings shown there.

I haven't tried deleting a file yet (it seems a bit drastic).
When I opened the file with the text editor it opened "Read-Only". Reading it, it certainly shows the browser settings (that I have changed to "False" in About:Config") as "True".

Aside from this problem simply being so much more stubborn than in the past, I find it interesting that on start-up, it is always my original tabs it restores, not the ones from the latest session. I don't think it was doing that before—but then, in past years I usually had the problem dealt with within minutes.

I will be grateful for any suggestions.
 
Old 03-12-2014, 06:04 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
There is an option in the tools menu to Save Private Browsing. That saves the current tabs for viewing later. If you knowingly, or unknowingly, created such a session, that might be the cause of the problem.

Quote:
I haven't tried deleting a file yet (it seems a bit drastic).
Deleting the file is seldom necessary. Just rename it (adding one character is enough). If that doesn't cure the problem, rename the file to its original name.
 
Old 03-13-2014, 02:57 PM   #3
Brant
Member
 
Registered: Oct 2007
Posts: 93

Original Poster
Rep: Reputation: 5
I am running Firefox 27.0.1. Mozilla Firefox for Linux Mint; mint-1.0.
I see nothing in Tools (or Edit>Preferences) about Save Private Browsing.
I have marked "Never Remember History" in Edit>Preferences>Privacy.

I went and had another look at lib/firefox/browser/defaults/preferences/vendor-firefox.js but it would not allow itself to be renamed (I presume because it is read-only).
 
Old 03-13-2014, 03:36 PM   #4
MARogue
Member
 
Registered: Jul 2011
Location: USA
Distribution: Ubuntu 12.04 , Debian "Wheezy"
Posts: 56

Rep: Reputation: Disabled
Quote:
When I opened the file with the text editor it opened "Read-Only". Reading it, it certainly shows the browser settings (that I have changed to "False" in About:Config") as "True".
You may trying to open the file with administrator (sudo) privileges. That may allow you to write to the file and change settings.

Regards
 
Old 03-14-2014, 08:09 PM   #5
Brant
Member
 
Registered: Oct 2007
Posts: 93

Original Poster
Rep: Reputation: 5
This problem seems to be solved—although it was easier than I had expected, which always makes me suspicious.
I went Firefox>Help>Troubleshooting Information and did a reset, with the intention of starting over, and replacing my add-ons after (Adblocker, Ghostery, DownloadHelper).

I cleared recent history, then set Preferences to "Never Remember History" and then closed Firefox. Very much to my surprise, it did not ask if I wanted to save tabs, and it did not save tabs. I replaced my add-ons, and Firefox continues to be on good behaviour.

An unexpected bonus was finding that the Multi-column bookmarks add-on seems to be compatible with this version of Firefox. My cup runneth over.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Saving multiple tabs on Iceweasel 4.0x jdkaye Debian 18 05-23-2011 04:05 AM
Firefox Now like IE with tabs wavesound General 11 01-27-2007 01:24 PM
firefox + tabs alaios Linux - General 5 07-18-2005 02:22 PM
Konqueror opens new tabs in firefox - how do I stop this Ebel Linux - Software 2 06-09-2004 05:11 PM
Galeon won't stop loading tabs! je_fro Linux - General 3 03-17-2003 05:27 PM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration